diff options
Diffstat (limited to 'meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb')
-rw-r--r-- | meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb b/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb new file mode 100644 index 0000000000..c4126a41fc --- /dev/null +++ b/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Check that create_cmdline_shebang works" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
4 | INHIBIT_DEFAULT_DEPS = "1" | ||
5 | |||
6 | SRC_URI += "file://test.awk" | ||
7 | |||
8 | EXCLUDE_FROM_WORLD = "1" | ||
9 | do_install() { | ||
10 | install -d ${D}${bindir} | ||
11 | install -m 0755 ${WORKDIR}/test.awk ${D}${bindir}/test | ||
12 | sed -i -e 's|@AWK_BIN@|${bindir}/awk|g' ${D}${bindir}/test | ||
13 | create_cmdline_shebang_wrapper ${D}${bindir}/test | ||
14 | if [ $(${D}${bindir}/test) != "Don't Panic!" ]; then | ||
15 | bbfatal "Wrapper is broken" | ||
16 | else | ||
17 | bbnote "Wrapper is good" | ||
18 | fi | ||
19 | } | ||
20 | |||
21 | BBCLASSEXTEND = "native" | ||