diff options
Diffstat (limited to 'meta-rt/recipes-kernel')
-rw-r--r-- | meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb new file mode 100644 index 0000000000..c8a175dad8 --- /dev/null +++ b/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | inherit kernel | ||
2 | require recipes-kernel/linux/linux-yocto.inc | ||
3 | |||
4 | KMACHINE = "common-pc" | ||
5 | KMACHINE_qemux86 = "common-pc" | ||
6 | KMACHINE_qemux86-64 = "common-pc-64" | ||
7 | KMACHINE_qemuarm = "arm-versatile-926ejs" | ||
8 | KMACHINE_qemuppc = "qemu-ppc32" | ||
9 | KMACHINE_qemumips = "mti-malta32-be" | ||
10 | |||
11 | KBRANCH = "yocto/standard/preempt-rt/base" | ||
12 | KMETA = meta | ||
13 | |||
14 | LINUX_VERSION ?= "3.0" | ||
15 | LINUX_KERNEL_TYPE = "preempt-rt" | ||
16 | LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}" | ||
17 | |||
18 | SRCREV_machine = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f" | ||
19 | SRCREV_meta = "7782fc673afd6a1c742409896ae787560d96fce8" | ||
20 | |||
21 | PR = "r0" | ||
22 | PV = "${LINUX_VERSION}+git${SRCPV}" | ||
23 | SRCREV_FORMAT = "meta_machine" | ||
24 | |||
25 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" | ||
26 | |||
27 | # Omit broken machines from COMPATIBLE_MACHINE | ||
28 | # qemuppc hangs at boot | ||
29 | # qemumips panics at boot | ||
30 | COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)" | ||
31 | |||
32 | # Functionality flags | ||
33 | KERNEL_REVISION_CHECKING ?= "t" | ||
34 | KERNEL_FEATURES=features/netfilter | ||
35 | KERNEL_FEATURES_append=" features/taskstats" | ||
36 | KERNEL_FEATURES_append_qemux86=" cfg/sound" | ||
37 | KERNEL_FEATURES_append_qemux86-64=" cfg/sound" | ||
38 | |||
39 | YOCTO_KERNEL_META_DATA=t | ||
40 | |||
41 | # extra tasks | ||
42 | addtask kernel_link_vmlinux after do_compile before do_install | ||
43 | addtask validate_branches before do_patch after do_kernel_checkout | ||
44 | addtask kernel_configcheck after do_configure before do_compile | ||
45 | |||
46 | require recipes-kernel/linux/linux-tools.inc | ||