diff options
Diffstat (limited to 'meta-openmoko/packages')
3 files changed, 60 insertions, 0 deletions
diff --git a/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch b/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch new file mode 100644 index 0000000000..31d147be7d --- /dev/null +++ b/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Index: pulseaudio-0.9.9/configure.ac | ||
2 | =================================================================== | ||
3 | --- pulseaudio-0.9.9.orig/configure.ac 2008-01-24 01:06:06.000000000 +0000 | ||
4 | +++ pulseaudio-0.9.9/configure.ac 2008-02-05 17:45:59.000000000 +0000 | ||
5 | @@ -139,8 +139,8 @@ | ||
6 | ret=$? | ||
7 | rm -f conftest.o conftest | ||
8 | if test $ret -eq 0 ; then | ||
9 | - AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().]) | ||
10 | - AC_MSG_RESULT([yes]) | ||
11 | +dnl AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().]) | ||
12 | + AC_MSG_RESULT([no]) | ||
13 | else | ||
14 | AC_MSG_RESULT([no]) | ||
15 | fi | ||
16 | @@ -325,8 +325,7 @@ | ||
17 | rm -f conftest.o conftest | ||
18 | |||
19 | if test $ret -eq 0 ; then | ||
20 | - AC_DEFINE([HAVE_PTHREAD_PRIO_INHERIT], 1, [Have PTHREAD_PRIO_INHERIT.]) | ||
21 | - AC_MSG_RESULT([yes]) | ||
22 | + AC_MSG_RESULT([no]) | ||
23 | else | ||
24 | AC_MSG_RESULT([no]) | ||
25 | fi | ||
diff --git a/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch b/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch new file mode 100644 index 0000000000..f8ac5674a6 --- /dev/null +++ b/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Index: pulseaudio-0.9.8/src/Makefile.am | ||
2 | =================================================================== | ||
3 | --- pulseaudio-0.9.8.orig/src/Makefile.am | ||
4 | +++ pulseaudio-0.9.8/src/Makefile.am | ||
5 | @@ -1424,8 +1424,8 @@ | ||
6 | # HAL | ||
7 | libdbus_util_la_SOURCES = modules/dbus-util.c modules/dbus-util.h | ||
8 | libdbus_util_la_LDFLAGS = -avoid-version | ||
9 | -libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) libpulsecore.la | ||
10 | -libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS) | ||
11 | +libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) $(DBUS_LIBS) libpulsecore.la | ||
12 | +libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS) $(DBUS_CFLAGS) | ||
13 | |||
14 | module_hal_detect_la_SOURCES = modules/module-hal-detect.c | ||
15 | module_hal_detect_la_LDFLAGS = -module -avoid-version | ||
diff --git a/meta-openmoko/packages/pulseaudio/files/fix-shm.patch b/meta-openmoko/packages/pulseaudio/files/fix-shm.patch new file mode 100644 index 0000000000..3bf61d0d34 --- /dev/null +++ b/meta-openmoko/packages/pulseaudio/files/fix-shm.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | # fixes building against uclibc | ||
2 | # fixed upstream, see http://www.pulseaudio.org/ticket/200 | ||
3 | Index: pulseaudio-0.9.9/src/pulsecore/shm.c | ||
4 | =================================================================== | ||
5 | --- pulseaudio-0.9.9/src/pulsecore/shm.c (revision 1971) | ||
6 | +++ pulseaudio-0.9.9/src/pulsecore/shm.c (revision 2110) | ||
7 | @@ -319,4 +319,5 @@ | ||
8 | int pa_shm_cleanup(void) { | ||
9 | |||
10 | +#ifdef HAVE_SHM_OPEN | ||
11 | #ifdef SHM_PATH | ||
12 | DIR *d; | ||
13 | @@ -376,5 +377,6 @@ | ||
14 | |||
15 | closedir(d); | ||
16 | -#endif | ||
17 | +#endif /* SHM_PATH */ | ||
18 | +#endif /* HAVE_SHM_OPEN */ | ||
19 | |||
20 | return 0; | ||