summaryrefslogtreecommitdiffstats
path: root/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openmoko/packages/freesmartphone/gsmd2_git.bb')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2_git.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
deleted file mode 100644
index 8c1cf5b7e2..0000000000
--- a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "GSM 07.07 phone server"
2HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
3AUTHOR = "Ixonos Team"
4SECTION = "console/network"
5DEPENDS = "dbus-native dbus dbus-glib"
6RDEPENDS = "gsm0710muxd"
7LICENSE = "GPL"
8PV = "0.1.0+gitr${SRCREV}"
9PR = "r3"
10
11SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master \
12 file://fix-dbus-location.patch;patch=1"
13
14S = "${WORKDIR}/git"
15
16inherit autotools
17
18EXTRA_OECONF = "--disable-tests"
19
20do_install_append () {
21 install -d ${D}${sysconfdir}/gsmd2
22
23 install -d ${D}${sysconfdir}/dbus-1/system.d/
24 install -m 0644 ${S}/res/freesmartphone.conf ${D}${sysconfdir}/dbus-1/system.d/
25
26 install -d ${D}${datadir}/dbus-1/system-services
27 install -m 0644 ${S}/gsmd2.service ${D}${datadir}/dbus-1/system-services/
28}
29
30PACKAGES =+ "libgsmd2 libfreesmartphone"
31
32FILES_libgsmd2 = "${libdir}/libgsmd2.so.* ${libdir}/gsmd2/*.so"
33FILES_libfreesmartphone = "${libdir}/libfreesmartphone.so.*"
34FILES_${PN}-dev += "${libdir}/gsmd2/*.*a"
35FILES_${PN} = "${bindir}/gsmd2 ${sysconfdir}/dbus-1/ ${datadir}/dbus-1/"