summaryrefslogtreecommitdiffstats
path: root/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch135
1 files changed, 135 insertions, 0 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch b/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
new file mode 100644
index 0000000000..01c598af48
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
@@ -0,0 +1,135 @@
1---
2 libfreesmartphone/Makefile.am | 14 +++++++-------
3 serial/Makefile.am | 2 +-
4 src/Makefile.am | 14 +++++++-------
5 3 files changed, 15 insertions(+), 15 deletions(-)
6
7--- git.orig/libfreesmartphone/Makefile.am
8+++ git/libfreesmartphone/Makefile.am
9@@ -21,47 +21,47 @@ fso-marshallers.h: $(top_srcdir)/src/sma
10 fso-marshallers.c: $(top_srcdir)/src/smartphone_marshaller.txt
11 glib-genmarshal --prefix fso_marshaller --body $(top_srcdir)/src/smartphone_marshaller.txt > fso-marshallers.c
12
13
14 freesmartphone-call-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
15- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
16+ $(LIBTOOL) --mode=execute dbus-binding-tool \
17 --prefix=smartphone_call --mode=glib-client \
18 --output=freesmartphone-call-binding.h \
19 $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
20
21 freesmartphone-sms-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
22- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
23+ $(LIBTOOL) --mode=execute dbus-binding-tool \
24 --prefix=smartphone_sms --mode=glib-client \
25 --output=freesmartphone-sms-binding.h \
26 $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
27
28 freesmartphone-device-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
29- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
30+ $(LIBTOOL) --mode=execute dbus-binding-tool \
31 --prefix=smartphone_device --mode=glib-client \
32 --output=freesmartphone-device-binding.h \
33 $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
34
35 freesmartphone-sim-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
36- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
37+ $(LIBTOOL) --mode=execute dbus-binding-tool \
38 --prefix=smartphone_sim --mode=glib-client \
39 --output=freesmartphone-sim-binding.h \
40 $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
41
42 freesmartphone-phonebook-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
43- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
44+ $(LIBTOOL) --mode=execute dbus-binding-tool \
45 --prefix=smartphone_phonebook --mode=glib-client \
46 --output=freesmartphone-phonebook-binding.h \
47 $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
48
49 freesmartphone-pdp-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
50- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
51+ $(LIBTOOL) --mode=execute dbus-binding-tool \
52 --prefix=smartphone_pdp --mode=glib-client \
53 --output=freesmartphone-pdp-binding.h \
54 $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
55
56 freesmartphone-network-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
57- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
58+ $(LIBTOOL) --mode=execute dbus-binding-tool \
59 --prefix=smartphone_network --mode=glib-client \
60 --output=freesmartphone-network-binding.h \
61 $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
62
63 CLEANFILES = $(BUILT_SOURCES)
64--- git.orig/serial/Makefile.am
65+++ git/serial/Makefile.am
66@@ -11,11 +11,11 @@ COMMON_LDFLAGS = -avoid-version -module
67 BUILT_SOURCES = fsomuxer_client.h
68
69 CLEANFILES = $(BUILT_SOURCES)
70
71 fsomuxer_client.h: fsomuxer.xml
72- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
73+ $(LIBTOOL) --mode=execute dbus-binding-tool \
74 --mode=glib-client \
75 --output=fsomuxer_client.h \
76 fsomuxer.xml
77
78
79--- git.orig/src/Makefile.am
80+++ git/src/Makefile.am
81@@ -30,47 +30,47 @@ dbus_marshal.h: $(srcdir)/smartphone_mar
82 dbus_marshal.c: $(srcdir)/smartphone_marshaller.txt
83 glib-genmarshal --prefix gsmd_smartphone_marshaller --body $(srcdir)/smartphone_marshaller.txt > dbus_marshal.c
84
85
86 dbus_call_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
87- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
88+ $(LIBTOOL) --mode=execute dbus-binding-tool \
89 --prefix=smartphone_call --mode=glib-server \
90 --output=dbus_call_glue.h \
91 $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
92
93 dbus_sms_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
94- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
95+ $(LIBTOOL) --mode=execute dbus-binding-tool \
96 --prefix=smartphone_sms --mode=glib-server \
97 --output=dbus_sms_glue.h \
98 $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
99
100 dbus_device_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
101- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
102+ $(LIBTOOL) --mode=execute dbus-binding-tool \
103 --prefix=smartphone_device --mode=glib-server \
104 --output=dbus_device_glue.h \
105 $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
106
107 dbus_sim_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
108- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
109+ $(LIBTOOL) --mode=execute dbus-binding-tool \
110 --prefix=smartphone_sim --mode=glib-server \
111 --output=dbus_sim_glue.h \
112 $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
113
114 dbus_phonebook_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
115- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
116+ $(LIBTOOL) --mode=execute dbus-binding-tool \
117 --prefix=smartphone_phonebook --mode=glib-server \
118 --output=dbus_phonebook_glue.h \
119 $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
120
121 dbus_pdp_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
122- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
123+ $(LIBTOOL) --mode=execute dbus-binding-tool \
124 --prefix=smartphone_pdp --mode=glib-server \
125 --output=dbus_pdp_glue.h \
126 $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
127
128 dbus_network_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
129- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
130+ $(LIBTOOL) --mode=execute dbus-binding-tool \
131 --prefix=smartphone_network --mode=glib-server \
132 --output=dbus_network_glue.h \
133 $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
134
135 gsmd-types.h: $(srcdir)/gsmd-error.h