summaryrefslogtreecommitdiffstats
path: root/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
new file mode 100644
index 0000000000..410ac36e2f
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "GSM 07.10 muxer userspace daemon"
2HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
3AUTHOR = "M. Dietrich"
4SECTION = "console/network"
5DEPENDS = "dbus dbus-glib"
6LICENSE = "GPL"
7PV = "0.9.1+gitr${SRCREV}"
8
9SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
10S = "${WORKDIR}/git"
11
12inherit autotools
13
14# install init script for people who want to manually
15# start/stop it, but don't add runlevels.
16do_install_append() {
17 install -d ${D}${sysconfdir}/init.d
18 install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
19}
20
21FILES_${PN} += "${datadir} ${sysconfdir}"