diff options
Diffstat (limited to 'meta-moblin')
-rw-r--r-- | meta-moblin/packages/aspell/aspell_0.60.6.bb | 15 | ||||
-rw-r--r-- | meta-moblin/packages/enchant/enchant_1.3.0.bb | 20 | ||||
-rw-r--r-- | meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch | 15 | ||||
-rw-r--r-- | meta-moblin/packages/libsexy/libsexy.inc | 13 | ||||
-rw-r--r-- | meta-moblin/packages/libsexy/libsexy_0.1.11.bb | 2 |
5 files changed, 65 insertions, 0 deletions
diff --git a/meta-moblin/packages/aspell/aspell_0.60.6.bb b/meta-moblin/packages/aspell/aspell_0.60.6.bb new file mode 100644 index 0000000000..de0cfa6aa6 --- /dev/null +++ b/meta-moblin/packages/aspell/aspell_0.60.6.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz" | ||
2 | DESCRIPTION = "GNU Aspell spell-checker" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE="LGPL" | ||
5 | |||
6 | PACKAGES += "libaspell libpspell libpspell-dev aspell-utils" | ||
7 | |||
8 | FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*" | ||
9 | FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" | ||
10 | FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" | ||
11 | FILES_${PN} = "${bindir}/aspell" | ||
12 | FILES_libpspell = "${libdir}/libpspell.so.*" | ||
13 | FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell" | ||
14 | |||
15 | inherit autotools_stage | ||
diff --git a/meta-moblin/packages/enchant/enchant_1.3.0.bb b/meta-moblin/packages/enchant/enchant_1.3.0.bb new file mode 100644 index 0000000000..e9e8a898cd --- /dev/null +++ b/meta-moblin/packages/enchant/enchant_1.3.0.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "Enchant Spell checker API Library" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "LGPL" | ||
4 | DEPENDS = "aspell" | ||
5 | RDEPENDS = "aspell" | ||
6 | |||
7 | inherit autotools_stage pkgconfig | ||
8 | |||
9 | PR = "r1" | ||
10 | |||
11 | S = "${WORKDIR}/enchant-${PV}" | ||
12 | |||
13 | SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz" | ||
14 | |||
15 | EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell --disable-binreloc" | ||
16 | |||
17 | FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/*.so" | ||
18 | FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la ${libdir}/${PN}/*.a" | ||
19 | |||
20 | export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ " | ||
diff --git a/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch b/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch new file mode 100644 index 0000000000..61da9474df --- /dev/null +++ b/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Index: libsexy-0.1.11/libsexy.pc.in | ||
2 | =================================================================== | ||
3 | --- libsexy-0.1.11.orig/libsexy.pc.in 2005-11-10 10:21:18.000000000 +0000 | ||
4 | +++ libsexy-0.1.11/libsexy.pc.in 2008-03-05 14:36:39.000000000 +0000 | ||
5 | @@ -6,7 +6,8 @@ | ||
6 | Name: libsexy | ||
7 | Description: Doing naughty things to good widgets | ||
8 | Version: @VERSION@ | ||
9 | -Libs: -L${libdir} -lsexy @PACKAGE_LIBS@ | ||
10 | -Cflags: -I${includedir} @PACKAGE_CFLAGS@ | ||
11 | |||
12 | +Requires: pango glib-2.0 gtk+-2.0 libxml-2.0 | ||
13 | +Libs: -L${libdir} -lsexy | ||
14 | +Cflags: -I${includedir} | ||
15 | |||
diff --git a/meta-moblin/packages/libsexy/libsexy.inc b/meta-moblin/packages/libsexy/libsexy.inc new file mode 100644 index 0000000000..473faf5e6e --- /dev/null +++ b/meta-moblin/packages/libsexy/libsexy.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "Libsexy is a collection of GTK+ widgets that extend the functionality of such standard widgets as GtkEntry and GtkLabel" | ||
2 | HOMEPAGE = "http://wiki.chipx86.com/wiki/Libsexy" | ||
3 | AUTHOR = "Christian Hammond <chipx86@chipx86.com>" | ||
4 | SECTION = "x11/libs" | ||
5 | |||
6 | DEPENDS = "gtk+ enchant libxml2" | ||
7 | |||
8 | SRC_URI = "http://releases.chipx86.com/libsexy/${PN}/${PN}-${PV}.tar.gz \ | ||
9 | file://libsexy-pkgconfig-fixes.patch;patch=1" | ||
10 | |||
11 | inherit autotools_stage pkgconfig | ||
12 | |||
13 | |||
diff --git a/meta-moblin/packages/libsexy/libsexy_0.1.11.bb b/meta-moblin/packages/libsexy/libsexy_0.1.11.bb new file mode 100644 index 0000000000..91784ffb49 --- /dev/null +++ b/meta-moblin/packages/libsexy/libsexy_0.1.11.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require libsexy.inc | ||
2 | PR = "r1" | ||