diff options
Diffstat (limited to 'meta-moblin/packages')
3 files changed, 86 insertions, 10 deletions
diff --git a/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg-7f7d50079c8bcc63874fd60a61f23d849e025445.patch b/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg-7f7d50079c8bcc63874fd60a61f23d849e025445.patch new file mode 100644 index 0000000000..1b57ffe32a --- /dev/null +++ b/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg-7f7d50079c8bcc63874fd60a61f23d849e025445.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | Index: git/configure.ac | ||
2 | =================================================================== | ||
3 | --- git.orig/configure.ac 2009-10-05 17:05:14.000000000 +0100 | ||
4 | +++ git/configure.ac 2009-10-05 21:02:48.000000000 +0100 | ||
5 | @@ -34,7 +34,7 @@ | ||
6 | gtk+-2.0 | ||
7 | packagekit-glib >= 0.4 | ||
8 | packagekit-glib < 0.5 | ||
9 | - rpm >= 4.6' | ||
10 | + libopkg' | ||
11 | |||
12 | AC_MSG_CHECKING([for available nbtk version]) | ||
13 | PKG_CHECK_EXISTS(nbtk-1.2, | ||
14 | Index: git/src/mai-package.c | ||
15 | =================================================================== | ||
16 | --- git.orig/src/mai-package.c 2009-10-05 17:05:06.000000000 +0100 | ||
17 | +++ git/src/mai-package.c 2009-10-05 21:01:57.000000000 +0100 | ||
18 | @@ -23,7 +23,7 @@ | ||
19 | #include <gtk/gtk.h> | ||
20 | |||
21 | /* FIXME make conditional. */ | ||
22 | -#include <rpm/rpmlib.h> | ||
23 | +#include <libopkg/opkg.h> | ||
24 | |||
25 | #include "mai-model-priv.h" | ||
26 | #include "mai-package.h" | ||
27 | @@ -191,7 +191,7 @@ | ||
28 | |||
29 | if (priv->package_id && | ||
30 | priv->version && | ||
31 | - rpmvercmp (version, priv->version) < 0) | ||
32 | + opkg_compare_versions (version, priv->version) < 0) | ||
33 | { | ||
34 | g_debug (" skipping '%s'", version); | ||
35 | return; | ||
36 | @@ -955,7 +955,7 @@ | ||
37 | return -1; | ||
38 | |||
39 | /* FIXME support deb. */ | ||
40 | - return rpmvercmp (priv->version, version); | ||
41 | + return opkg_compare_versions (priv->version, version); | ||
42 | } | ||
43 | |||
44 | gboolean | ||
diff --git a/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg.patch b/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg.patch index 1b57ffe32a..3496c22bf5 100644 --- a/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg.patch +++ b/meta-moblin/packages/moblin-app-installer/moblin-app-installer/opkg.patch | |||
@@ -1,20 +1,20 @@ | |||
1 | Index: git/configure.ac | 1 | Index: git/configure.ac |
2 | =================================================================== | 2 | =================================================================== |
3 | --- git.orig/configure.ac 2009-10-05 17:05:14.000000000 +0100 | 3 | --- git.orig/configure.ac 2009-12-10 21:37:39.000000000 +0000 |
4 | +++ git/configure.ac 2009-10-05 21:02:48.000000000 +0100 | 4 | +++ git/configure.ac 2009-12-10 21:39:05.000000000 +0000 |
5 | @@ -34,7 +34,7 @@ | 5 | @@ -34,7 +34,7 @@ |
6 | clutter-1.0 | ||
7 | clutter-gtk-0.10 | ||
6 | gtk+-2.0 | 8 | gtk+-2.0 |
7 | packagekit-glib >= 0.4 | ||
8 | packagekit-glib < 0.5 | ||
9 | - rpm >= 4.6' | 9 | - rpm >= 4.6' |
10 | + libopkg' | 10 | + libopkg' |
11 | 11 | ||
12 | AC_MSG_CHECKING([for available nbtk version]) | 12 | AC_MSG_CHECKING([for available nbtk version]) |
13 | PKG_CHECK_EXISTS(nbtk-1.2, | 13 | PKG_CHECK_EXISTS(nbtk-1.2, |
14 | Index: git/src/mai-package.c | 14 | Index: git/src/pk-glib/mai-package.c |
15 | =================================================================== | 15 | =================================================================== |
16 | --- git.orig/src/mai-package.c 2009-10-05 17:05:06.000000000 +0100 | 16 | --- git.orig/src/pk-glib/mai-package.c 2009-12-10 21:42:24.000000000 +0000 |
17 | +++ git/src/mai-package.c 2009-10-05 21:01:57.000000000 +0100 | 17 | +++ git/src/pk-glib/mai-package.c 2009-12-10 21:43:48.000000000 +0000 |
18 | @@ -23,7 +23,7 @@ | 18 | @@ -23,7 +23,7 @@ |
19 | #include <gtk/gtk.h> | 19 | #include <gtk/gtk.h> |
20 | 20 | ||
@@ -24,7 +24,7 @@ Index: git/src/mai-package.c | |||
24 | 24 | ||
25 | #include "mai-model-priv.h" | 25 | #include "mai-model-priv.h" |
26 | #include "mai-package.h" | 26 | #include "mai-package.h" |
27 | @@ -191,7 +191,7 @@ | 27 | @@ -230,7 +230,7 @@ |
28 | 28 | ||
29 | if (priv->package_id && | 29 | if (priv->package_id && |
30 | priv->version && | 30 | priv->version && |
@@ -33,7 +33,7 @@ Index: git/src/mai-package.c | |||
33 | { | 33 | { |
34 | g_debug (" skipping '%s'", version); | 34 | g_debug (" skipping '%s'", version); |
35 | return; | 35 | return; |
36 | @@ -955,7 +955,7 @@ | 36 | @@ -998,7 +998,7 @@ |
37 | return -1; | 37 | return -1; |
38 | 38 | ||
39 | /* FIXME support deb. */ | 39 | /* FIXME support deb. */ |
@@ -42,3 +42,34 @@ Index: git/src/mai-package.c | |||
42 | } | 42 | } |
43 | 43 | ||
44 | gboolean | 44 | gboolean |
45 | Index: git/src/pk-glib2/mai-package.c | ||
46 | =================================================================== | ||
47 | --- git.orig/src/pk-glib2/mai-package.c 2009-12-10 21:41:01.000000000 +0000 | ||
48 | +++ git/src/pk-glib2/mai-package.c 2009-12-10 21:42:08.000000000 +0000 | ||
49 | @@ -23,7 +23,7 @@ | ||
50 | #include <gtk/gtk.h> | ||
51 | |||
52 | /* FIXME make conditional. */ | ||
53 | -#include <rpm/rpmlib.h> | ||
54 | +#include <libopkg/opkg.h> | ||
55 | |||
56 | #include "mai-model-priv.h" | ||
57 | #include "mai-package.h" | ||
58 | @@ -737,7 +737,7 @@ | ||
59 | return -1; | ||
60 | |||
61 | /* FIXME support deb. */ | ||
62 | - return rpmvercmp (priv->version, version); | ||
63 | + return opkg_compare_versions (priv->version, version); | ||
64 | } | ||
65 | |||
66 | static void | ||
67 | @@ -820,7 +820,7 @@ | ||
68 | gchar **id = pk_package_id_split (package_id); | ||
69 | |||
70 | if (!priv->version || | ||
71 | - rpmvercmp (id[PK_PACKAGE_ID_VERSION], priv->version) > 0) | ||
72 | + opkg_compare_versions (id[PK_PACKAGE_ID_VERSION], priv->version) > 0) | ||
73 | { | ||
74 | PkInfoEnum package_info; | ||
75 | |||
diff --git a/meta-moblin/packages/moblin-app-installer/moblin-app-installer_git.bb b/meta-moblin/packages/moblin-app-installer/moblin-app-installer_git.bb index 502db63a08..8b2df3291a 100644 --- a/meta-moblin/packages/moblin-app-installer/moblin-app-installer_git.bb +++ b/meta-moblin/packages/moblin-app-installer/moblin-app-installer_git.bb | |||
@@ -1,6 +1,7 @@ | |||
1 | DESCRIPTION = "Moblin Appliction Installer" | 1 | DESCRIPTION = "Moblin Appliction Installer" |
2 | SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \ | 2 | SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \ |
3 | file://opkg.patch;patch=1 " | 3 | file://opkg-7f7d50079c8bcc63874fd60a61f23d849e025445.patch;patch=1;rev=7f7d50079c8bcc63874fd60a61f23d849e025445" |
4 | file://opkg.patch;patch=1;notrev=7f7d50079c8bcc63874fd60a61f23d849e025445" | ||
4 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
5 | PV = "0.0+git${SRCPV}" | 6 | PV = "0.0+git${SRCPV}" |
6 | PR = "r0" | 7 | PR = "r0" |