summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb')
-rw-r--r--meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb b/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb
deleted file mode 100644
index 68582850a2..0000000000
--- a/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1DESCRIPTION = "User Interface Generator and Meta Object Compiler (moc) for Qt(E) 3.x"
2HOMEPAGE = "http://www.trolltech.com"
3SECTION = "devel"
4PRIORITY = "optional"
5LICENSE = "GPL QPL"
6DEPENDS = "qmake-native"
7PR = "r3"
8
9SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-free-${PV}.tar.bz2 \
10 file://no-examples.patch;patch=1 \
11 file://64bit-cleanup.patch;patch=1"
12S = "${WORKDIR}/qt-embedded-free-${PV}"
13
14inherit native qmake_base qt3e
15
16export QTDIR = "${S}"
17export OE_QMAKE_LINK="${CXX}"
18CXXFLAGS += " -DQWS"
19
20QT_CONFIG_FLAGS = "-release -static -depths 8,16 -qt-zlib -no-nas-sound \
21 -no-sm -no-libjpeg -no-libmng -no-gif -no-xshape -no-xinerama \
22 -no-xcursor -no-xrandr -no-xrender -no-xft -no-tablet \
23 -no-xkb -no-dlopen-opengl -no-freetype -no-thread \
24 -no-nis -no-cups -prefix ${prefix} \
25 -xplatform ${OE_QMAKE_PLATFORM} \
26 -platform ${OE_QMAKE_PLATFORM}"
27
28do_configure() {
29 oe_qmake_mkspecs
30 echo "yes" | ./configure ${QT_CONFIG_FLAGS}
31}
32
33do_compile() {
34 oe_runmake symlinks || die "Can't symlink include files"
35 oe_runmake src-moc || die "Building moc failed"
36 oe_runmake sub-tools || die "Building tools failed"
37}
38
39do_install() {
40 install -d ${D}${bindir}/
41 install -d ${D}/qte3/lib/
42 install -d ${D}/qte3/include
43
44 install -m 0755 bin/moc ${D}${bindir}/
45 install -m 0755 bin/uic ${D}${bindir}/
46 install -m 0655 lib/*.a ${D}/qte3/lib/
47
48 for f in include/*.h
49 do
50 install -m 0644 $f ${D}/qte3/include/
51 done
52}
53
54sysroot_stage_all_append() {
55 sysroot_stage_dir ${D}/qte3 ${SYSROOT_DESTDIR}/${QTEDIR}/
56}