summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/tracker/tracker-0.6.95/05-tracker-ioprio-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/tracker/tracker-0.6.95/05-tracker-ioprio-cross.patch')
-rw-r--r--meta-moblin/packages/tracker/tracker-0.6.95/05-tracker-ioprio-cross.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-moblin/packages/tracker/tracker-0.6.95/05-tracker-ioprio-cross.patch b/meta-moblin/packages/tracker/tracker-0.6.95/05-tracker-ioprio-cross.patch
new file mode 100644
index 0000000000..c04c12536c
--- /dev/null
+++ b/meta-moblin/packages/tracker/tracker-0.6.95/05-tracker-ioprio-cross.patch
@@ -0,0 +1,64 @@
1From ae32c3902a1afe2f900ec5e42a1070c8c7fce83b Mon Sep 17 00:00:00 2001
2From: John Carr <john.carr@unrouted.co.uk>
3Date: Tue, 3 Nov 2009 01:18:26 +0000
4Subject: [PATCH 1/2] Add AC_CACHE_CHECK magic around ioprio checking.
5
6Having the cache check allows the end user to set whether ioprio
7is available or not. Without this cross-compilation is not
8possible as there is no way to run the test program.
9---
10 configure.ac | 24 +++++++++++-------------
11 1 files changed, 11 insertions(+), 13 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index 441b4b8..fca54b9 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -1164,17 +1164,15 @@ AM_CONDITIONAL(HAVE_LIBVORBIS, test "x$have_libvorbis" = "xyes")
18 # Check ioprio support
19 ####################################################################
20
21-AC_MSG_CHECKING([[ioprio support]])
22-have_ioprio=no
23-
24-AC_RUN_IFELSE(
25-[AC_LANG_PROGRAM([[
26+AC_CACHE_CHECK([if we have ioprio],[tracker_cv_have_ioprio],
27+ [AC_RUN_IFELSE(
28+ [AC_LANG_PROGRAM([[
29 #include <stdlib.h>
30 #include <errno.h>
31 #include <sys/syscall.h>
32 #include <unistd.h>
33-]],
34-[[
35+ ]],
36+ [[
37 inline int ioprio_get (int which, int who)
38 {
39 return syscall (__NR_ioprio_get, which, who);
40@@ -1184,16 +1182,16 @@ AC_RUN_IFELSE(
41 {
42 return ioprio_get (1, 0);
43 }
44-]]
45-)],
46-[have_ioprio=yes],[])
47+ ]])],
48+ [tracker_cv_have_ioprio=yes],
49+ [tracker_cv_have_ioprio=no],
50+ [AC_MSG_ERROR([cross-compiling: please set 'tracker_cv_have_ioprio'])])
51+ ])
52
53-if test "$have_ioprio" = "yes" ; then
54+if test "x$tracker_cv_have_ioprio" = "xyes" ; then
55 AC_DEFINE(HAVE_IOPRIO, 1, [Define if we have ioprio])
56 fi
57
58-AC_MSG_RESULT([$have_ioprio])
59-
60 ##################################################################
61 # Check for exempi
62 ##################################################################
63--
641.6.3.3