summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/samba/files/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/samba/files/configure.patch')
-rw-r--r--meta-moblin/packages/samba/files/configure.patch179
1 files changed, 0 insertions, 179 deletions
diff --git a/meta-moblin/packages/samba/files/configure.patch b/meta-moblin/packages/samba/files/configure.patch
deleted file mode 100644
index b7ba287795..0000000000
--- a/meta-moblin/packages/samba/files/configure.patch
+++ /dev/null
@@ -1,179 +0,0 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- source/configure.in~configure 2003-12-14 22:36:25.000000000 -0500
7+++ source/configure.in 2004-01-26 14:33:15.000000000 -0500
8@@ -959,7 +959,7 @@
9 #endif
10 exit(0);
11 }
12-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
13+], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no], [linux_getgrouplist_ok=cross])
14 if test x"$linux_getgrouplist_ok" = x"yes"; then
15 AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
16 fi
17--- source/aclocal.m4~configure 2004-01-26 14:33:15.000000000 -0500
18+++ source/aclocal.m4 2004-01-26 17:34:28.000000000 -0500
19@@ -2,7 +2,7 @@
20 dnl if the cache file is inconsistent with the current host,
21 dnl target and build system types, execute CMD or print a default
22 dnl error message.
23-AC_DEFUN(AC_VALIDATE_CACHE_SYSTEM_TYPE, [
24+AC_DEFUN([AC_VALIDATE_CACHE_SYSTEM_TYPE], [
25 AC_REQUIRE([AC_CANONICAL_SYSTEM])
26 AC_MSG_CHECKING([config.cache system type])
27 if { test x"${ac_cv_host_system_type+set}" = x"set" &&
28@@ -24,7 +24,7 @@
29
30
31 dnl test whether dirent has a d_off member
32-AC_DEFUN(AC_DIRENT_D_OFF,
33+AC_DEFUN([AC_DIRENT_D_OFF],
34 [AC_CACHE_CHECK([for d_off in dirent], ac_cv_dirent_d_off,
35 [AC_TRY_COMPILE([
36 #include <unistd.h>
37@@ -38,7 +38,7 @@
38
39 dnl Mark specified module as shared
40 dnl SMB_MODULE(name,static_files,shared_files,subsystem,whatif-static,whatif-shared)
41-AC_DEFUN(SMB_MODULE,
42+AC_DEFUN([SMB_MODULE],
43 [
44 AC_MSG_CHECKING([how to build $1])
45 if test "$[MODULE_][$1]"; then
46@@ -68,7 +68,7 @@
47 fi
48 ])
49
50-AC_DEFUN(SMB_SUBSYSTEM,
51+AC_DEFUN([SMB_SUBSYSTEM],
52 [
53 AC_SUBST($1_STATIC)
54 AC_SUBST($1_MODULES)
55@@ -77,7 +77,7 @@
56 ])
57
58 dnl AC_PROG_CC_FLAG(flag)
59-AC_DEFUN(AC_PROG_CC_FLAG,
60+AC_DEFUN([AC_PROG_CC_FLAG],
61 [AC_CACHE_CHECK(whether ${CC-cc} accepts -$1, ac_cv_prog_cc_$1,
62 [echo 'void f(){}' > conftest.c
63 if test -z "`${CC-cc} -$1 -c conftest.c 2>&1`"; then
64@@ -91,7 +91,7 @@
65 dnl see if a declaration exists for a function or variable
66 dnl defines HAVE_function_DECL if it exists
67 dnl AC_HAVE_DECL(var, includes)
68-AC_DEFUN(AC_HAVE_DECL,
69+AC_DEFUN([AC_HAVE_DECL],
70 [
71 AC_CACHE_CHECK([for $1 declaration],ac_cv_have_$1_decl,[
72 AC_TRY_COMPILE([$2],[int i = (int)$1],
73@@ -105,7 +105,7 @@
74 dnl check for a function in a library, but don't
75 dnl keep adding the same library to the LIBS variable.
76 dnl AC_LIBTESTFUNC(lib,func)
77-AC_DEFUN(AC_LIBTESTFUNC,
78+AC_DEFUN([AC_LIBTESTFUNC],
79 [case "$LIBS" in
80 *-l$1*) AC_CHECK_FUNCS($2) ;;
81 *) AC_CHECK_LIB($1, $2)
82@@ -223,7 +223,7 @@
83
84 dnl Define an AC_DEFINE with ifndef guard.
85 dnl AC_N_DEFINE(VARIABLE [, VALUE])
86-define(AC_N_DEFINE,
87+define([AC_N_DEFINE],
88 [cat >> confdefs.h <<\EOF
89 [#ifndef] $1
90 [#define] $1 ifelse($#, 2, [$2], $#, 3, [$2], 1)
91@@ -233,14 +233,14 @@
92
93 dnl Add an #include
94 dnl AC_ADD_INCLUDE(VARIABLE)
95-define(AC_ADD_INCLUDE,
96+define([AC_ADD_INCLUDE],
97 [cat >> confdefs.h <<\EOF
98 [#include] $1
99 EOF
100 ])
101
102 dnl Copied from libtool.m4
103-AC_DEFUN(AC_PROG_LD_GNU,
104+AC_DEFUN([AC_PROG_LD_GNU],
105 [AC_CACHE_CHECK([if the linker ($LD) is GNU ld], ac_cv_prog_gnu_ld,
106 [# I'd rather use --version here, but apparently some GNU ld's only accept -v.
107 if $LD -v 2>&1 </dev/null | egrep '(GNU|with BFD)' 1>&5; then
108@@ -259,7 +259,7 @@
109 dnl AM_PATH_XML2([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
110 dnl Test for XML, and define XML_CFLAGS and XML_LIBS
111 dnl
112-AC_DEFUN(AM_PATH_XML2,[
113+AC_DEFUN([AM_PATH_XML2],[
114 AC_ARG_WITH(xml-prefix,
115 [ --with-xml-prefix=PFX Prefix where libxml is installed (optional)],
116 xml_config_prefix="$withval", xml_config_prefix="")
117@@ -443,7 +443,7 @@
118 dnl AM_PATH_MYSQL([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
119 dnl Test for MYSQL, and define MYSQL_CFLAGS and MYSQL_LIBS
120 dnl
121-AC_DEFUN(AM_PATH_MYSQL,
122+AC_DEFUN([AM_PATH_MYSQL],
123 [dnl
124 dnl Get the cflags and libraries from the mysql_config script
125 dnl
126@@ -485,7 +485,7 @@
127 ])
128
129 dnl Removes -I/usr/include/? from given variable
130-AC_DEFUN(CFLAGS_REMOVE_USR_INCLUDE,[
131+AC_DEFUN([CFLAGS_REMOVE_USR_INCLUDE],[
132 ac_new_flags=""
133 for i in [$]$1; do
134 case [$]i in
135@@ -497,7 +497,7 @@
136 ])
137
138 dnl Removes -L/usr/lib/? from given variable
139-AC_DEFUN(LIB_REMOVE_USR_LIB,[
140+AC_DEFUN([LIB_REMOVE_USR_LIB],[
141 ac_new_flags=""
142 for i in [$]$1; do
143 case [$]i in
144@@ -510,7 +510,7 @@
145
146 dnl From Bruno Haible.
147
148-AC_DEFUN(jm_ICONV,
149+AC_DEFUN([jm_ICONV],
150 [
151 dnl Some systems have iconv in libc, some have it in libiconv (OSF/1 and
152 dnl those with the standalone portable libiconv installed).
153@@ -607,7 +607,7 @@
154 fi
155 ])
156
157-AC_DEFUN(rjs_CHARSET,[
158+AC_DEFUN([rjs_CHARSET],[
159 dnl Find out if we can convert from $1 to UCS2-LE
160 AC_MSG_CHECKING([can we convert from $1 to UCS2-LE?])
161 AC_TRY_RUN([
162@@ -625,7 +625,7 @@
163
164 dnl CFLAGS_ADD_DIR(CFLAGS, $INCDIR)
165 dnl This function doesn't add -I/usr/include into CFLAGS
166-AC_DEFUN(CFLAGS_ADD_DIR,[
167+AC_DEFUN([CFLAGS_ADD_DIR],[
168 if test "$2" != "/usr/include" ; then
169 $1="$$1 -I$2"
170 fi
171@@ -633,7 +633,7 @@
172
173 dnl LIB_ADD_DIR(LDFLAGS, $LIBDIR)
174 dnl This function doesn't add -L/usr/lib into LDFLAGS
175-AC_DEFUN(LIB_ADD_DIR,[
176+AC_DEFUN([LIB_ADD_DIR],[
177 if test "$2" != "/usr/lib" ; then
178 $1="$$1 -L$2"
179 fi