summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/samba/files/configure-3.3.0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/samba/files/configure-3.3.0.patch')
-rw-r--r--meta-moblin/packages/samba/files/configure-3.3.0.patch87
1 files changed, 0 insertions, 87 deletions
diff --git a/meta-moblin/packages/samba/files/configure-3.3.0.patch b/meta-moblin/packages/samba/files/configure-3.3.0.patch
deleted file mode 100644
index a2e2544802..0000000000
--- a/meta-moblin/packages/samba/files/configure-3.3.0.patch
+++ /dev/null
@@ -1,87 +0,0 @@
1Index: source/configure
2===================================================================
3--- source.orig/configure 2009-01-27 07:53:11.000000000 +0000
4+++ source/configure 2009-05-15 12:51:02.000000000 +0100
5@@ -43860,13 +43860,7 @@
6 *linux*)
7 # glibc <= 2.3.2 has a broken getgrouplist
8 if test "$cross_compiling" = yes; then
9- { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
10-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
11-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
12-See \`config.log' for more details." >&5
13-$as_echo "$as_me: error: cannot run test program while cross compiling
14-See \`config.log' for more details." >&2;}
15- { (exit 1); exit 1; }; }; }
16+linux_getgrouplist_ok=no
17 else
18 cat >conftest.$ac_ext <<_ACEOF
19 /* confdefs.h. */
20Index: source/configure.in
21===================================================================
22--- source.orig/configure.in 2009-05-15 12:51:01.000000000 +0100
23+++ source/configure.in 2009-05-15 13:02:22.000000000 +0100
24@@ -280,6 +280,8 @@
25 fi
26 AC_SUBST(BROKEN_CC)
27
28+AC_TRY_COMPILE([],[(void)sizeof(char[-1])],AC_MSG_ERROR([configure's compilation assert doesn't work with $CC]))
29+
30 dnl Check if the C compiler understands -Werror
31 AC_CACHE_CHECK([that the C compiler understands -Werror],samba_cv_HAVE_Werror, [
32 AC_TRY_RUN_STRICT([
33@@ -330,25 +332,11 @@
34 # a runtime test is needed here
35 AC_SUBST(PIDL_ARGS)
36 AC_CACHE_CHECK([that the C compiler understands negative enum values],samba_cv_CC_NEGATIVE_ENUM_VALUES, [
37- AC_TRY_RUN(
38+ AC_TRY_COMPILE([],
39 [
40- #include <stdio.h>
41 enum negative_values { NEGATIVE_VALUE = 0xFFFFFFFF };
42- int main(void) {
43- enum negative_values v1 = NEGATIVE_VALUE;
44- unsigned v2 = NEGATIVE_VALUE;
45-
46- if (v1 != 0xFFFFFFFF) {
47- printf("%u != 0xFFFFFFFF\n", v1);
48- return 1;
49- }
50- if (v2 != 0xFFFFFFFF) {
51- printf("%u != 0xFFFFFFFF\n", v2);
52- return 1;
53- }
54-
55- return 0;
56- }
57+ (void)sizeof(char[1-2*( (unsigned)NEGATIVE_VALUE != 0xFFFFFFFF)]);
58+ (void)sizeof(char[1-2*((enum negative_values)NEGATIVE_VALUE != 0xFFFFFFFF)]);
59 ],
60 samba_cv_CC_NEGATIVE_ENUM_VALUES=yes,samba_cv__CC_NEGATIVE_ENUM_VALUES=no)])
61 if test x"$samba_cv_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
62@@ -1223,22 +1211,12 @@
63 case "$host_os" in
64 *linux*)
65 # glibc <= 2.3.2 has a broken getgrouplist
66- AC_TRY_RUN([
67-#include <unistd.h>
68+ AC_TRY_COMPILE([
69 #include <sys/utsname.h>
70-main() {
71- /* glibc up to 2.3 has a broken getgrouplist */
72+],[
73 #if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
74- int libc_major = __GLIBC__;
75- int libc_minor = __GLIBC_MINOR__;
76-
77- if (libc_major < 2)
78- exit(1);
79- if ((libc_major == 2) && (libc_minor <= 3))
80- exit(1);
81+ (void)sizeof(char[1-2*(__GLIBC__ < 2 || __GLIBC__ == 2 && __GLIBC_MINOR__ <= 3)]);
82 #endif
83- exit(0);
84-}
85 ], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
86 if test x"$linux_getgrouplist_ok" = x"yes"; then
87 AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])