diff options
Diffstat (limited to 'meta-moblin/packages/qmake/qmake-native_1.07a.bb')
-rw-r--r-- | meta-moblin/packages/qmake/qmake-native_1.07a.bb | 47 |
1 files changed, 0 insertions, 47 deletions
diff --git a/meta-moblin/packages/qmake/qmake-native_1.07a.bb b/meta-moblin/packages/qmake/qmake-native_1.07a.bb deleted file mode 100644 index 82a24968af..0000000000 --- a/meta-moblin/packages/qmake/qmake-native_1.07a.bb +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | DESCRIPTION = "TrollTech Makefile Generator" | ||
2 | PRIORITY = "optional" | ||
3 | HOMEPAGE = "http://www.trolltech.com" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPL QPL" | ||
6 | PR = "r4" | ||
7 | |||
8 | QTEVER = "qt-embedded-free-3.3.5" | ||
9 | |||
10 | SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTEVER}.tar.bz2 \ | ||
11 | file://linux-oe-qmake.conf" | ||
12 | S = "${WORKDIR}/${QTEVER}" | ||
13 | |||
14 | inherit autotools native | ||
15 | |||
16 | export QTDIR = "${S}" | ||
17 | EXTRA_OEMAKE = "-e" | ||
18 | |||
19 | do_configure() { | ||
20 | # Install the OE build templates | ||
21 | for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ | ||
22 | do | ||
23 | install -d ${S}/mkspecs/$template | ||
24 | install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf | ||
25 | ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h | ||
26 | done | ||
27 | QMAKESPEC= | ||
28 | PLATFORM=${HOST_OS}-oe-g++ | ||
29 | export PLATFORM | ||
30 | oenote ./configure ${EXTRA_OECONF} | ||
31 | echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed" | ||
32 | } | ||
33 | |||
34 | do_compile() { | ||
35 | : | ||
36 | } | ||
37 | |||
38 | do_install() { | ||
39 | install -d ${D}${bindir}/ | ||
40 | install -m 0755 ${S}/bin/qmake ${D}${bindir}/ | ||
41 | install -d ${D}/qmake/ | ||
42 | cp -fPR ${S}/mkspecs/* ${D}/qmake/ | ||
43 | } | ||
44 | |||
45 | sysroot_stage_all_append() { | ||
46 | sysroot_stage_dir ${D}/qmake ${SYSROOT_DESTDIR}/${QMAKE_MKSPEC_PATH} | ||
47 | } | ||