summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb')
-rw-r--r--meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb b/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
new file mode 100644
index 0000000000..37d5b2158b
--- /dev/null
+++ b/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "A Moblin specific plugin for the Mutter composite window manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv3"
4DEPENDS = "nbtk mutter gnome-menus mojito libjana anerley clutter-mozembed"
5PV = "2.25.2+git${SRCPV}"
6PR = "r3"
7
8SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
9 file://startup-notify.patch;patch=1 \
10 file://background-tile.png"
11
12FILES_${PN} += "${libdir}/metacity/plugins/clutter/*.so* ${datadir}/mutter-moblin-netbook-plugin"
13FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
14
15S = "${WORKDIR}/git"
16
17ASNEEDED = ""
18
19EXTRA_OECONF = "--enable-ahoghill --enable-netpanel --enable-people"
20
21inherit autotools_stage
22
23do_configure_prepend () {
24 rm -f ${S}/build/autotools/gtk-doc.m4
25 cp ${WORKDIR}/background-tile.png ${S}/data/theme/panel/
26}
27
28pkg_postinst_${PN} () {
29#!/bin/sh -e
30if [ "x$D" != "x" ]; then
31 exit 1
32fi
33
34. ${sysconfdir}/init.d/functions
35
36gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[moblin-netbook]'
37}