summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/mozilla-headless/mozilla-headless/configurefix-1a622cb7c384.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/mozilla-headless/mozilla-headless/configurefix-1a622cb7c384.patch')
-rw-r--r--meta-moblin/packages/mozilla-headless/mozilla-headless/configurefix-1a622cb7c384.patch764
1 files changed, 764 insertions, 0 deletions
diff --git a/meta-moblin/packages/mozilla-headless/mozilla-headless/configurefix-1a622cb7c384.patch b/meta-moblin/packages/mozilla-headless/mozilla-headless/configurefix-1a622cb7c384.patch
new file mode 100644
index 0000000000..d31f91a42d
--- /dev/null
+++ b/meta-moblin/packages/mozilla-headless/mozilla-headless/configurefix-1a622cb7c384.patch
@@ -0,0 +1,764 @@
1Index: offscreen/configure.in
2===================================================================
3--- offscreen.orig/configure.in 2009-06-12 14:15:55.000000000 +0100
4+++ offscreen/configure.in 2009-06-12 14:15:55.000000000 +0100
5@@ -62,7 +62,6 @@
6
7 AC_PREREQ(2.13)
8 AC_INIT(config/config.mk)
9-AC_CONFIG_AUX_DIR(${srcdir}/build/autoconf)
10 AC_CANONICAL_SYSTEM
11 TARGET_CPU="${target_cpu}"
12 TARGET_VENDOR="${target_vendor}"
13@@ -103,7 +102,6 @@
14 _SUBDIR_HOST_CFLAGS="$HOST_CFLAGS"
15 _SUBDIR_HOST_CXXFLAGS="$HOST_CXXFLAGS"
16 _SUBDIR_HOST_LDFLAGS="$HOST_LDFLAGS"
17-_SUBDIR_CONFIG_ARGS="$ac_configure_args"
18
19 dnl Set the version number of the libs included with mozilla
20 dnl ========================================================
21@@ -135,6 +133,9 @@
22
23 MSMANIFEST_TOOL=
24
25+ac_cv_have_usable_wchar_v2=no
26+ac_cv_have_usable_wchar_option_v2=no
27+
28 dnl Set various checks
29 dnl ========================================================
30 MISSING_X=
31@@ -285,7 +286,7 @@
32 ;;
33 esac
34
35-if test -n "$CROSS_COMPILE" && test "$target" != "$host"; then
36+
37 echo "cross compiling from $host to $target"
38 cross_compiling=yes
39
40@@ -323,7 +324,7 @@
41
42 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
43 AC_TRY_COMPILE([], [return(0);],
44- [ac_cv_prog_hostcc_works=1 AC_MSG_RESULT([yes])],
45+ [ac_cv_prog_hostcc_works=1; AC_MSG_RESULT([yes])],
46 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
47
48 CC="$HOST_CXX"
49@@ -331,7 +332,7 @@
50
51 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
52 AC_TRY_COMPILE([], [return(0);],
53- [ac_cv_prog_hostcxx_works=1 AC_MSG_RESULT([yes])],
54+ [ac_cv_prog_hostcxx_works=1; AC_MSG_RESULT([yes])],
55 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
56
57 CC=$_SAVE_CC
58@@ -352,7 +353,7 @@
59 ;;
60 esac
61
62- AC_CHECK_PROGS(CC, $CC "${target_alias}-gcc" "${target}-gcc", :)
63+ CC="${target_alias}-gcc"
64 unset ac_cv_prog_CC
65 AC_PROG_CC
66 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
67@@ -376,37 +377,6 @@
68 AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", :)
69 AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", :)
70 AC_DEFINE(CROSS_COMPILE)
71-else
72- AC_PROG_CC
73- AC_PROG_CXX
74- AC_PROG_RANLIB
75- MOZ_PATH_PROGS(AS, $AS as, $CC)
76- AC_CHECK_PROGS(AR, ar, :)
77- AC_CHECK_PROGS(LD, ld, :)
78- AC_CHECK_PROGS(STRIP, strip, :)
79- AC_CHECK_PROGS(WINDRES, windres, :)
80- if test -z "$HOST_CC"; then
81- HOST_CC="$CC"
82- fi
83- if test -z "$HOST_CFLAGS"; then
84- HOST_CFLAGS="$CFLAGS"
85- fi
86- if test -z "$HOST_CXX"; then
87- HOST_CXX="$CXX"
88- fi
89- if test -z "$HOST_CXXFLAGS"; then
90- HOST_CXXFLAGS="$CXXFLAGS"
91- fi
92- if test -z "$HOST_LDFLAGS"; then
93- HOST_LDFLAGS="$LDFLAGS"
94- fi
95- if test -z "$HOST_RANLIB"; then
96- HOST_RANLIB="$RANLIB"
97- fi
98- if test -z "$HOST_AR"; then
99- HOST_AR="$AR"
100- fi
101-fi
102
103 GNU_AS=
104 GNU_LD=
105@@ -1606,6 +1576,7 @@
106 '
107
108 dnl test that the macros actually work:
109+ac_cv_static_assertion_macros_work="yes"
110 AC_MSG_CHECKING(that static assertion macros used in autoconf tests work)
111 AC_CACHE_VAL(ac_cv_static_assertion_macros_work,
112 [AC_LANG_SAVE
113@@ -2767,9 +2738,13 @@
114 AC_LANG_C
115 AC_HEADER_STDC
116 AC_C_CONST
117+ac_cv_type_mode_t=yes
118 AC_TYPE_MODE_T
119+ac_cv_type_off_t=yes
120 AC_TYPE_OFF_T
121+ac_cv_type_pid_t=yes
122 AC_TYPE_PID_T
123+ac_cv_type_size_t=yes
124 AC_TYPE_SIZE_T
125 AC_STRUCT_ST_BLKSIZE
126 AC_MSG_CHECKING(for siginfo_t)
127@@ -3152,19 +3127,9 @@
128 dnl We don't want to link against libm or libpthread on Darwin since
129 dnl they both are just symlinks to libSystem and explicitly linking
130 dnl against libSystem causes issues when debugging (see bug 299601).
131-case $target in
132-*-darwin*)
133- ;;
134-*-beos*)
135- ;;
136-*)
137 AC_CHECK_LIB(m, atan)
138 AC_CHECK_LIB(dl, dlopen,
139- AC_CHECK_HEADER(dlfcn.h,
140- LIBS="-ldl $LIBS"
141- AC_DEFINE(HAVE_LIBDL)))
142- ;;
143-esac
144+ AC_DEFINE(HAVE_LIBDL))
145
146 _SAVE_CFLAGS="$CFLAGS"
147 CFLAGS="$CFLAGS -D_GNU_SOURCE"
148@@ -7007,18 +6972,13 @@
149
150 # Demangle only for debug or trace-malloc builds
151 MOZ_DEMANGLE_SYMBOLS=
152-if test "$HAVE_DEMANGLE" -a "$HAVE_GCC3_ABI" && test "$MOZ_DEBUG" -o "$NS_TRACE_MALLOC"; then
153- MOZ_DEMANGLE_SYMBOLS=1
154- AC_DEFINE(MOZ_DEMANGLE_SYMBOLS)
155-fi
156+
157 AC_SUBST(MOZ_DEMANGLE_SYMBOLS)
158
159 dnl ========================================================
160 dnl = Support for gcc stack unwinding (from gcc 3.3)
161 dnl ========================================================
162-if test "$HAVE_GCC3_ABI" && test -z "$SKIP_LIBRARY_CHECKS"; then
163- AC_CHECK_HEADER(unwind.h, AC_CHECK_FUNCS(_Unwind_Backtrace))
164-fi
165+
166
167 dnl ========================================================
168 dnl =
169@@ -7530,10 +7490,7 @@
170 dnl if no gtk/libIDL1 or gtk2/libIDL2 combination was found, fall back
171 dnl to either libIDL1 or libIDL2.
172 if test -z "$_LIBIDL_FOUND"; then
173- AM_PATH_LIBIDL($LIBIDL_VERSION,_LIBIDL_FOUND=1)
174- if test -z "$_LIBIDL_FOUND"; then
175 PKG_CHECK_MODULES(LIBIDL, libIDL-2.0 >= 0.8.0,_LIBIDL_FOUND=1)
176- fi
177 fi
178 dnl
179 dnl If we don't have a libIDL config program & not cross-compiling,
180@@ -7605,13 +7562,7 @@
181 fi
182
183 if test -z "$SKIP_PATH_CHECKS"; then
184-if test -z "${GLIB_CFLAGS}" || test -z "${GLIB_LIBS}" ; then
185- if test "$MOZ_ENABLE_GTK2" || test "$USE_ELF_DYNSTR_GC" || test "$MOZ_ENABLE_HEADLESS"; then
186 PKG_CHECK_MODULES(GLIB, glib-2.0 >= 1.3.7 gobject-2.0)
187- else
188- AM_PATH_GLIB(${GLIB_VERSION})
189- fi
190-fi
191 fi
192
193 if test -z "${GLIB_GMODULE_LIBS}" -a -n "${GLIB_CONFIG}"; then
194@@ -8457,10 +8408,7 @@
195 HAVE_WCRTOMB
196 "
197
198-AC_CONFIG_HEADER(
199-netwerk/necko-config.h
200-xpcom/xpcom-config.h
201-xpcom/xpcom-private.h
202+AC_CONFIG_HEADER(netwerk/necko-config.h xpcom/xpcom-config.h xpcom/xpcom-private.h
203 )
204
205 # Save the defines header file before autoconf removes it.
206@@ -8519,31 +8467,11 @@
207 dnl To add new Makefiles, edit allmakefiles.sh.
208 dnl allmakefiles.sh sets the variable, MAKEFILES.
209 . ${srcdir}/allmakefiles.sh
210-dnl
211-dnl Run a perl script to quickly create the makefiles.
212-dnl If it succeeds, it outputs a shell command to set CONFIG_FILES
213-dnl for the files it cannot handle correctly. This way, config.status
214-dnl will handle these files.
215-dnl If it fails, nothing is set and config.status will run as usual.
216-dnl
217-dnl This does not change the $MAKEFILES variable.
218-dnl
219-dnl OpenVMS gets a line overflow on the long eval command, so use a temp file.
220-dnl
221-if test -z "${AS_PERL}"; then
222-echo $MAKEFILES | ${PERL} $srcdir/build/autoconf/acoutput-fast.pl > conftest.sh
223-else
224-echo $MAKEFILES | ${PERL} $srcdir/build/autoconf/acoutput-fast.pl -nowrap --cygwin-srcdir=$srcdir > conftest.sh
225-fi
226-. ./conftest.sh
227-rm conftest.sh
228
229 echo $MAKEFILES > unallmakefiles
230
231 mv -f config/autoconf.mk config/autoconf.mk.orig 2> /dev/null
232
233-AC_OUTPUT($MAKEFILES)
234-
235 dnl Prevent the regeneration of cairo-features.h forcing rebuilds of gfx stuff
236 if test "$CAIRO_FEATURES_H"; then
237 if cmp -s $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig; then
238@@ -8569,14 +8497,14 @@
239 HOST_LDFLAGS="$_SUBDIR_HOST_LDFLAGS"
240 RC=
241
242-unset MAKEFILES
243-unset CONFIG_FILES
244+#unset MAKEFILES
245+#unset CONFIG_FILES
246
247 # No need to run subconfigures when building with LIBXUL_SDK_DIR
248 if test "$COMPILE_ENVIRONMENT" -a -z "$LIBXUL_SDK_DIR"; then
249
250 if test -z "$MOZ_NATIVE_NSPR"; then
251- ac_configure_args="$_SUBDIR_CONFIG_ARGS --with-dist-prefix=$MOZ_BUILD_ROOT/dist --with-mozilla"
252+ ac_configure_args="$ac_configure_args --with-dist-prefix=$MOZ_BUILD_ROOT/dist --with-mozilla"
253 if test -z "$MOZ_DEBUG"; then
254 ac_configure_args="$ac_configure_args --disable-debug"
255 fi
256@@ -8592,8 +8520,7 @@
257 if test -n "$USE_ARM_KUSER"; then
258 ac_configure_args="$ac_configure_args --with-arm-kuser"
259 fi
260- AC_OUTPUT_SUBDIRS(nsprpub)
261- ac_configure_args="$_SUBDIR_CONFIG_ARGS"
262+ AC_CONFIG_SUBDIRS(nsprpub)
263 fi
264
265 if test -z "$MOZ_NATIVE_NSPR"; then
266@@ -8610,7 +8537,6 @@
267
268 # Run the SpiderMonkey 'configure' script.
269 dist=$MOZ_BUILD_ROOT/dist
270-ac_configure_args="$_SUBDIR_CONFIG_ARGS"
271 ac_configure_args="$ac_configure_args --enable-threadsafe"
272 if test -z "$MOZ_NATIVE_NSPR"; then
273 ac_configure_args="$ac_configure_args --with-nspr-cflags='$NSPR_CFLAGS'"
274@@ -8627,11 +8553,14 @@
275 export MOZ_MEMORY_LDFLAGS
276 fi
277 fi
278-AC_OUTPUT_SUBDIRS(js/src)
279-ac_configure_args="$_SUBDIR_CONFIG_ARGS"
280+AC_CONFIG_SUBDIRS(js/src)
281
282 fi # COMPILE_ENVIRONMENT && !LIBXUL_SDK_DIR
283
284+m4_pattern_allow(AS_BIN)
285+
286+AC_OUTPUT($MAKEFILES)
287+
288 dnl Prevent the regeneration of autoconf.mk forcing rebuilds of the world
289 dnl Needs to be at the end to respect possible changes from NSPR configure
290 if cmp -s config/autoconf.mk config/autoconf.mk.orig; then
291Index: offscreen/js/src/configure.in
292===================================================================
293--- offscreen.orig/js/src/configure.in 2009-06-12 14:15:55.000000000 +0100
294+++ offscreen/js/src/configure.in 2009-06-12 14:15:55.000000000 +0100
295@@ -62,7 +62,6 @@
296
297 AC_PREREQ(2.13)
298 AC_INIT(jsapi.h)
299-AC_CONFIG_AUX_DIR(${srcdir}/build/autoconf)
300 AC_CONFIG_HEADER(js-config.h)
301 AC_CANONICAL_SYSTEM
302 TARGET_CPU="${target_cpu}"
303@@ -101,6 +100,9 @@
304 _SUBDIR_HOST_LDFLAGS="$HOST_LDFLAGS"
305 _SUBDIR_CONFIG_ARGS="$ac_configure_args"
306
307+ac_cv_have_usable_wchar_v2=no
308+ac_cv_have_usable_wchar_option_v2=no
309+
310 dnl Set the version number of the libs included with mozilla
311 dnl ========================================================
312 NSPR_VERSION=4
313@@ -113,6 +115,8 @@
314
315 MSMANIFEST_TOOL=
316
317+m4_pattern_allow(AS_BIN)
318+
319 dnl Set various checks
320 dnl ========================================================
321 MISSING_X=
322@@ -198,7 +202,7 @@
323
324 if test "$COMPILE_ENVIRONMENT"; then
325
326-if test "$target" != "$host"; then
327+
328 echo "cross compiling from $host to $target"
329
330 _SAVE_CC="$CC"
331@@ -235,7 +239,7 @@
332
333 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
334 AC_TRY_COMPILE([], [return(0);],
335- [ac_cv_prog_hostcc_works=1 AC_MSG_RESULT([yes])],
336+ [ac_cv_prog_hostcc_works=1; AC_MSG_RESULT([yes])],
337 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
338
339 CC="$HOST_CXX"
340@@ -243,7 +247,7 @@
341
342 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
343 AC_TRY_COMPILE([], [return(0);],
344- [ac_cv_prog_hostcxx_works=1 AC_MSG_RESULT([yes])],
345+ [ac_cv_prog_hostcxx_works=1; AC_MSG_RESULT([yes])],
346 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
347
348 CC=$_SAVE_CC
349@@ -298,7 +302,7 @@
350 ;;
351 esac
352
353- AC_CHECK_PROGS(CC, $CC "${target_alias}-gcc" "${target}-gcc", :)
354+ CC="${target_alias}-gcc"
355 unset ac_cv_prog_CC
356 AC_PROG_CC
357 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
358@@ -328,37 +332,6 @@
359 dnl able to run ppc code in a translated environment, making a cross
360 dnl compiler appear native. So we override that here.
361 cross_compiling=yes
362-else
363- AC_PROG_CC
364- AC_PROG_CXX
365- AC_PROG_RANLIB
366- MOZ_PATH_PROGS(AS, $AS as, $CC)
367- AC_CHECK_PROGS(AR, ar, :)
368- AC_CHECK_PROGS(LD, ld, :)
369- AC_CHECK_PROGS(STRIP, strip, :)
370- AC_CHECK_PROGS(WINDRES, windres, :)
371- if test -z "$HOST_CC"; then
372- HOST_CC="$CC"
373- fi
374- if test -z "$HOST_CFLAGS"; then
375- HOST_CFLAGS="$CFLAGS"
376- fi
377- if test -z "$HOST_CXX"; then
378- HOST_CXX="$CXX"
379- fi
380- if test -z "$HOST_CXXFLAGS"; then
381- HOST_CXXFLAGS="$CXXFLAGS"
382- fi
383- if test -z "$HOST_LDFLAGS"; then
384- HOST_LDFLAGS="$LDFLAGS"
385- fi
386- if test -z "$HOST_RANLIB"; then
387- HOST_RANLIB="$RANLIB"
388- fi
389- if test -z "$HOST_AR"; then
390- HOST_AR="$AR"
391- fi
392-fi
393
394 GNU_AS=
395 GNU_LD=
396@@ -1424,6 +1397,8 @@
397 fi # GNU_CC
398 fi # COMPILE_ENVIRONMENT
399
400+ac_cv_static_assertion_macros_work=yes
401+
402 dnl =================================================================
403 dnl Set up and test static assertion macros used to avoid AC_TRY_RUN,
404 dnl which is bad when cross compiling.
405@@ -2579,9 +2554,13 @@
406 AC_LANG_C
407 AC_HEADER_STDC
408 AC_C_CONST
409+ac_cv_type_mode_t=yes
410 AC_TYPE_MODE_T
411+ac_cv_type_off_t=yes
412 AC_TYPE_OFF_T
413+ac_cv_type_pid_t=yes
414 AC_TYPE_PID_T
415+ac_cv_type_size_t=yes
416 AC_TYPE_SIZE_T
417 AC_STRUCT_ST_BLKSIZE
418 AC_MSG_CHECKING(for siginfo_t)
419@@ -2606,7 +2585,8 @@
420
421 AC_CHECK_HEADER(stdint.h)
422 if test "$ac_cv_header_stdint_h" = yes; then
423- AC_DEFINE(JS_HAVE_STDINT_H)
424+ AC_DEFINE(JS_HAVE_STDINT_H, 1, [have stdint.h])
425+ AC_DEFINE(HAVE_STDINT_H)
426 else
427 dnl We'll figure them out for ourselves. List more likely types
428 dnl earlier. If we ever really encounter a size for which none of
429@@ -3004,10 +2984,7 @@
430 ;;
431 *)
432 AC_CHECK_LIB(m, atan)
433- AC_CHECK_LIB(dl, dlopen,
434- AC_CHECK_HEADER(dlfcn.h,
435- LIBS="-ldl $LIBS"
436- AC_DEFINE(HAVE_LIBDL)))
437+ AC_CHECK_LIB(dl, dlopen, AC_DEFINE(HAVE_LIBDL))
438 ;;
439 esac
440
441@@ -3903,6 +3880,7 @@
442 [ --with-nspr-libs=LIBS Pass LIBS to LD when linking code that uses NSPR.
443 See --with-nspr-cflags for more details.],
444 NSPR_LIBS=$withval)
445+$NSPR_LIBS="$NSPR_LIBS -L$(LIBXUL_DIST)/sdk/lib"
446 AC_SUBST(NSPR_CFLAGS)
447 AC_SUBST(NSPR_LIBS)
448
449@@ -4512,18 +4490,11 @@
450
451 # Demangle only for debug or trace-malloc builds
452 MOZ_DEMANGLE_SYMBOLS=
453-if test "$HAVE_DEMANGLE" -a "$HAVE_GCC3_ABI" && test "$MOZ_DEBUG" -o "$NS_TRACE_MALLOC"; then
454- MOZ_DEMANGLE_SYMBOLS=1
455- AC_DEFINE(MOZ_DEMANGLE_SYMBOLS)
456-fi
457 AC_SUBST(MOZ_DEMANGLE_SYMBOLS)
458
459 dnl ========================================================
460 dnl = Support for gcc stack unwinding (from gcc 3.3)
461 dnl ========================================================
462-if test "$HAVE_GCC3_ABI" && test -z "$SKIP_LIBRARY_CHECKS"; then
463- AC_CHECK_HEADER(unwind.h, AC_CHECK_FUNCS(_Unwind_Backtrace))
464-fi
465
466 dnl ========================================================
467 dnl =
468@@ -5231,6 +5202,8 @@
469 done
470 AC_SUBST(LIBS_PATH)
471
472+
473+
474 dnl ========================================================
475 dnl JavaScript shell
476 dnl ========================================================
477@@ -5371,3 +5344,4 @@
478 # 'js-config' in Makefile.in.
479 AC_MSG_RESULT(invoking make to create js-config script)
480 $MAKE js-config
481+
482Index: offscreen/nsprpub/configure.in
483===================================================================
484--- offscreen.orig/nsprpub/configure.in 2009-06-12 14:15:55.000000000 +0100
485+++ offscreen/nsprpub/configure.in 2009-06-12 14:15:55.000000000 +0100
486@@ -42,7 +42,6 @@
487 AC_PREREQ(2.12)
488 AC_INIT(config/libc_r.h)
489
490-AC_CONFIG_AUX_DIR(${srcdir}/build/autoconf)
491 AC_CANONICAL_SYSTEM
492
493 dnl ========================================================
494@@ -396,7 +395,7 @@
495 dnl ========================================================
496 dnl Checks for compilers.
497 dnl ========================================================
498-if test "$target" != "$host"; then
499+
500 echo "cross compiling from $host to $target"
501 cross_compiling=yes
502
503@@ -423,7 +422,7 @@
504
505 AC_MSG_CHECKING([whether the $host compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
506 AC_TRY_COMPILE([], [return(0);],
507- [ac_cv_prog_host_cc_works=1 AC_MSG_RESULT([yes])],
508+ [ac_cv_prog_host_cc_works=1; AC_MSG_RESULT([yes])],
509 AC_MSG_ERROR([installation or configuration problem: $host compiler $HOST_CC cannot create executables.]) )
510
511 CC=$_SAVE_CC
512@@ -444,7 +443,7 @@
513 ;;
514 esac
515
516- AC_CHECK_PROGS(CC, $CC "${target_alias}-gcc" "${target}-gcc", echo)
517+ CC="${target_alias}-gcc"
518 unset ac_cv_prog_CC
519 AC_PROG_CC
520 if test -n "$USE_CPLUS"; then
521@@ -470,30 +469,6 @@
522 AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", echo)
523 AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", echo)
524
525-else
526- AC_PROG_CC
527- if test -n "$USE_CPLUS"; then
528- if test "$CC" = "cl" -a -z "$CXX"; then
529- CXX=$CC
530- else
531- AC_PROG_CXX
532- fi
533- fi
534- AC_PROG_CPP
535- AC_PROG_RANLIB
536- AC_PATH_PROGS(AS, as, $CC)
537- AC_PATH_PROGS(AR, ar, echo not_ar)
538- AC_PATH_PROGS(LD, ld link, echo not_ld)
539- AC_PATH_PROGS(STRIP, strip, echo not_strip)
540- AC_PATH_PROGS(WINDRES, windres, echo not_windres)
541- if test -z "$HOST_CC"; then
542- HOST_CC="$CC"
543- fi
544- if test -z "$HOST_CFLAGS"; then
545- HOST_CFLAGS="$CFLAGS"
546- fi
547-fi
548-
549 if test "$GCC" = "yes"; then
550 GNU_CC=1
551 fi
552@@ -514,11 +489,8 @@
553 ;;
554 esac
555
556-if test "$cross_compiling" = "yes"; then
557+
558 CROSS_COMPILE=1
559-else
560- CROSS_COMPILE=
561-fi
562
563 dnl ========================================================
564 dnl Check for gcc -pipe support
565@@ -2283,10 +2255,7 @@
566 *-darwin*|*-beos*)
567 ;;
568 *)
569- AC_CHECK_LIB(dl, dlopen,
570- AC_CHECK_HEADER(dlfcn.h,
571- OS_LIBS="-ldl $OS_LIBS"))
572- ;;
573+ AC_CHECK_LIB(dl, dlopen)
574 esac
575
576
577@@ -2904,6 +2873,8 @@
578 dnl pr/tests/w16gui/Makefile
579 dnl tools/Makefile
580
581+m4_pattern_allow(AS_BIN)
582+
583 if test -z "$USE_PTHREADS" && test -z "$USE_BTHREADS"; then
584 MAKEFILES="$MAKEFILES pr/src/threads/combined/Makefile"
585 elif test -n "$USE_PTHREADS"; then
586@@ -2919,3 +2890,5 @@
587 echo $MAKEFILES > unallmakefiles
588
589 AC_OUTPUT([$MAKEFILES], [chmod +x config/nspr-config])
590+
591+
592Index: offscreen/js/src/Makefile.in
593===================================================================
594--- offscreen.orig/js/src/Makefile.in 2009-06-12 14:15:55.000000000 +0100
595+++ offscreen/js/src/Makefile.in 2009-06-12 14:15:55.000000000 +0100
596@@ -514,20 +514,8 @@
597
598 export:: jsautocfg.h
599
600-ifeq (,$(CROSS_COMPILE)$(GNU_CC)$(filter-out WINNT,$(OS_ARCH)))
601 jsautocfg.h:
602 touch $@
603-else
604-ifeq ($(OS_ARCH),WINCE)
605-jsautocfg.h:
606- touch $@
607-else
608-jsautocfg.h: jscpucfg$(HOST_BIN_SUFFIX)
609- @rm -f $@ jsautocfg.tmp
610- ./jscpucfg > jsautocfg.tmp
611- mv jsautocfg.tmp $@
612-endif
613-endif
614
615 # jscpucfg is a strange target
616 # Needs to be built with the host compiler but needs to include
617@@ -557,7 +545,7 @@
618 echo no need to build jscpucfg $<
619 else
620 jscpucfg$(HOST_BIN_SUFFIX): jscpucfg.cpp Makefile.in
621- $(HOST_CXX) $(HOST_CXXFLAGS) $(JSCPUCFG_DEFINES) $(DEFINES) $(NSPR_CFLAGS) $(HOST_OUTOPTION)$@ $<
622+ $(HOST_CXX) $(HOST_CXXFLAGS) $(JSCPUCFG_DEFINES) $(DEFINES) -I$(DIST)/sdk/include $(NSPR_CFLAGS) $(HOST_OUTOPTION)$@ $<
623 endif
624 endif
625
626Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp
627===================================================================
628--- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-06-12 14:15:55.000000000 +0100
629+++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-06-12 14:15:55.000000000 +0100
630@@ -47,6 +47,8 @@
631
632 #include <stdarg.h>
633
634+#include "mozilla-config.h"
635+
636 #include "prlog.h"
637
638 #include "nsCOMPtr.h"
639Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
640===================================================================
641--- offscreen.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-06-12 14:15:55.000000000 +0100
642+++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-06-12 14:15:55.000000000 +0100
643@@ -39,6 +39,8 @@
644 *
645 * ***** END LICENSE BLOCK ***** */
646
647+#include "mozilla-config.h"
648+
649 #if !defined(XPCONNECT_STANDALONE) && !defined(NO_SUBSCRIPT_LOADER)
650
651 #include "mozJSSubScriptLoader.h"
652Index: offscreen/modules/lcms/include/icc34.h
653===================================================================
654--- offscreen.orig/modules/lcms/include/icc34.h 2009-06-12 14:15:55.000000000 +0100
655+++ offscreen/modules/lcms/include/icc34.h 2009-06-12 14:15:55.000000000 +0100
656@@ -144,7 +144,7 @@
657 */
658
659
660-#ifdef PACKAGE_NAME
661+#if 0
662 /*
663 June 9, 2003, Adapted for use with configure by Bob Friesenhahn
664 Added the stupid check for autoconf by Marti Maria.
665Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in
666===================================================================
667--- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-06-12 14:15:55.000000000 +0100
668+++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-06-12 14:15:55.000000000 +0100
669@@ -60,7 +60,7 @@
670
671 LIBS += \
672 $(DEPTH)/modules/libmar/src/$(LIB_PREFIX)mar.$(LIB_SUFFIX) \
673- $(BZ2_LIBS) \
674+ $(BZ2_LIBS) -lpthread \
675 $(NULL)
676
677 ifeq ($(OS_ARCH),WINNT)
678Index: offscreen/xpcom/sample/program/Makefile.in
679===================================================================
680--- offscreen.orig/xpcom/sample/program/Makefile.in 2009-06-12 14:15:55.000000000 +0100
681+++ offscreen/xpcom/sample/program/Makefile.in 2009-06-12 14:15:55.000000000 +0100
682@@ -57,7 +57,7 @@
683 # that the application be linked against the XPCOM dynamic library or the NSPR
684 # dynamic libraries.
685 LIBS = \
686- $(XPCOM_STANDALONE_GLUE_LDOPTS) \
687+ $(XPCOM_STANDALONE_GLUE_LDOPTS) -ldl \
688 $(NULL)
689
690 # Need to link with CoreFoundation on Mac
691Index: offscreen/xpcom/tools/registry/Makefile.in
692===================================================================
693--- offscreen.orig/xpcom/tools/registry/Makefile.in 2009-06-12 14:15:55.000000000 +0100
694+++ offscreen/xpcom/tools/registry/Makefile.in 2009-06-12 14:15:55.000000000 +0100
695@@ -54,7 +54,7 @@
696 SIMPLE_PROGRAMS = $(CPPSRCS:.cpp=$(BIN_SUFFIX))
697
698 LIBS = \
699- $(XPCOM_STANDALONE_GLUE_LDOPTS) \
700+ $(XPCOM_STANDALONE_GLUE_LDOPTS) -ldl \
701 $(NULL)
702
703 # Need to link with CoreFoundation on Mac
704Index: offscreen/xulrunner/app/Makefile.in
705===================================================================
706--- offscreen.orig/xulrunner/app/Makefile.in 2009-06-12 14:15:55.000000000 +0100
707+++ offscreen/xulrunner/app/Makefile.in 2009-06-12 14:15:55.000000000 +0100
708@@ -184,7 +184,7 @@
709 RCFLAGS += -DXULRUNNER_ICO=\"$(DIST)/branding/xulrunner.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\"
710 endif
711
712-LIBS += $(JEMALLOC_LIBS)
713+LIBS += $(JEMALLOC_LIBS) -lpthread -ldl
714
715 include $(topsrcdir)/config/rules.mk
716
717Index: offscreen/xulrunner/stub/Makefile.in
718===================================================================
719--- offscreen.orig/xulrunner/stub/Makefile.in 2009-06-12 14:15:55.000000000 +0100
720+++ offscreen/xulrunner/stub/Makefile.in 2009-06-12 14:15:55.000000000 +0100
721@@ -101,7 +101,7 @@
722 endif
723 endif
724
725-LIBS += $(JEMALLOC_LIBS)
726+LIBS += $(JEMALLOC_LIBS) -lpthread -ldl
727
728 include $(topsrcdir)/config/rules.mk
729
730Index: offscreen/modules/plugin/test/testplugin/Makefile.in
731===================================================================
732--- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-06-12 14:15:55.000000000 +0100
733+++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-06-12 14:15:55.000000000 +0100
734@@ -63,9 +63,7 @@
735 CMMSRCS = nptest_macosx.mm
736 endif
737
738-ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
739 CPPSRCS += nptest_gtk2.cpp
740-endif
741
742 ifeq ($(MOZ_WIDGET_TOOLKIT),os2)
743 CPPSRCS += nptest_os2.cpp
744Index: offscreen/js/src/aclocal.m4
745===================================================================
746--- offscreen.orig/js/src/aclocal.m4 2009-06-12 14:15:55.000000000 +0100
747+++ offscreen/js/src/aclocal.m4 2009-06-12 14:15:55.000000000 +0100
748@@ -9,4 +9,3 @@
749 builtin(include, build/autoconf/moznbytetype.m4)dnl
750 builtin(include, build/autoconf/mozprog.m4)dnl
751
752-MOZ_PROG_CHECKMSYS()
753Index: offscreen/toolkit/toolkit-makefiles.sh
754===================================================================
755--- offscreen.orig/toolkit/toolkit-makefiles.sh 2009-06-12 14:19:59.000000000 +0100
756+++ offscreen/toolkit/toolkit-makefiles.sh 2009-06-12 14:20:09.000000000 +0100
757@@ -342,7 +342,6 @@
758 modules/plugin/sdk/samples/Makefile
759 modules/plugin/sdk/samples/common/Makefile
760 modules/plugin/sdk/samples/basic/windows/Makefile
761- modules/plugin/sdk/samples/basic/unix/Makefile
762 modules/plugin/sdk/samples/winless/windows/Makefile
763 "
764