diff options
Diffstat (limited to 'meta-moblin/packages/matchbox-netbook-session')
-rw-r--r-- | meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session | 4 | ||||
-rw-r--r-- | meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb | 57 |
2 files changed, 53 insertions, 8 deletions
diff --git a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session index 5cf9ee1bf3..79cf1af65a 100644 --- a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session +++ b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session | |||
@@ -1,5 +1,5 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | export LIBGL_ALWAYS_INDIRECT=1 | 3 | export LIBGL_ALWAYS_INDIRECT=1 |
4 | 4 | #--mutter-plugins=moblin-netbook | |
5 | exec metacity --mutter-plugins=moblin-netbook | 5 | exec /usr/bin/mutter |
diff --git a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb index 518e2d790b..a35dd8f875 100644 --- a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb +++ b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky" | |||
2 | LICENSE = "GPL" | 2 | LICENSE = "GPL" |
3 | SECTION = "x11" | 3 | SECTION = "x11" |
4 | RDEPENDS = "formfactor gtk-engines initscripts matchbox-session" | 4 | RDEPENDS = "formfactor gtk-engines initscripts matchbox-session" |
5 | PR = "r16" | 5 | PR = "r17" |
6 | 6 | ||
7 | # This package is architecture specific because the session script is modified | 7 | # This package is architecture specific because the session script is modified |
8 | # based on the machine architecture. | 8 | # based on the machine architecture. |
@@ -25,6 +25,7 @@ fi | |||
25 | 25 | ||
26 | . ${sysconfdir}/init.d/functions | 26 | . ${sysconfdir}/init.d/functions |
27 | 27 | ||
28 | |||
28 | # Theme | 29 | # Theme |
29 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 30 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
30 | --direct --type string -s \ | 31 | --direct --type string -s \ |
@@ -62,6 +63,25 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | |||
62 | --direct --type string -s \ | 63 | --direct --type string -s \ |
63 | /desktop/gnome/sound/theme_name moblin | 64 | /desktop/gnome/sound/theme_name moblin |
64 | 65 | ||
66 | # Screen shot | ||
67 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
68 | --direct --type string -s \ | ||
69 | /apps/metacity/global_keybindings/run_command_screenshot \ | ||
70 | "Print" | ||
71 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
72 | --direct --type string -s \ | ||
73 | /apps/metacity/keybinding_commands/command_screenshot \ | ||
74 | "gnome-screenshot" | ||
75 | |||
76 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
77 | --direct --type string -s \ | ||
78 | /apps/metacity/global_keybindings/run_command_window_screenshot \ | ||
79 | "<Alt>Print" | ||
80 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
81 | --direct --type string -s \ | ||
82 | /apps/metacity/keybinding_commands/command_window_screenshot \ | ||
83 | "gnome-screenshot --window" | ||
84 | |||
65 | # Window Actions | 85 | # Window Actions |
66 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 86 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
67 | --direct --type string -s \ | 87 | --direct --type string -s \ |
@@ -73,14 +93,15 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | |||
73 | --direct --type string -s \ | 93 | --direct --type string -s \ |
74 | /apps/metacity/general/action_right_click_titlebar "none" | 94 | /apps/metacity/general/action_right_click_titlebar "none" |
75 | 95 | ||
96 | |||
76 | # UX Shell | 97 | # UX Shell |
77 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 98 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
78 | --direct --type bool -s \ | 99 | --direct --type bool -s \ |
79 | /apps/metacity/general/clutter_disabled false | 100 | /apps/mutter/general/clutter_disabled false |
80 | 101 | ||
81 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 102 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
82 | --direct --type list --list-type string -s \ | 103 | --direct --type list --list-type string -s \ |
83 | /apps/metacity/general/clutter_plugins '[moblin-netbook]' | 104 | /apps/mutter/general/clutter_plugins '[moblin-netbook]' |
84 | 105 | ||
85 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 106 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
86 | --direct --type string -s \ | 107 | --direct --type string -s \ |
@@ -93,7 +114,7 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | |||
93 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 114 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
94 | --direct --type string -s \ | 115 | --direct --type string -s \ |
95 | /desktop/gnome/background/picture_filename \ | 116 | /desktop/gnome/background/picture_filename \ |
96 | '/usr/share/mutter-moblin/theme/myzone/toys.jpg' | 117 | '/usr/share/mutter-moblin/theme/moblin-panel-myzone/toys.jpg' |
97 | 118 | ||
98 | # Fonts | 119 | # Fonts |
99 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 120 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
@@ -118,16 +139,40 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | |||
118 | 139 | ||
119 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 140 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
120 | --direct --type bool -s \ | 141 | --direct --type bool -s \ |
121 | /apps/nautilus/icon_view/labels_beside_icons true | 142 | /apps/nautilus/preferences/exit_with_last_window false |
143 | |||
144 | # Do not automount, this is done by g-s-d plugin | ||
145 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
146 | --direct --type bool -s \ | ||
147 | /apps/nautilus/preferences/media_automount false | ||
148 | |||
149 | # And should not open new window whenever media mounted | ||
150 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
151 | --direct --type bool -s \ | ||
152 | /apps/nautilus/preferences/media_automount_open false | ||
153 | |||
154 | |||
155 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
156 | --direct --type bool -s \ | ||
157 | /apps/nautilus/icon_view/labels_beside_icons false | ||
122 | 158 | ||
123 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 159 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
124 | --direct --type string -s \ | 160 | --direct --type string -s \ |
125 | /apps/nautilus/icon_view/default_zoom_level large | 161 | /apps/nautilus/icon_view/default_zoom_level standard |
126 | 162 | ||
127 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | 163 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ |
128 | --direct --type string -s \ | 164 | --direct --type string -s \ |
129 | /apps/gnome_settings_daemon/keybindings/power "" | 165 | /apps/gnome_settings_daemon/keybindings/power "" |
130 | 166 | ||
167 | # General | ||
168 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
169 | --direct --type float -s \ | ||
170 | /desktop/gnome/peripherals/mouse/mouse_acceleration 0.8 | ||
171 | |||
172 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
173 | --direct --type int -s \ | ||
174 | /desktop/gnome/peripherals/mouse/mouse_threshold 2 | ||
175 | |||
131 | # | 176 | # |
132 | # The interesting bit - we convert to run the system as the user "pokyuser" | 177 | # The interesting bit - we convert to run the system as the user "pokyuser" |
133 | # and setup this user account as needed | 178 | # and setup this user account as needed |