diff options
Diffstat (limited to 'meta-moblin/packages/linux/linux-moblin-2.6.31.5/linux-2.6-build-nonintconfig.patch')
-rw-r--r-- | meta-moblin/packages/linux/linux-moblin-2.6.31.5/linux-2.6-build-nonintconfig.patch | 142 |
1 files changed, 142 insertions, 0 deletions
diff --git a/meta-moblin/packages/linux/linux-moblin-2.6.31.5/linux-2.6-build-nonintconfig.patch b/meta-moblin/packages/linux/linux-moblin-2.6.31.5/linux-2.6-build-nonintconfig.patch new file mode 100644 index 0000000000..38de047249 --- /dev/null +++ b/meta-moblin/packages/linux/linux-moblin-2.6.31.5/linux-2.6-build-nonintconfig.patch | |||
@@ -0,0 +1,142 @@ | |||
1 | From e412ebbb8cea2aaf32f689ffc630b57cfe13bde5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alan Olsen <alanx.r.olsen@intel.com> | ||
3 | Date: Tue, 21 Jul 2009 13:14:25 -0700 | ||
4 | Subject: [PATCH] linux-2.6-build-nonintconfig.patch | ||
5 | |||
6 | Signed-off-by: Alan Olsen <alanx.r.olsen@intel.com> | ||
7 | --- | ||
8 | scripts/kconfig/Makefile | 5 +++++ | ||
9 | scripts/kconfig/conf.c | 36 ++++++++++++++++++++++++++++++++---- | ||
10 | 2 files changed, 37 insertions(+), 4 deletions(-) | ||
11 | |||
12 | diff --git a/scripts/kconfig/Makefile b/scripts/kconfig/Makefile | ||
13 | index 5ddf8be..a4365db 100644 | ||
14 | --- a/scripts/kconfig/Makefile | ||
15 | +++ b/scripts/kconfig/Makefile | ||
16 | @@ -28,6 +28,11 @@ oldconfig: $(obj)/conf | ||
17 | silentoldconfig: $(obj)/conf | ||
18 | $< -s $(Kconfig) | ||
19 | |||
20 | +nonint_oldconfig: $(obj)/conf | ||
21 | + $< -b $(Kconfig) | ||
22 | +loose_nonint_oldconfig: $(obj)/conf | ||
23 | + $< -B $(Kconfig) | ||
24 | + | ||
25 | # Create new linux.pot file | ||
26 | # Adjust charset to UTF-8 in .po file to accept UTF-8 in Kconfig files | ||
27 | # The symlink is used to repair a deficiency in arch/um | ||
28 | diff --git a/scripts/kconfig/conf.c b/scripts/kconfig/conf.c | ||
29 | index 3baaaec..2a81742 100644 | ||
30 | --- a/scripts/kconfig/conf.c | ||
31 | +++ b/scripts/kconfig/conf.c | ||
32 | @@ -23,6 +23,8 @@ enum { | ||
33 | ask_all, | ||
34 | ask_new, | ||
35 | ask_silent, | ||
36 | + dont_ask, | ||
37 | + dont_ask_dont_tell, | ||
38 | set_default, | ||
39 | set_yes, | ||
40 | set_mod, | ||
41 | @@ -40,6 +42,8 @@ static struct menu *rootEntry; | ||
42 | |||
43 | static char nohelp_text[] = N_("Sorry, no help available for this option yet.\n"); | ||
44 | |||
45 | +static int return_value = 0; | ||
46 | + | ||
47 | static const char *get_help(struct menu *menu) | ||
48 | { | ||
49 | if (menu_has_help(menu)) | ||
50 | @@ -360,7 +364,10 @@ static void conf(struct menu *menu) | ||
51 | |||
52 | switch (prop->type) { | ||
53 | case P_MENU: | ||
54 | - if (input_mode == ask_silent && rootEntry != menu) { | ||
55 | + if ((input_mode == ask_silent || | ||
56 | + input_mode == dont_ask || | ||
57 | + input_mode == dont_ask_dont_tell) && | ||
58 | + rootEntry != menu) { | ||
59 | check_conf(menu); | ||
60 | return; | ||
61 | } | ||
62 | @@ -418,12 +425,21 @@ static void check_conf(struct menu *menu) | ||
63 | if (sym && !sym_has_value(sym)) { | ||
64 | if (sym_is_changable(sym) || | ||
65 | (sym_is_choice(sym) && sym_get_tristate_value(sym) == yes)) { | ||
66 | + if (input_mode == dont_ask || | ||
67 | + input_mode == dont_ask_dont_tell) { | ||
68 | + if (input_mode == dont_ask && | ||
69 | + sym->name && !sym_is_choice_value(sym)) { | ||
70 | + fprintf(stderr,"CONFIG_%s\n",sym->name); | ||
71 | + ++return_value; | ||
72 | + } | ||
73 | + } else { | ||
74 | if (!conf_cnt++) | ||
75 | printf(_("*\n* Restart config...\n*\n")); | ||
76 | rootEntry = menu_get_parent_menu(menu); | ||
77 | conf(rootEntry); | ||
78 | } | ||
79 | } | ||
80 | + } | ||
81 | |||
82 | for (child = menu->list; child; child = child->next) | ||
83 | check_conf(child); | ||
84 | @@ -439,7 +455,7 @@ int main(int ac, char **av) | ||
85 | bindtextdomain(PACKAGE, LOCALEDIR); | ||
86 | textdomain(PACKAGE); | ||
87 | |||
88 | - while ((opt = getopt(ac, av, "osdD:nmyrh")) != -1) { | ||
89 | + while ((opt = getopt(ac, av, "osbBdD:nmyrh")) != -1) { | ||
90 | switch (opt) { | ||
91 | case 'o': | ||
92 | input_mode = ask_silent; | ||
93 | @@ -448,6 +464,12 @@ int main(int ac, char **av) | ||
94 | input_mode = ask_silent; | ||
95 | sync_kconfig = 1; | ||
96 | break; | ||
97 | + case 'b': | ||
98 | + input_mode = dont_ask; | ||
99 | + break; | ||
100 | + case 'B': | ||
101 | + input_mode = dont_ask_dont_tell; | ||
102 | + break; | ||
103 | case 'd': | ||
104 | input_mode = set_default; | ||
105 | break; | ||
106 | @@ -525,6 +547,8 @@ int main(int ac, char **av) | ||
107 | case ask_silent: | ||
108 | case ask_all: | ||
109 | case ask_new: | ||
110 | + case dont_ask: | ||
111 | + case dont_ask_dont_tell: | ||
112 | conf_read(NULL); | ||
113 | break; | ||
114 | case set_no: | ||
115 | @@ -586,12 +610,16 @@ int main(int ac, char **av) | ||
116 | conf(&rootmenu); | ||
117 | input_mode = ask_silent; | ||
118 | /* fall through */ | ||
119 | + case dont_ask: | ||
120 | + case dont_ask_dont_tell: | ||
121 | case ask_silent: | ||
122 | /* Update until a loop caused no more changes */ | ||
123 | do { | ||
124 | conf_cnt = 0; | ||
125 | check_conf(&rootmenu); | ||
126 | - } while (conf_cnt); | ||
127 | + } while (conf_cnt && | ||
128 | + (input_mode != dont_ask && | ||
129 | + input_mode != dont_ask_dont_tell)); | ||
130 | break; | ||
131 | } | ||
132 | |||
133 | @@ -613,5 +641,5 @@ int main(int ac, char **av) | ||
134 | exit(1); | ||
135 | } | ||
136 | } | ||
137 | - return 0; | ||
138 | + return return_value; | ||
139 | } | ||
140 | -- | ||
141 | 1.6.0.6 | ||
142 | |||