summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch')
-rw-r--r--meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch b/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
deleted file mode 100644
index eda77564ce..0000000000
--- a/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From: Arjan van de Ven <arjan@linux.intel.com>
2Date: Mon, 26 Jan 2009 18:58:11 -0800
3Subject: [PATCH] ide/net: flip the order of SATA and network init
4
5this patch flips the order in which sata and network drivers are initialized.
6
7SATA probing takes quite a bit of time, and with the asynchronous infrastructure
8other drivers that run after it can execute in parallel. Network drivers do tend
9to take some real time talking to the hardware, so running these later is
10a good thing (the sata probe then runs concurrent)
11
12This saves about 15% of my kernels boot time.
13
14Signed-off-by: Arjan van de Ven <arjan@linux.intel.com>
15---
16 drivers/Makefile | 5 +++--
17 1 files changed, 3 insertions(+), 2 deletions(-)
18
19diff --git a/drivers/Makefile b/drivers/Makefile
20index c1bf417..2618a61 100644
21--- a/drivers/Makefile
22+++ b/drivers/Makefile
23@@ -36,13 +36,14 @@
24 obj-$(CONFIG_FB_INTEL) += video/intelfb/
25 obj-y += serial/
26 obj-$(CONFIG_PARPORT) += parport/
27-obj-y += base/ block/ misc/ mfd/ net/ media/
28+obj-y += base/ block/ misc/ mfd/ media/
29 obj-$(CONFIG_NUBUS) += nubus/
30-obj-$(CONFIG_ATM) += atm/
31 obj-y += macintosh/
32 obj-$(CONFIG_IDE) += ide/
33 obj-$(CONFIG_SCSI) += scsi/
34 obj-$(CONFIG_ATA) += ata/
35+obj-y += net/
36+obj-$(CONFIG_ATM) += atm/
37 obj-$(CONFIG_FUSION) += message/
38 obj-$(CONFIG_FIREWIRE) += firewire/
39 obj-y += ieee1394/
40