diff options
Diffstat (limited to 'meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch')
-rw-r--r-- | meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch b/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch new file mode 100644 index 0000000000..b979f57cae --- /dev/null +++ b/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | --- a/Makefile 2010-07-20 18:51:32.000000000 +0800 | ||
2 | +++ b/Makefile 2010-07-20 18:54:54.000000000 +0800 | ||
3 | @@ -4,7 +4,8 @@ | ||
4 | DESTDIR = | ||
5 | SBINDIR = /usr/sbin | ||
6 | XCFLAGS = -W -g `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare | ||
7 | -LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncursesw | ||
8 | +LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncurses | ||
9 | +CC ?= gcc | ||
10 | |||
11 | OBJS= latencytop.o text_display.o translate.o fsync.o | ||
12 | |||
13 | @@ -26,16 +27,17 @@ | ||
14 | |||
15 | # We write explicity this "implicit rule" | ||
16 | %.o : %.c | ||
17 | - gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@ | ||
18 | + $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@ | ||
19 | |||
20 | latencytop: $(OBJS) latencytop.h Makefile | ||
21 | - gcc $(CFLAGS) $(OBJS) $(LDF) -o latencytop | ||
22 | + $(CC) $(CFLAGS) $(OBJS) $(LDF) -o latencytop | ||
23 | |||
24 | clean: | ||
25 | rm -f *~ latencytop DEADJOE *.o | ||
26 | |||
27 | install: latencytop | ||
28 | mkdir -p $(DESTDIR)/usr/share/latencytop | ||
29 | + mkdir -p $(DESTDIR)/$(SBINDIR) | ||
30 | install -m 0644 latencytop.trans $(DESTDIR)/usr/share/latencytop/latencytop.trans | ||
31 | install -m 0644 *.png $(DESTDIR)/usr/share/latencytop/ | ||
32 | install -m 0755 latencytop $(DESTDIR)$(SBINDIR)/ | ||