summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/gnet/files/configure_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/gnet/files/configure_fix.patch')
-rw-r--r--meta-moblin/packages/gnet/files/configure_fix.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta-moblin/packages/gnet/files/configure_fix.patch b/meta-moblin/packages/gnet/files/configure_fix.patch
deleted file mode 100644
index e6aadcc6a9..0000000000
--- a/meta-moblin/packages/gnet/files/configure_fix.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1Index: trunk/configure.ac
2===================================================================
3--- trunk.orig/configure.ac
4+++ trunk/configure.ac
5@@ -332,53 +332,6 @@ AC_DEFINE_UNQUOTED(GNET_SOCKADDR_FAMILY_
6 [$gnet_sockaddr_family_field_name],
7 [Name of sockaddr_storage family field])
8
9-dnl #######################################
10-dnl Check if abstract sockets are supported
11-dnl #######################################
12-
13-AC_LANG_PUSH(C)
14-AC_CACHE_CHECK([for abstract socket namespace availability],
15- ac_cv_gnet_have_abstract_sockets,
16- [AC_RUN_IFELSE([AC_LANG_PROGRAM(
17-[[
18-#include <sys/types.h>
19-#include <stdlib.h>
20-#include <string.h>
21-#include <stdio.h>
22-#include <sys/socket.h>
23-#include <sys/un.h>
24-#include <errno.h>
25-]],
26-[[
27- int listen_fd, len;
28- struct sockaddr_un addr;
29-
30- listen_fd = socket (PF_UNIX, SOCK_STREAM, 0);
31- if (listen_fd < 0) {
32- perror ("socket() failed: ");
33- exit (1);
34- }
35- memset (&addr, '\0', sizeof (addr));
36- addr.sun_family = AF_UNIX;
37- strcpy (addr.sun_path, "X/tmp/gnet-fake-socket-path-used-in-configure-test");
38- len = SUN_LEN (&addr); /* calculate size before adding the \0 */
39- addr.sun_path[0] = '\0'; /* this is what makes it abstract */
40-
41- if (bind (listen_fd, (struct sockaddr*) &addr, len) < 0) {
42- perror ("Abstract socket namespace bind() failed: ");
43- exit (1);
44- }
45- exit (0);
46-]])],
47- [ac_cv_gnet_have_abstract_sockets=yes],
48- [ac_cv_gnet_have_abstract_sockets=no]
49-)])
50-AC_LANG_POP(C)
51-
52-if test x$ac_cv_gnet_have_abstract_sockets = xyes ; then
53- AC_DEFINE(HAVE_ABSTRACT_SOCKETS,1,[Have abstract socket namespace])
54-fi
55-
56 ###############################
57 # Compiler characteristics
58 AC_C_CONST