summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/boost/boost-36.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/boost/boost-36.inc')
-rw-r--r--meta-moblin/packages/boost/boost-36.inc148
1 files changed, 0 insertions, 148 deletions
diff --git a/meta-moblin/packages/boost/boost-36.inc b/meta-moblin/packages/boost/boost-36.inc
deleted file mode 100644
index d297dfb1af..0000000000
--- a/meta-moblin/packages/boost/boost-36.inc
+++ /dev/null
@@ -1,148 +0,0 @@
1# The Boost web site provides free peer-reviewed portable
2# C++ source libraries. The emphasis is on libraries which
3# work well with the C++ Standard Library. The libraries are
4# intended to be widely useful, and are in regular use by
5# thousands of programmers across a broad spectrum of applications.
6DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
7HOMEPAGE = "http://www.boost.org/"
8SECTION = "libs"
9DEPENDS = "boost-jam-native zlib"
10PRIORITY = "optional"
11LICENSE = "Boost Software License"
12PR = "r3"
13
14ARM_INSTRUCTION_SET = "arm"
15BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
16BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
17BOOST_P = "boost_${BOOST_VER}"
18
19BOOST_LIBS = "\
20 date_time \
21 filesystem \
22 graph \
23 iostreams \
24 program_options \
25 regex \
26 signals \
27 system \
28 test \
29 thread \
30 "
31
32# FIXME: for some reason this fails on powerpc
33#BOOST_LIBS += "serialization"
34
35# To enable python, uncomment the following:
36#BOOST_LIBS += "python"
37#DEPENDS += "python"
38#PYTHON_ROOT = "${STAGING_DIR_HOST}/${prefix}"
39#PYTHON_VERSION = "2.5"
40
41S = "${WORKDIR}/${BOOST_P}"
42
43# Make a package for each library, plus -dev
44PACKAGES = "${PN}-dbg ${BOOST_PACKAGES}"
45python __anonymous () {
46 import bb
47
48 packages = []
49 extras = []
50 for lib in bb.data.getVar('BOOST_LIBS', d, 1).split( ):
51 pkg = "boost-%s" % lib.replace("_", "-")
52 extras.append("--with-%s" % lib)
53 packages.append(pkg)
54 if not bb.data.getVar("FILES_%s" % pkg, d, 1):
55 bb.data.setVar("FILES_%s" % pkg, "${libdir}/libboost_%s*.so*" % lib, d)
56 bb.data.setVar("BOOST_PACKAGES", " ".join(packages), d)
57 bb.data.setVar("BJAM_EXTRA", " ".join(extras), d)
58}
59
60# Override the contents of specific packages
61FILES_boost-serialization = "${libdir}/libboost_serialization*.so* \
62 ${libdir}/libboost_wserialization*.so*"
63FILES_boost-test = "${libdir}/libboost_prg_exec_monitor*.so \
64 ${libdir}/libboost_unit_test_framework*.so*"
65
66# -dev last to pick up the remaining stuff
67PACKAGES += "${PN}-dev"
68FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
69
70# "boost" is a metapackage which pulls in all boost librabries
71PACKAGES += "${PN}"
72RRECOMMENDS_${PN} += "${BOOST_PACKAGES}"
73
74# to avoid GNU_HASH QA errors added LDFLAGS to ARCH; a little bit dirty but at least it works
75TARGET_CC_ARCH += " ${LDFLAGS}"
76
77# Oh yippee, a new build system, it's sooo cooool I could eat my own
78# foot. inlining=on lets the compiler choose, I think. At least this
79# stuff is documented...
80# NOTE: if you leave <debug-symbols>on then in a debug build the build sys
81# objcopy will be invoked, and that won't work. Building debug apparently
82# requires hacking gcc-tools.jam
83#
84# Sometimes I wake up screaming. Famous figures are gathered in the nightmare,
85# Steve Bourne, Larry Wall, the whole of the ANSI C committee. They're just
86# standing there, waiting, but the truely terrifying thing is what they carry
87# in their hands. At first sight each seems to bear the same thing, but it is
88# not so for the forms in their grasp are ever so slightly different one from
89# the other. Each is twisted in some grotesque way from the other to make each
90# an unspeakable perversion impossible to perceive without the onset of madness.
91# True insanity awaits anyone who perceives all of these horrors together.
92#
93# Quotation marks, there might be an easier way to do this, but I can't find
94# it. The problem is that the user.hpp configuration file must receive a
95# pre-processor macro defined as the appropriate string - complete with "'s
96# around it. (<> is a possibility here but the danger to that is that the
97# failure case interprets the < and > as shell redirections, creating
98# random files in the source tree.)
99#
100#bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
101#do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
102SQD = '"'
103EQD = '\"'
104#boost.bb: "... '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
105BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
106
107# bzip2 and zip are disabled because... they're broken - the compilation simply
108# isn't working with bjam. I guess they will fix it, but who needs it? This
109# only affects the (new in 33) iostream library.
110BJAM_TOOLS = "-sTOOLS=gcc \
111 '-sGCC=${CC} '${BJAM_CONF} \
112 '-sGXX=${CXX} '${BJAM_CONF} \
113 '-sGCC_INCLUDE_DIRECTORY=${STAGING_INCDIR}' \
114 '-sGCC_STDLIB_DIRECTORY=${STAGING_LIBDIR}' \
115 '-sNO_BZIP2=1' \
116 '-sNO_ZLIB=1' \
117 '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
118 '-sPYTHON_VERSION=${PYTHON_VERSION}' \
119 '--layout=system' \
120 "
121
122BJAM_OPTS = '${BJAM_TOOLS} \
123 --builddir=${S}/${TARGET_SYS} \
124 --with-python-root=${PYTHON_ROOT} \
125 ${BJAM_EXTRA}'
126
127
128do_configure_prepend() {
129 cp -f boost/config/platform/linux.hpp boost/config/platform/linux-gnueabi.hpp
130
131 echo 'using gcc : 4.3.1 : ${CXX} : compileflags -DBOOST_SP_USE_PTHREADS -I${includedir} linkflags -L${libdir} ;' >> ${S}/tools/build/v2/user-config.jam
132}
133
134do_compile() {
135 set -ex
136 bjam ${BJAM_OPTS} --prefix=${prefix} \
137 --exec-prefix=${exec_prefix} \
138 --libdir=${libdir} \
139 --includedir=${includedir}
140}
141
142do_install() {
143 set -ex
144 bjam ${BJAM_OPTS} \
145 --libdir=${D}${libdir} \
146 --includedir=${D}${includedir} \
147 install
148}