summaryrefslogtreecommitdiffstats
path: root/meta-hob
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hob')
-rw-r--r--meta-hob/COPYING.MIT17
-rw-r--r--meta-hob/conf/layer.conf15
-rw-r--r--meta-hob/recipes-core/images/hob-image.bb1
-rw-r--r--meta-hob/recipes-core/meta/hob-toolchain.bb9
4 files changed, 42 insertions, 0 deletions
diff --git a/meta-hob/COPYING.MIT b/meta-hob/COPYING.MIT
new file mode 100644
index 0000000000..fb950dc69f
--- /dev/null
+++ b/meta-hob/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-hob/conf/layer.conf b/meta-hob/conf/layer.conf
new file mode 100644
index 0000000000..1785e65dda
--- /dev/null
+++ b/meta-hob/conf/layer.conf
@@ -0,0 +1,15 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
6
7BBFILE_COLLECTIONS += "hob"
8BBFILE_PATTERN_hob = "^${LAYERDIR}/"
9BBFILE_PRIORITY_hob = "1"
10
11# This should only be incremented on significant changes that will
12# cause compatibility issues with other layers
13LAYERVERSION_hob = "1"
14
15LAYERDEPENDS_hob = "core"
diff --git a/meta-hob/recipes-core/images/hob-image.bb b/meta-hob/recipes-core/images/hob-image.bb
new file mode 100644
index 0000000000..c8d6f49e6e
--- /dev/null
+++ b/meta-hob/recipes-core/images/hob-image.bb
@@ -0,0 +1 @@
inherit image
diff --git a/meta-hob/recipes-core/meta/hob-toolchain.bb b/meta-hob/recipes-core/meta/hob-toolchain.bb
new file mode 100644
index 0000000000..6f1a3d42e6
--- /dev/null
+++ b/meta-hob/recipes-core/meta/hob-toolchain.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "dummy toolchain"
2LICENSE = "MIT"
3
4PR = "r0"
5
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
7 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9inherit populate_sdk