diff options
Diffstat (limited to 'meta-extras')
-rw-r--r-- | meta-extras/packages/ubootchart/files/sysvinit.patch | 12 | ||||
-rw-r--r-- | meta-extras/packages/ubootchart/ubootchart_svn.bb | 22 |
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-extras/packages/ubootchart/files/sysvinit.patch b/meta-extras/packages/ubootchart/files/sysvinit.patch new file mode 100644 index 0000000000..de9fb0b17d --- /dev/null +++ b/meta-extras/packages/ubootchart/files/sysvinit.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: ubootchart.conf | ||
2 | =================================================================== | ||
3 | --- ubootchart.conf (revision 9) | ||
4 | +++ ubootchart.conf (working copy) | ||
5 | @@ -1,6 +1,6 @@ | ||
6 | |||
7 | # If you want to chain on and run somthing other than /sbin/init... | ||
8 | -export init_prog=/sbin/init | ||
9 | +export init_prog=/sbin/init.sysvinit | ||
10 | |||
11 | # On startup ubootchart will mount a tmpfs filesystem at this | ||
12 | # location and chdir here. This is only used for the logging of | ||
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb new file mode 100644 index 0000000000..b3f1ad30ee --- /dev/null +++ b/meta-extras/packages/ubootchart/ubootchart_svn.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "A boot profiling tool" | ||
2 | HOMEPAGE = "http://code.google.com/p/ubootchart/" | ||
3 | LICENSE="GPLv3" | ||
4 | |||
5 | SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \ | ||
6 | file://sysvinit.patch;patch=1;pnum=0" | ||
7 | |||
8 | S = "${WORKDIR}/trunk" | ||
9 | |||
10 | do_compile() { | ||
11 | ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin | ||
12 | } | ||
13 | |||
14 | do_install() { | ||
15 | install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart | ||
16 | install -m 0755 ${S}/ubootchartd_bin ${D}/sbin | ||
17 | install -m 0755 ${S}/ubootchartd ${D}/sbin | ||
18 | install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart | ||
19 | install -m 0755 ${S}/start.sh ${D}/etc/ubootchart | ||
20 | install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart | ||
21 | } | ||
22 | |||