diff options
Diffstat (limited to 'meta-extras/packages')
-rw-r--r-- | meta-extras/packages/python/python-imaging/path.patch | 37 | ||||
-rw-r--r-- | meta-extras/packages/python/python-imaging_1.1.6.bb | 30 |
2 files changed, 67 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-imaging/path.patch b/meta-extras/packages/python/python-imaging/path.patch new file mode 100644 index 0000000000..1dc467a56d --- /dev/null +++ b/meta-extras/packages/python/python-imaging/path.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | Index: Imaging-1.1.5/setup.py | ||
2 | =================================================================== | ||
3 | --- Imaging-1.1.5.orig/setup.py 2005-03-23 19:16:40.000000000 +0100 | ||
4 | +++ Imaging-1.1.5/setup.py 2006-05-31 14:36:07.000000000 +0200 | ||
5 | @@ -28,12 +28,13 @@ | ||
6 | # | ||
7 | # TIFF_ROOT = libinclude("/opt/tiff") | ||
8 | |||
9 | -FREETYPE_ROOT = None | ||
10 | -JPEG_ROOT = None | ||
11 | +FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR'] | ||
12 | +JPEG_ROOT = os.environ['STAGING_LIBDIR'] | ||
13 | TIFF_ROOT = None | ||
14 | -ZLIB_ROOT = None | ||
15 | +ZLIB_ROOT = os.environ['STAGING_LIBDIR'] | ||
16 | TCL_ROOT = None | ||
17 | |||
18 | + | ||
19 | # FIXME: add mechanism to explicitly *disable* the use of a library | ||
20 | |||
21 | # -------------------------------------------------------------------- | ||
22 | @@ -175,15 +176,6 @@ | ||
23 | add_directory(include_dirs, include_root) | ||
24 | |||
25 | # | ||
26 | - # add standard directories | ||
27 | - | ||
28 | - add_directory(library_dirs, "/usr/local/lib") | ||
29 | - add_directory(include_dirs, "/usr/local/include") | ||
30 | - | ||
31 | - add_directory(library_dirs, "/usr/lib") | ||
32 | - add_directory(include_dirs, "/usr/include") | ||
33 | - | ||
34 | - # | ||
35 | # insert new dirs *before* default libs, to avoid conflicts | ||
36 | # between Python PYD stub libs and real libraries | ||
37 | |||
diff --git a/meta-extras/packages/python/python-imaging_1.1.6.bb b/meta-extras/packages/python/python-imaging_1.1.6.bb new file mode 100644 index 0000000000..9f3b6323dd --- /dev/null +++ b/meta-extras/packages/python/python-imaging_1.1.6.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "Python Imaging Library" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "freetype jpeg tiff" | ||
6 | RDEPENDS = "python-lang python-stringold" | ||
7 | SRCNAME = "Imaging" | ||
8 | PR = "ml0" | ||
9 | |||
10 | SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \ | ||
11 | file://path.patch;patch=1" | ||
12 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
13 | |||
14 | inherit distutils | ||
15 | |||
16 | do_compile() { | ||
17 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
18 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
19 | distutils_do_compile | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
24 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
25 | distutils_do_install | ||
26 | install -d ${D}${datadir}/doc/${PN}/html/ | ||
27 | install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/ | ||
28 | install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/ | ||
29 | |||
30 | } | ||