diff options
Diffstat (limited to 'meta-extras/packages/yum/yum_3.2.27.bb')
-rw-r--r-- | meta-extras/packages/yum/yum_3.2.27.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-extras/packages/yum/yum_3.2.27.bb b/meta-extras/packages/yum/yum_3.2.27.bb new file mode 100644 index 0000000000..acebc79dde --- /dev/null +++ b/meta-extras/packages/yum/yum_3.2.27.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | DESCRIPTION = "yum package manger is an automatic updater for rpm." | ||
2 | HOMEPAGE = "http://yum.baseurl.org/" | ||
3 | BUGTRACKER = "http://yum.baseurl.org/report" | ||
4 | |||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \ | ||
7 | file://yum/sqlutils.py;beginline=2;endline=14;md5=d704ae6a9d69ce90768ab9188236b992" | ||
8 | |||
9 | RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \ | ||
10 | python-shell python-re python-logging python-pickle \ | ||
11 | python-netserver python-compression \ | ||
12 | python-unixadmin python-xml python-sqlite3 \ | ||
13 | python-textutils python-fcntl python-email \ | ||
14 | yum-metadata-parser" | ||
15 | |||
16 | PR = "r9" | ||
17 | |||
18 | SRC_URI = "http://yum.baseurl.org/download/3.2/yum-${PV}.tar.gz \ | ||
19 | file://paths.patch;apply=yes \ | ||
20 | file://paths2.patch;apply=yes \ | ||
21 | file://yum-install-recommends.py \ | ||
22 | file://extract-postinst.awk \ | ||
23 | file://98_yum" | ||
24 | |||
25 | S = "${WORKDIR}/yum-${PV}" | ||
26 | |||
27 | inherit autotools | ||
28 | |||
29 | do_compile_append () { | ||
30 | sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py | ||
31 | sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py | ||
32 | } | ||
33 | |||
34 | do_install_append () { | ||
35 | install -d ${D}${bindir}/ | ||
36 | install ${WORKDIR}/extract-postinst.awk ${D}${bindir}/ | ||
37 | install ${WORKDIR}/yum-install-recommends.py ${D}${bindir}/ | ||
38 | rmdir ${D}${localstatedir}/cache/yum | ||
39 | rmdir ${D}${localstatedir}/cache | ||
40 | install -d ${D}/etc/default/volatiles | ||
41 | install -m 0644 ${WORKDIR}/98_yum ${D}/etc/default/volatiles | ||
42 | } | ||
43 | |||
44 | FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli" | ||
45 | |||
46 | BBCLASSEXTEND = "native" | ||