summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb')
-rw-r--r--meta-extras/packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb b/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb
new file mode 100644
index 0000000000..d1e955f9d3
--- /dev/null
+++ b/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap_1.1.99.3.bb
@@ -0,0 +1,52 @@
1LICENSE = "MIT"
2DEPENDS = "tslib xproto libxdmcp xextproto xtrans libxau virtual/libx11 libxext libxrandr fixesproto damageproto libxfont resourceproto compositeproto calibrateproto recordproto videoproto scrnsaverproto xpext xsp libxkbfile dbus"
3
4PROVIDES = "virtual/xserver"
5PACKAGES =+ "xserver-kdrive-xomap"
6SECTION = "x11/base"
7DESCRIPTION = "X server from freedesktop.org"
8DESCRIPTION_xserver-kdrive-xomap = "X server for the OMAP in the Nokia 800"
9
10PE = "1"
11
12COMPATIBLE_MACHINE = "nokia(800|770)"
13
14FILES_${PN} = "${libdir}/xserver /etc/dbus-1/* ${bindir}/Xomap"
15
16SRC_URI = "http://repository.maemo.org/pool/maemo3.1/free/source/xorg-server_1.1.99.3-0osso31.tar.gz \
17 file://kmode.patch;patch=1 \
18 file://disable-apm.patch;patch=1 \
19 file://no-serial-probing.patch;patch=1 \
20 file://fbdev-not-fix.patch;patch=1 \
21 file://enable-builtin-fonts.patch;patch=1 \
22 file://xcalibrate.patch;patch=1 \
23 file://fixups.patch;patch=1 \
24 file://button_only.patch;patch=1 \
25 file://calibrateext.patch;patch=1 \
26 file://disable-xkb.patch;patch=1 \
27 file://configfix.patch;patch=1 \
28 file://xcalibrate_coords.patch;patch=1"
29# file://kdrive-evdev.patch;patch=1 \
30# file://kdrive-use-evdev.patch;patch=1 \
31# file://disable-xf86-dga-xorgcfg.patch;patch=1 \
32# file://enable-tslib.patch;patch=1 \
33# file://xfbdev-fb-opt.patch;patch=1"
34
35S = "${WORKDIR}/xorg-server-1.1.99.3"
36
37inherit autotools pkgconfig
38
39EXTRA_OECONF = "--enable-composite --enable-kdrive --enable-builtin-fonts \
40 --disable-dga --disable-dri --disable-xinerama \
41 --disable-xf86misc --disable-xf86vidmode \
42 --disable-xorg --disable-xorgcfg \
43 --disable-dmx --enable-xcalibrate \
44 --disable-xkb --disable-xnest --disable-xvfb \
45 --disable-xevie --disable-xprint --disable-xtrap \
46 --with-default-font-path=built-ins \
47 ac_cv_file__usr_share_X11_sgml_defs_ent=no \
48 --enable-xomap"
49
50do_configure_prepend() {
51 sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
52}