summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch')
-rw-r--r--meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch b/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch
new file mode 100644
index 0000000000..2a10f13d40
--- /dev/null
+++ b/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch
@@ -0,0 +1,73 @@
1---
2 Xext/Makefile.am | 5
3 Xext/xcalibrate.c | 262 +++++++++++++++++++++++++++++++++++++++++++++
4 configure.ac | 8 +
5 include/kdrive-config.h.in | 3
6 mi/miinitext.c | 6 +
7 5 files changed, 283 insertions(+), 1 deletion(-)
8
9Index: xorg-server-1.1.99.3/mi/miinitext.c
10===================================================================
11--- xorg-server-1.1.99.3.orig/mi/miinitext.c 2006-11-03 14:49:06.000000000 +0000
12+++ xorg-server-1.1.99.3/mi/miinitext.c 2007-01-27 17:59:40.000000000 +0000
13@@ -368,6 +368,9 @@ extern void ResExtensionInit(INITARGS);
14 #ifdef DMXEXT
15 extern void DMXExtensionInit(INITARGS);
16 #endif
17+#ifdef XCALIBRATE
18+extern void XCalibrateExtensionInit(INITARGS);
19+#endif
20 #ifdef XEVIE
21 extern void XevieExtensionInit(INITARGS);
22 #endif
23@@ -662,6 +665,9 @@ InitExtensions(argc, argv)
24 #ifdef XSP
25 if (!noXspExtension) XSPExtensionInit();
26 #endif
27+#ifdef XCALIBRATE
28+ XCalibrateExtensionInit ();
29+#endif
30 }
31
32 void
33Index: xorg-server-1.1.99.3/configure.ac
34===================================================================
35--- xorg-server-1.1.99.3.orig/configure.ac 2006-11-03 14:49:05.000000000 +0000
36+++ xorg-server-1.1.99.3/configure.ac 2007-01-29 22:58:18.000000000 +0000
37@@ -1584,7 +1590,7 @@ if test "$KDRIVE" = yes; then
38 KDRIVE_LIB='$(top_builddir)/hw/kdrive/src/libkdrive.a'
39 KDRIVE_OS_LIB='$(top_builddir)/hw/kdrive/linux/liblinux.a'
40 KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
41- KDRIVE_LIBS="$XSERVERLIBS_LIBS $DIX_LIB $XSP_LIB $KDRIVE_LIB $TSLIB_LIBS $KDRIVE_OS_LIB $KDRIVE_PURE_LIBS $KDRIVE_STUB_LIB"
42+ KDRIVE_LIBS="$XSERVERLIBS_LIBS $DIX_LIB $XSP_LIB $KDRIVE_LIB $TSLIB_LIBS $KDRIVE_PURE_LIBS $KDRIVE_OS_LIB $KDRIVE_STUB_LIB"
43
44 # check if we can build Xephyr
45 PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])
46Index: xorg-server-1.1.99.3/include/kdrive-config.h.in
47===================================================================
48--- xorg-server-1.1.99.3.orig/include/kdrive-config.h.in 2006-11-03 14:49:06.000000000 +0000
49+++ xorg-server-1.1.99.3/include/kdrive-config.h.in 2007-01-27 17:59:40.000000000 +0000
50@@ -28,4 +28,7 @@
51 /* Have the backtrace() functiln. */
52 #undef HAVE_BACKTRACE
53
54+/* Enable XCalibrate extension */
55+#undef XCALIBRATE
56+
57 #endif /* _KDRIVE_CONFIG_H_ */
58Index: xorg-server-1.1.99.3/Xext/Makefile.am
59===================================================================
60--- xorg-server-1.1.99.3.orig/Xext/Makefile.am 2006-11-03 14:49:05.000000000 +0000
61+++ xorg-server-1.1.99.3/Xext/Makefile.am 2007-01-29 22:58:33.000000000 +0000
62@@ -81,6 +81,11 @@ BUILTIN_SRCS += $(XCALIBRATE_SRCS)
63 # XCalibrare needs tslib
64 endif
65
66+XCALIBRATE_SRCS = xcalibrate.c
67+if XCALIBRATE
68+BUILTIN_SRCS += $(XCALIBRATE_SRCS)
69+endif
70+
71 # X EVent Interception Extension: allows accessibility helpers & composite
72 # managers to intercept events from input devices and transform as needed
73 # before the clients see them.