summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb')
-rw-r--r--meta-extras/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-extras/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb b/meta-extras/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
new file mode 100644
index 0000000000..cdfa305d50
--- /dev/null
+++ b/meta-extras/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
@@ -0,0 +1,64 @@
1DESCRIPTION = "X server for glamo chip in GTA02"
2SECTION = "x11/base"
3LICENSE = "MIT"
4DEPENDS = "compositeproto damageproto fixesproto recordproto resourceproto \
5 scrnsaverproto xineramaproto videoproto xextproto xproto \
6 libxau libxext libxdmcp libxfont libxrandr tslib virtual/libx11 \
7 xtrans libxkbfile libxcalibrate"
8DEPENDS += "libxkbfile libxcalibrate"
9RDEPENDS_${PN} = "xserver-kdrive"
10PROVIDES = "virtual/xserver"
11PE = "1"
12PR = "r8"
13PV = "1.3.0.0+git${SRCREV}"
14
15SRC_URI = "git://git.openmoko.org/git/xglamo.git;protocol=git \
16 file://kmode.patch;patch=1 \
17 file://disable-apm.patch;patch=1 \
18 file://no-serial-probing.patch;patch=1 \
19 file://fbdev-not-fix.patch;patch=1 \
20 file://optional-xkb.patch;patch=1 \
21 file://enable-tslib.patch;patch=1 \
22 file://kmode-palm.patch;patch=1 \
23 file://enable-epson.patch;patch=1 \
24 file://enable-builtin-fonts.patch;patch=1 \
25 file://kdrive-evdev.patch;patch=1 \
26 file://kdrive-use-evdev.patch;patch=1 \
27 file://disable-xf86-dga-xorgcfg.patch;patch=1 \
28 file://fix_default_mode.patch;patch=1 \
29 file://enable-xcalibrate.patch;patch=1 \
30 file://hide-cursor-and-ppm-root.patch;patch=1 \
31 file://xcalibrate_coords.patch;patch=1 \
32 file://w100.patch;patch=1 \
33 file://w100-autofoo.patch;patch=1 \
34 file://w100-fix-offscreen-bmp.patch;patch=1 \
35 file://kdrive-1.3-18bpp.patch;patch=1 \
36 file://gumstix-kmode.patch;patch=1 \
37 file://fix-picturestr-include-order.patch;patch=1 \
38"
39
40FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-glamo:${FILE_DIRNAME}/xserver-kdrive-1.3.0.0:${FILE_DIRNAME}/xserver-kdrive:${FILE_DIRNAME}/files"
41
42S = "${WORKDIR}/git"
43
44inherit autotools pkgconfig
45
46EXTRA_OECONF = "--enable-composite --enable-kdrive \
47 --disable-dga --disable-dri --disable-xinerama \
48 --disable-xf86misc --disable-xf86vidmode \
49 --disable-xorg --disable-xorgcfg \
50 --disable-xkb --disable-xnest --disable-xvfb \
51 --disable-xevie --disable-xprint --disable-xtrap \
52 --disable-dmx \
53 --with-default-font-path=built-ins \
54 --enable-tslib --enable-xcalibrate \
55 ac_cv_file__usr_share_sgml_X11_defs_ent=no"
56
57do_configure_prepend() {
58 sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
59}
60
61FILES_${PN} = "${bindir}/Xglamo"
62FILES_${PN}-dbg = "${bindir}/.debug/Xglamo"
63
64ARM_INSTRUCTION_SET = "arm"