diff options
Diffstat (limited to 'meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch')
-rw-r--r-- | meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch | 92 |
1 files changed, 0 insertions, 92 deletions
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch deleted file mode 100644 index 31d4f0d162..0000000000 --- a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch +++ /dev/null | |||
@@ -1,92 +0,0 @@ | |||
1 | --- sqlite-3.3.7/configure.ac.orig 2006-08-21 00:20:50.000000000 +0200 | ||
2 | +++ sqlite-3.3.7/configure.ac 2006-08-21 00:22:35.000000000 +0200 | ||
3 | @@ -187,10 +187,11 @@ | ||
4 | default_build_cflags="-g" | ||
5 | if test "$config_BUILD_CC" = ""; then | ||
6 | AC_PROG_CC | ||
7 | - if test "$cross_compiling" = "yes"; then | ||
8 | - AC_MSG_ERROR([unable to find a compiler for building build tools]) | ||
9 | - fi | ||
10 | - BUILD_CC=$CC | ||
11 | +# if test "$cross_compiling" = "yes"; then | ||
12 | +# AC_MSG_ERROR([unable to find a compiler for building build tools]) | ||
13 | +# fi | ||
14 | +# BUILD_CC=$CC | ||
15 | +BUILD_CC=gcc | ||
16 | default_build_cflags=$CFLAGS | ||
17 | else | ||
18 | BUILD_CC=$config_BUILD_CC | ||
19 | @@ -238,6 +239,12 @@ | ||
20 | TARGET_LINK=$config_TARGET_LINK | ||
21 | fi | ||
22 | AC_MSG_RESULT($TARGET_LINK) | ||
23 | +if test "$config_TARGET_LFLAGS" != ""; then | ||
24 | + TARGET_LFLAGS=$config_TARGET_LFLAGS | ||
25 | + else | ||
26 | + TARGET_LFLAGS=$BUILD_LFLAGS | ||
27 | + fi | ||
28 | +AC_MSG_RESULT($TARGET_LFLAGS) | ||
29 | AC_MSG_CHECKING([switches on the target compiler]) | ||
30 | if test "$config_TARGET_TFLAGS" != ""; then | ||
31 | TARGET_TFLAGS=$config_TARGET_TFLAGS | ||
32 | @@ -592,15 +599,7 @@ | ||
33 | # Figure out what C libraries are required to compile programs | ||
34 | # that use "readline()" library. | ||
35 | # | ||
36 | -if test "$config_TARGET_READLINE_LIBS" != ""; then | ||
37 | - TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS" | ||
38 | -else | ||
39 | - CC=$TARGET_CC | ||
40 | - LIBS="" | ||
41 | - AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap]) | ||
42 | - AC_CHECK_LIB([readline], [readline]) | ||
43 | - TARGET_READLINE_LIBS="$LIBS" | ||
44 | -fi | ||
45 | +TARGET_READLINE_LIBS="-lreadline" | ||
46 | AC_SUBST(TARGET_READLINE_LIBS) | ||
47 | |||
48 | ########## | ||
49 | @@ -615,41 +614,8 @@ | ||
50 | ########## | ||
51 | # Figure out where to get the READLINE header files. | ||
52 | # | ||
53 | -AC_MSG_CHECKING([readline header files]) | ||
54 | -found=no | ||
55 | -if test "$config_TARGET_READLINE_INC" != ""; then | ||
56 | - TARGET_READLINE_INC=$config_TARGET_READLINE_INC | ||
57 | - found=yes | ||
58 | -fi | ||
59 | -if test "$found" = "yes"; then | ||
60 | - AC_MSG_RESULT($TARGET_READLINE_INC) | ||
61 | -else | ||
62 | - AC_MSG_RESULT(not specified: still searching...) | ||
63 | - AC_CHECK_HEADER(readline.h, [found=yes]) | ||
64 | -fi | ||
65 | -if test "$found" = "no"; then | ||
66 | - for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do | ||
67 | - AC_CHECK_FILE($dir/include/readline.h, found=yes) | ||
68 | - if test "$found" = "yes"; then | ||
69 | - TARGET_READLINE_INC="-I$dir/include" | ||
70 | - break | ||
71 | - fi | ||
72 | - AC_CHECK_FILE($dir/include/readline/readline.h, found=yes) | ||
73 | - if test "$found" = "yes"; then | ||
74 | - TARGET_READLINE_INC="-I$dir/include/readline" | ||
75 | - break | ||
76 | - fi | ||
77 | - done | ||
78 | -fi | ||
79 | -if test "$found" = "yes"; then | ||
80 | - if test "$TARGET_READLINE_LIBS" = ""; then | ||
81 | - TARGET_HAVE_READLINE=0 | ||
82 | - else | ||
83 | - TARGET_HAVE_READLINE=1 | ||
84 | - fi | ||
85 | -else | ||
86 | - TARGET_HAVE_READLINE=0 | ||
87 | -fi | ||
88 | +TARGET_READLINE_INC="" | ||
89 | +TARGET_HAVE_READLINE=1 | ||
90 | AC_SUBST(TARGET_READLINE_INC) | ||
91 | AC_SUBST(TARGET_HAVE_READLINE) | ||
92 | |||