diff options
Diffstat (limited to 'meta-extras/packages/redland/files')
-rw-r--r-- | meta-extras/packages/redland/files/crosscompile.patch | 29 | ||||
-rw-r--r-- | meta-extras/packages/redland/files/sane_pkgconfig.patch | 126 |
2 files changed, 0 insertions, 155 deletions
diff --git a/meta-extras/packages/redland/files/crosscompile.patch b/meta-extras/packages/redland/files/crosscompile.patch deleted file mode 100644 index 281007a791..0000000000 --- a/meta-extras/packages/redland/files/crosscompile.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | Index: redland-1.0.8/raptor/configure.ac | ||
2 | =================================================================== | ||
3 | --- redland-1.0.8.orig/raptor/configure.ac 2008-12-16 17:26:58.000000000 +0000 | ||
4 | +++ redland-1.0.8/raptor/configure.ac 2008-12-16 17:27:41.000000000 +0000 | ||
5 | @@ -279,23 +279,7 @@ | ||
6 | |||
7 | if test $ac_cv_func_vsnprintf = yes; then | ||
8 | AC_MSG_CHECKING(vsnprintf has C99 compatible return value) | ||
9 | - AC_TRY_RUN([#include <stdarg.h> | ||
10 | -int is_c99(char *s, ...) { | ||
11 | - char buffer[32]; | ||
12 | - va_list args; | ||
13 | - int r; | ||
14 | - va_start(args, s); | ||
15 | - r = vsnprintf(buffer, 5, s, args); | ||
16 | - va_end(args); | ||
17 | - | ||
18 | - return (r == 7); | ||
19 | -} | ||
20 | - | ||
21 | -int main(int argc, char* argv) { | ||
22 | - return is_c99("1234567"); | ||
23 | -}], AC_MSG_RESULT(no), | ||
24 | - AC_DEFINE(HAVE_C99_VSNPRINTF, 1, [vsnprint has C99 compatible return value]) | ||
25 | - AC_MSG_RESULT(yes)) | ||
26 | + AC_DEFINE(HAVE_C99_VSNPRINTF, 1, [vsnprint has C99 compatible return value]) | ||
27 | fi | ||
28 | |||
29 | need_libm=no | ||
diff --git a/meta-extras/packages/redland/files/sane_pkgconfig.patch b/meta-extras/packages/redland/files/sane_pkgconfig.patch deleted file mode 100644 index 32742e2b29..0000000000 --- a/meta-extras/packages/redland/files/sane_pkgconfig.patch +++ /dev/null | |||
@@ -1,126 +0,0 @@ | |||
1 | Index: redland-1.0.8/configure.ac | ||
2 | =================================================================== | ||
3 | --- redland-1.0.8.orig/configure.ac 2008-07-04 07:56:25.000000000 +0100 | ||
4 | +++ redland-1.0.8/configure.ac 2008-12-17 23:04:25.000000000 +0000 | ||
5 | @@ -404,7 +404,7 @@ | ||
6 | |||
7 | if test "$have_libdb" = yes; then | ||
8 | bdb_available="Version $bdb_version (library $bdb_dbname in $bdb_lib_dir)" | ||
9 | - LIBRDF_LIBS="$LIBRDF_LIBS $nLDFLAGS -l$bdb_dbname" | ||
10 | + LIBRDF_LIBS="$LIBRDF_LIBS -l$bdb_dbname" | ||
11 | LIBRDF_CPPFLAGS="$LIBRDF_CPPFLAGS $nCPPFLAGS" | ||
12 | fi | ||
13 | |||
14 | Index: redland-1.0.8/raptor/configure.ac | ||
15 | =================================================================== | ||
16 | --- redland-1.0.8.orig/raptor/configure.ac 2008-12-17 23:04:25.000000000 +0000 | ||
17 | +++ redland-1.0.8/raptor/configure.ac 2008-12-18 11:18:36.000000000 +0000 | ||
18 | @@ -304,9 +304,12 @@ | ||
19 | AC_DEFINE(HAVE_ROUND, 1, [have round() in libm]), | ||
20 | AC_MSG_RESULT(no)) | ||
21 | LIBS="$oLIBS" | ||
22 | +PRIV_PC_LIBS="" | ||
23 | +PRIV_PC_REQS="" | ||
24 | |||
25 | if test "X$need_libm" = Xyes; then | ||
26 | LIBS="$LIBS -lm" | ||
27 | + PRIV_PC_LIBS="$PRIV_PC_LIBS -lm" | ||
28 | fi | ||
29 | |||
30 | |||
31 | @@ -369,6 +372,7 @@ | ||
32 | AC_MSG_CHECKING(for working expat in libxmlparse and libxmltok) | ||
33 | if test $xmlp = 1 -a $xmlt = 1 -a $ac_cv_header_xmlparse_h = yes; then | ||
34 | LIBS="$LIBS -lxmlparse -lxmltok" | ||
35 | + PRIV_PC_LIBS="$PRIV_PC_LIBS -lxmlparse -lxmltok" | ||
36 | AC_TRY_RUN([#include <stdio.h> | ||
37 | main() {XML_ParserCreate(NULL); return(0);}], | ||
38 | worked=yes, worked=no, worked=no) | ||
39 | @@ -391,6 +395,7 @@ | ||
40 | AC_MSG_CHECKING(for working expat in libexpat) | ||
41 | if test $libexpat = 1 -a $ac_cv_header_expat_h = yes ; then | ||
42 | LIBS="$LIBS -lexpat" | ||
43 | + PRIV_PC_LIBS="$PRIV_PC_LIBS -lexpat" | ||
44 | AC_TRY_RUN([#include <stdio.h> | ||
45 | main() {XML_ParserCreate(NULL); return(0);}], | ||
46 | worked=yes, worked=no, worked=no) | ||
47 | @@ -531,6 +536,7 @@ | ||
48 | oLIBS="$LIBS" | ||
49 | if test "X$XML_CONFIG" != X; then | ||
50 | LIBS="$LIBS `$XML_CONFIG --libs`" | ||
51 | + PRIV_PC_REQS="$PRIV_PC_REQS libxml-2.0" | ||
52 | AC_CHECK_FUNC(xmlCreatePushParserCtxt, have_xmlCreatePushParserCtxt=yes, have_xmlCreatePushParserCtxt=no) | ||
53 | AC_MSG_CHECKING(for system (GNOME) libxml library) | ||
54 | if test $have_xmlCreatePushParserCtxt = yes; then | ||
55 | @@ -637,6 +643,7 @@ | ||
56 | oLIBS="$LIBS" | ||
57 | if test "X$XSLT_CONFIG" != X; then | ||
58 | LIBS="$LIBS `$XSLT_CONFIG --libs`" | ||
59 | + PRIV_PC_REQS="$PRIV_PC_REQS libxslt" | ||
60 | AC_CHECK_FUNC(xsltSaveResultToString, have_xsltSaveResultToString=yes, have_xsltSaveResultToString=no) | ||
61 | AC_MSG_CHECKING(for system libxslt library) | ||
62 | if test $have_xsltSaveResultToString = yes; then | ||
63 | @@ -1034,6 +1041,7 @@ | ||
64 | if test $need_libcurl = 1; then | ||
65 | CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`" | ||
66 | LIBS="$LIBS `$CURL_CONFIG --libs`" | ||
67 | + PRIV_PC_REQS="$PRIV_PC_REQS libcurl" | ||
68 | AC_LIBOBJ(raptor_www_curl) | ||
69 | |||
70 | fi | ||
71 | @@ -1054,6 +1062,7 @@ | ||
72 | if test $ac_cv_header_libinn_h = yes; then | ||
73 | CPPFLAGS="$CPPFLAGS -I/usr/include/inn" | ||
74 | LIBS="$LIBS -L/usr/lib/news -linn" | ||
75 | + PRIV_PC_LIBS="$PRIV_PC_LIBS -linn" | ||
76 | AC_CHECK_LIB(inn, HashMessageID, have_libinn=yes) | ||
77 | |||
78 | AC_MSG_CHECKING(parsedate in libinn) | ||
79 | @@ -1102,6 +1111,7 @@ | ||
80 | |||
81 | if test $need_libfetch = 1; then | ||
82 | LIBS="$LIBS -lfetch" | ||
83 | + PRIV_PC_LIBS="$PRIV_PC_REQS -lfetch" | ||
84 | AC_LIBOBJ(raptor_www_libfetch) | ||
85 | fi | ||
86 | |||
87 | @@ -1120,6 +1130,7 @@ | ||
88 | else | ||
89 | LIBS="$LIBS `$XML_CONFIG --libs`" | ||
90 | CPPFLAGS="`$XML_CONFIG --cflags` $CPPFLAGS" | ||
91 | + PRIV_PC_REQS="$PRIV_PC_REQS libxml-2.0" | ||
92 | fi | ||
93 | RAPTOR_XML_PARSER=libxml | ||
94 | fi | ||
95 | @@ -1147,6 +1158,7 @@ | ||
96 | if test $need_libxslt = 1; then | ||
97 | LIBS="$LIBS `$XSLT_CONFIG --libs`" | ||
98 | CPPFLAGS="`$XSLT_CONFIG --cflags` $CPPFLAGS" | ||
99 | + PRIV_PC_REQS="$PRIV_PC_REQS libxslt" | ||
100 | fi | ||
101 | |||
102 | RAPTOR_LIBTOOLLIBS=libraptor.la | ||
103 | @@ -1214,6 +1226,9 @@ | ||
104 | AC_SUBST(MEM_LIBS) | ||
105 | AC_SUBST(STANDARD_CFLAGS) | ||
106 | |||
107 | +AC_SUBST(PRIV_PC_LIBS) | ||
108 | +AC_SUBST(PRIV_PC_REQS) | ||
109 | + | ||
110 | ECHO_N="$ECHO_N" | ||
111 | ECHO_C="$ECHO_C" | ||
112 | AC_SUBST(ECHO_N) | ||
113 | Index: redland-1.0.8/raptor/raptor.pc.in | ||
114 | =================================================================== | ||
115 | --- redland-1.0.8.orig/raptor/raptor.pc.in 2008-12-17 23:06:47.000000000 +0000 | ||
116 | +++ redland-1.0.8/raptor/raptor.pc.in 2008-12-17 23:07:20.000000000 +0000 | ||
117 | @@ -6,7 +6,8 @@ | ||
118 | Name: Raptor | ||
119 | Description: RDF Parser Toolkit Library | ||
120 | Version: @VERSION@ | ||
121 | +Requires.private: @PRIV_PC_REQS@ | ||
122 | Libs: -L${libdir} -lraptor | ||
123 | -Libs.private: @LIBS@ | ||
124 | +Libs.private: @PRIV_PC_LIBS@@ | ||
125 | Cflags: -I${includedir} | ||
126 | |||