diff options
Diffstat (limited to 'meta-extras/packages/python/python_2.5.2.bb')
-rw-r--r-- | meta-extras/packages/python/python_2.5.2.bb | 105 |
1 files changed, 0 insertions, 105 deletions
diff --git a/meta-extras/packages/python/python_2.5.2.bb b/meta-extras/packages/python/python_2.5.2.bb deleted file mode 100644 index 1ac48f3686..0000000000 --- a/meta-extras/packages/python/python_2.5.2.bb +++ /dev/null | |||
@@ -1,105 +0,0 @@ | |||
1 | DESCRIPTION = "Python Programming Language" | ||
2 | HOMEPAGE = "http://www.python.org" | ||
3 | LICENSE = "PSF" | ||
4 | SECTION = "devel/python" | ||
5 | PRIORITY = "optional" | ||
6 | DEPENDS = "python-native readline zlib gdbm openssl sqlite3" | ||
7 | DEPENDS_sharprom = "python-native readline zlib gdbm openssl" | ||
8 | PR = "ml1" | ||
9 | |||
10 | PYTHON_MAJMIN = "2.5" | ||
11 | |||
12 | SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \ | ||
13 | file://bindir-libdir.patch;patch=1 \ | ||
14 | file://crosscompile.patch;patch=1 \ | ||
15 | file://fix-tkinter-detection.patch;patch=1 \ | ||
16 | file://autohell.patch;patch=1 \ | ||
17 | file://sitebranding.patch;patch=1 \ | ||
18 | file://enable-ctypes-module.patch;patch=1 \ | ||
19 | file://default-is-optimized.patch;patch=1 \ | ||
20 | file://sitecustomize.py" | ||
21 | S = "${WORKDIR}/Python-${PV}" | ||
22 | |||
23 | inherit autotools | ||
24 | |||
25 | EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \ | ||
26 | --without-cxx --with-signal-module --with-wctype-functions \ | ||
27 | --enable-shared" | ||
28 | |||
29 | # | ||
30 | # copy config.h and an appropriate Makefile for distutils.sysconfig | ||
31 | # which laters uses the information out of these to compile extensions | ||
32 | # | ||
33 | do_compile_prepend() { | ||
34 | install -d ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/ | ||
35 | install -d ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/ | ||
36 | install -m 0644 pyconfig.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/ | ||
37 | install -m 0644 Makefile Makefile.orig | ||
38 | install -m 0644 Makefile Makefile.backup | ||
39 | sed -e 's,${includedir},${STAGING_INCDIR},' < Makefile.backup > Makefile | ||
40 | install -m 0644 Makefile Makefile.backup | ||
41 | sed -e 's,${libdir},${STAGING_LIBDIR},' < Makefile.backup > Makefile | ||
42 | install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/ | ||
43 | } | ||
44 | |||
45 | do_compile() { | ||
46 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ | ||
47 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ | ||
48 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | ||
49 | STAGING_INCDIR=${STAGING_INCDIR} \ | ||
50 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
51 | OPT="${CFLAGS}" libpython2.5.so | ||
52 | |||
53 | oe_libinstall -so libpython2.5 ${STAGING_LIBDIR} | ||
54 | |||
55 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ | ||
56 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ | ||
57 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | ||
58 | STAGING_INCDIR=${STAGING_INCDIR} \ | ||
59 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
60 | OPT="${CFLAGS}" | ||
61 | } | ||
62 | |||
63 | do_stage() { | ||
64 | install -m 0644 Include/*.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/ | ||
65 | oe_libinstall -a -so libpython${PYTHON_MAJMIN} ${STAGING_LIBDIR} | ||
66 | } | ||
67 | |||
68 | do_install() { | ||
69 | install -m 0644 Makefile.orig Makefile | ||
70 | |||
71 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ | ||
72 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ | ||
73 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | ||
74 | STAGING_INCDIR=${STAGING_INCDIR} \ | ||
75 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
76 | DESTDIR=${D} LIBDIR=${libdir} install | ||
77 | |||
78 | install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN} | ||
79 | } | ||
80 | |||
81 | require python-${PYTHON_MAJMIN}-manifest.inc | ||
82 | |||
83 | # manual dependency additions | ||
84 | RPROVIDES_python-core = "python" | ||
85 | RRECOMMENDS_python-core = "python-readline" | ||
86 | RRECOMMENDS_python-crypt = "openssl" | ||
87 | |||
88 | # add sitecustomize | ||
89 | FILES_python-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py" | ||
90 | |||
91 | # package libpython | ||
92 | PACKAGES =+ "libpython2" | ||
93 | FILES_libpython2 = "${libdir}/libpython*" | ||
94 | |||
95 | # catch debug extensions | ||
96 | FILES_python-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug" | ||
97 | |||
98 | # catch all the rest (unsorted) | ||
99 | PACKAGES += "python-misc" | ||
100 | FILES_python-misc = "${libdir}/python${PYTHON_MAJMIN}" | ||
101 | |||
102 | # catch manpage | ||
103 | PACKAGES += "python-man" | ||
104 | FILES_python-man = "${datadir}/man" | ||
105 | |||