diff options
Diffstat (limited to 'meta-extras/packages/python/python-native-2.5.1')
6 files changed, 0 insertions, 134 deletions
diff --git a/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch b/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch deleted file mode 100644 index 999bddc449..0000000000 --- a/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | |||
2 | # | ||
3 | # Made by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200 | ||
7 | +++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100 | ||
8 | @@ -78,8 +78,8 @@ | ||
9 | exec_prefix= @exec_prefix@ | ||
10 | |||
11 | # Expanded directories | ||
12 | -BINDIR= $(exec_prefix)/bin | ||
13 | -LIBDIR= $(exec_prefix)/lib | ||
14 | +BINDIR= @bindir@ | ||
15 | +LIBDIR= @libdir@ | ||
16 | MANDIR= @mandir@ | ||
17 | INCLUDEDIR= @includedir@ | ||
18 | CONFINCLUDEDIR= $(exec_prefix)/include | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/catchup-with-swig.patch b/meta-extras/packages/python/python-native-2.5.1/catchup-with-swig.patch deleted file mode 100644 index f049b759f4..0000000000 --- a/meta-extras/packages/python/python-native-2.5.1/catchup-with-swig.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: Python-2.5.1/Lib/distutils/command/build_ext.py | ||
2 | =================================================================== | ||
3 | --- Python-2.5.1.orig/Lib/distutils/command/build_ext.py | ||
4 | +++ Python-2.5.1/Lib/distutils/command/build_ext.py | ||
5 | @@ -513,7 +513,7 @@ class build_ext (Command): | ||
6 | target_lang=language) | ||
7 | |||
8 | |||
9 | - def swig_sources (self, sources, extension): | ||
10 | + def swig_sources (self, sources, extension=None): | ||
11 | |||
12 | """Walk the list of source files in 'sources', looking for SWIG | ||
13 | interface (.i) files. Run SWIG on all that are found, and | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch b/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch deleted file mode 100644 index 3356c1abbe..0000000000 --- a/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100 | ||
7 | +++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100 | ||
8 | @@ -19,8 +19,8 @@ | ||
9 | from errors import DistutilsPlatformError | ||
10 | |||
11 | # These are needed in a couple of spots, so just compute them once. | ||
12 | -PREFIX = os.path.normpath(sys.prefix) | ||
13 | -EXEC_PREFIX = os.path.normpath(sys.exec_prefix) | ||
14 | +PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
15 | +EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
16 | |||
17 | # python_build: (Boolean) if true, we're either building Python or | ||
18 | # building an extension with an un-installed Python, so we use | ||
19 | @@ -192,7 +192,7 @@ | ||
20 | else: | ||
21 | # The name of the config.h file changed in 2.2 | ||
22 | config_h = 'pyconfig.h' | ||
23 | - return os.path.join(inc_dir, config_h) | ||
24 | + return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
25 | |||
26 | |||
27 | def get_makefile_filename(): | ||
28 | @@ -200,7 +200,7 @@ | ||
29 | if python_build: | ||
30 | return os.path.join(os.path.dirname(sys.executable), "Makefile") | ||
31 | lib_dir = get_python_lib(plat_specific=1, standard_lib=1) | ||
32 | - return os.path.join(lib_dir, "config", "Makefile") | ||
33 | + return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
34 | |||
35 | |||
36 | def parse_config_h(fp, g=None): | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch b/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch deleted file mode 100644 index 6beeb6e022..0000000000 --- a/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: Python-2.5.1/Python/compile.c | ||
2 | =================================================================== | ||
3 | --- Python-2.5.1.orig/Python/compile.c | ||
4 | +++ Python-2.5.1/Python/compile.c | ||
5 | @@ -30,7 +30,7 @@ | ||
6 | #include "symtable.h" | ||
7 | #include "opcode.h" | ||
8 | |||
9 | -int Py_OptimizeFlag = 0; | ||
10 | +int Py_OptimizeFlag = 1; | ||
11 | |||
12 | /* | ||
13 | ISSUES: | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch b/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch deleted file mode 100644 index 54109afd62..0000000000 --- a/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | |||
2 | # | ||
3 | # Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de> | ||
4 | # | ||
5 | |||
6 | --- Python-2.4/Lib/distutils/command/build_scripts.py~dont-modify-shebang-line | ||
7 | +++ Python-2.4/Lib/distutils/command/build_scripts.py | ||
8 | @@ -87,7 +87,7 @@ | ||
9 | continue | ||
10 | |||
11 | match = first_line_re.match(first_line) | ||
12 | - if match: | ||
13 | + if False: #match: | ||
14 | adjust = 1 | ||
15 | post_interp = match.group(1) or '' | ||
16 | |||
diff --git a/meta-extras/packages/python/python-native-2.5.1/fix-staging.patch b/meta-extras/packages/python/python-native-2.5.1/fix-staging.patch deleted file mode 100644 index 087c813fd4..0000000000 --- a/meta-extras/packages/python/python-native-2.5.1/fix-staging.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | --- | ||
2 | Lib/distutils/sysconfig.py | 10 ++++++++-- | ||
3 | 1 file changed, 8 insertions(+), 2 deletions(-) | ||
4 | |||
5 | --- Python-2.5.1.orig/Lib/distutils/sysconfig.py | ||
6 | +++ Python-2.5.1/Lib/distutils/sysconfig.py | ||
7 | @@ -52,11 +52,14 @@ def get_python_inc(plat_specific=0, pref | ||
8 | |||
9 | If 'prefix' is supplied, use it instead of sys.prefix or | ||
10 | sys.exec_prefix -- i.e., ignore 'plat_specific'. | ||
11 | """ | ||
12 | if prefix is None: | ||
13 | - prefix = plat_specific and EXEC_PREFIX or PREFIX | ||
14 | + if plat_specific: | ||
15 | + prefix = plat_specific and os.environ['STAGING_INCDIR'].rstrip('include') | ||
16 | + else: | ||
17 | + prefix = plat_specific and EXEC_PREFIX or PREFIX | ||
18 | if os.name == "posix": | ||
19 | if python_build: | ||
20 | base = os.path.dirname(os.path.abspath(sys.executable)) | ||
21 | if plat_specific: | ||
22 | inc_dir = base | ||
23 | @@ -94,11 +97,14 @@ def get_python_lib(plat_specific=0, stan | ||
24 | |||
25 | If 'prefix' is supplied, use it instead of sys.prefix or | ||
26 | sys.exec_prefix -- i.e., ignore 'plat_specific'. | ||
27 | """ | ||
28 | if prefix is None: | ||
29 | - prefix = plat_specific and EXEC_PREFIX or PREFIX | ||
30 | + if plat_specific: | ||
31 | + prefix = plat_specific and os.environ['STAGING_LIBDIR'].rstrip('lib') | ||
32 | + else: | ||
33 | + prefix = plat_specific and EXEC_PREFIX or PREFIX | ||
34 | |||
35 | if os.name == "posix": | ||
36 | libpython = os.path.join(prefix, | ||
37 | "lib", "python" + get_python_version()) | ||
38 | if standard_lib: | ||