summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/networkmanager
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/networkmanager')
-rw-r--r--meta-extras/packages/networkmanager/files/70NetworkManagerApplet.shbg4
-rw-r--r--meta-extras/packages/networkmanager/files/99_networkmanager1
-rw-r--r--meta-extras/packages/networkmanager/files/NetworkManager43
-rw-r--r--meta-extras/packages/networkmanager/files/allow-disabling.patch45
-rw-r--r--meta-extras/packages/networkmanager/files/applet-no-animation.patch234
-rw-r--r--meta-extras/packages/networkmanager/files/applet-no-gnome.diff59
-rw-r--r--meta-extras/packages/networkmanager/files/libnlfix.patch29
-rw-r--r--meta-extras/packages/networkmanager/files/makefile-fix.patch17
-rw-r--r--meta-extras/packages/networkmanager/files/nmutil-fix.patch12
-rw-r--r--meta-extras/packages/networkmanager/files/no-restarts.diff21
-rw-r--r--meta-extras/packages/networkmanager/files/no_vpn.patch13
-rw-r--r--meta-extras/packages/networkmanager/networkmanager-applet_svn.bb33
-rw-r--r--meta-extras/packages/networkmanager/networkmanager_svn.bb51
13 files changed, 562 insertions, 0 deletions
diff --git a/meta-extras/packages/networkmanager/files/70NetworkManagerApplet.shbg b/meta-extras/packages/networkmanager/files/70NetworkManagerApplet.shbg
new file mode 100644
index 0000000000..8858b3e7c2
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/70NetworkManagerApplet.shbg
@@ -0,0 +1,4 @@
1#!/bin/sh
2# Wait for the desktop to say its finished loading
3dbus-wait org.matchbox_project.desktop Loaded
4exec /usr/bin/nm-applet
diff --git a/meta-extras/packages/networkmanager/files/99_networkmanager b/meta-extras/packages/networkmanager/files/99_networkmanager
new file mode 100644
index 0000000000..20cbcc1bca
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/99_networkmanager
@@ -0,0 +1 @@
d root root 0700 /var/run/NetworkManager none
diff --git a/meta-extras/packages/networkmanager/files/NetworkManager b/meta-extras/packages/networkmanager/files/NetworkManager
new file mode 100644
index 0000000000..4522e0107b
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/NetworkManager
@@ -0,0 +1,43 @@
1#!/bin/sh
2#
3### BEGIN INIT INFO
4# Provides: NetworkManager
5# Required-Start: $remote_fs dbus hal
6# Required-Stop: $remote_fs dbus hal
7# Should-Start: $syslog
8# Should-Stop: $syslog
9# Default-Start: 2 3 4 5
10# Default-Stop: 0 1 6
11# Short-Description: network connection manager
12# Description: Daemon for automatically switching network
13# connections to the best available connection.
14### END INIT INFO
15
16. /etc/profile
17
18case $1 in
19 'start')
20 echo -n "Starting NetworkManager daemon: NetworkManager"
21 /usr/sbin/NetworkManager
22 /usr/sbin/NetworkManagerDispatcher
23 /usr/sbin/wpa_supplicant -u &
24 echo "."
25 ;;
26
27 'stop')
28 echo -n "Stopping NetworkManager daemon: NetworkManager"
29 kill `ps |grep /usr/sbin/NetworkManagerDispatcher | grep -v grep | cut "-d " -f2`
30 kill `ps |grep /usr/sbin/NetworkManager | grep -v grep | cut "-d " -f2`
31 kill `ps |grep /usr/sbin/wpa_supplicant | grep -v grep | cut "-d " -f2`
32 echo "."
33 ;;
34
35 'restart')
36 $0 stop
37 $0 start
38 ;;
39
40 *)
41 echo "Usage: $0 { start | stop | restart }"
42 ;;
43esac
diff --git a/meta-extras/packages/networkmanager/files/allow-disabling.patch b/meta-extras/packages/networkmanager/files/allow-disabling.patch
new file mode 100644
index 0000000000..10730e9fe5
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/allow-disabling.patch
@@ -0,0 +1,45 @@
1Allow interfaces to be ignored by networkmanager by creation of a
2/etc/network/nm-disabled-INTERFACENAME file.
3
4RP - 16/7/2008
5
6Index: trunk/src/backends/NetworkManagerDebian.c
7===================================================================
8--- trunk.orig/src/backends/NetworkManagerDebian.c 2008-07-15 19:23:11.000000000 +0100
9+++ trunk/src/backends/NetworkManagerDebian.c 2008-07-15 19:37:05.000000000 +0100
10@@ -29,6 +29,7 @@
11
12 #include <stdio.h>
13 #include <sys/types.h>
14+#include <sys/stat.h>
15 #include <signal.h>
16 #include <arpa/inet.h>
17 #include "NetworkManagerGeneric.h"
18@@ -374,12 +375,25 @@
19 /*
20 * nm_system_device_get_disabled
21 *
22- * Return whether the distro-specific system config tells us to use
23- * dhcp for this device.
24+ * Return whether the distro-specific system config tells us to interact
25+ * with this device.
26 *
27 */
28 gboolean nm_system_device_get_disabled (NMDevice *dev)
29 {
30+ struct stat statbuf;
31+ gchar *filepath;
32+
33+ g_return_val_if_fail (dev != NULL, FALSE);
34+
35+ filepath = g_strdup_printf (SYSCONFDIR"/network/nm-disabled-%s", nm_device_get_iface (dev));
36+
37+ if (stat(filepath, &statbuf) == 0) {
38+ g_free(filepath);
39+ return TRUE;
40+ }
41+
42+ g_free(filepath);
43 return FALSE;
44 }
45
diff --git a/meta-extras/packages/networkmanager/files/applet-no-animation.patch b/meta-extras/packages/networkmanager/files/applet-no-animation.patch
new file mode 100644
index 0000000000..d437fd0fc9
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/applet-no-animation.patch
@@ -0,0 +1,234 @@
1Index: trunk/src/applet.c
2===================================================================
3--- trunk.orig/src/applet.c 2008-02-06 20:30:04.000000000 +0000
4+++ trunk/src/applet.c 2008-02-06 20:46:59.000000000 +0000
5@@ -111,8 +111,6 @@
6
7 static void nma_init (NMApplet *applet)
8 {
9- applet->animation_id = 0;
10- applet->animation_step = 0;
11 applet->passphrase_dialog = NULL;
12 applet->icon_theme = NULL;
13 #ifdef ENABLE_NOTIFY
14@@ -1006,20 +1004,6 @@
15 }
16 }
17
18-static gboolean
19-vpn_animation_timeout (gpointer data)
20-{
21- NMApplet *applet = NM_APPLET (data);
22-
23- foo_set_icon (applet, applet->vpn_connecting_icons[applet->animation_step], ICON_LAYER_VPN);
24-
25- applet->animation_step++;
26- if (applet->animation_step >= NUM_VPN_CONNECTING_FRAMES)
27- applet->animation_step = 0;
28-
29- return TRUE;
30-}
31-
32 static void
33 vpn_connection_state_changed (NMVPNConnection *connection,
34 NMVPNConnectionState state,
35@@ -1030,10 +1014,6 @@
36
37 switch (state) {
38 case NM_VPN_CONNECTION_STATE_ACTIVATED:
39- if (applet->animation_id) {
40- g_source_remove (applet->animation_id);
41- applet->animation_id = 0;
42- }
43 foo_set_icon (applet, applet->vpn_lock_icon, ICON_LAYER_VPN);
44 // vpn_connection_info_set_last_attempt_success (info, TRUE);
45 break;
46@@ -1041,10 +1021,7 @@
47 case NM_VPN_CONNECTION_STATE_NEED_AUTH:
48 case NM_VPN_CONNECTION_STATE_CONNECT:
49 case NM_VPN_CONNECTION_STATE_IP_CONFIG_GET:
50- if (applet->animation_id == 0) {
51- applet->animation_step = 0;
52- applet->animation_id = g_timeout_add (100, vpn_animation_timeout, applet);
53- }
54+ foo_set_icon (applet, applet->network_connecting_icon, ICON_LAYER_VPN);
55 break;
56 case NM_VPN_CONNECTION_STATE_FAILED:
57 // vpn_connection_info_set_last_attempt_success (info, FALSE);
58@@ -1053,10 +1030,6 @@
59 g_hash_table_remove (applet->vpn_connections, nm_vpn_connection_get_name (connection));
60 /* Fall through */
61 default:
62- if (applet->animation_id) {
63- g_source_remove (applet->animation_id);
64- applet->animation_id = 0;
65- }
66 foo_set_icon (applet, NULL, ICON_LAYER_VPN);
67 break;
68 }
69@@ -2295,45 +2268,6 @@
70 } FooAnimationTimeoutInfo;
71
72 static void
73-foo_animation_timeout_info_destroy (gpointer data)
74-{
75- g_slice_free (FooAnimationTimeoutInfo, data);
76-}
77-
78-static gboolean
79-foo_animation_timeout (gpointer data)
80-{
81- FooAnimationTimeoutInfo *info = (FooAnimationTimeoutInfo *) data;
82- NMApplet *applet = info->applet;
83- int stage = -1;
84-
85- switch (info->state) {
86- case NM_DEVICE_STATE_PREPARE:
87- stage = 0;
88- break;
89- case NM_DEVICE_STATE_CONFIG:
90- stage = 1;
91- break;
92- case NM_DEVICE_STATE_IP_CONFIG:
93- stage = 2;
94- break;
95- default:
96- break;
97- }
98-
99- if (stage >= 0)
100- foo_set_icon (applet,
101- applet->network_connecting_icons[stage][applet->animation_step],
102- ICON_LAYER_LINK);
103-
104- applet->animation_step++;
105- if (applet->animation_step >= NUM_CONNECTING_FRAMES)
106- applet->animation_step = 0;
107-
108- return TRUE;
109-}
110-
111-static void
112 foo_common_state_change (NMDevice *device, NMDeviceState state, NMApplet *applet)
113 {
114 FooAnimationTimeoutInfo *info;
115@@ -2345,11 +2279,7 @@
116 info = g_slice_new (FooAnimationTimeoutInfo);
117 info->applet = applet;
118 info->state = state;
119- applet->animation_step = 0;
120- applet->animation_id = g_timeout_add_full (G_PRIORITY_DEFAULT_IDLE,
121- 100, foo_animation_timeout,
122- info,
123- foo_animation_timeout_info_destroy);
124+ foo_set_icon (applet, applet->network_connecting_icon, ICON_LAYER_LINK);
125 break;
126 case NM_DEVICE_STATE_ACTIVATED:
127 break;
128@@ -2602,12 +2532,6 @@
129 NMApplet *applet = NM_APPLET (user_data);
130 gboolean handled = FALSE;
131
132- applet->animation_step = 0;
133- if (applet->animation_id) {
134- g_source_remove (applet->animation_id);
135- applet->animation_id = 0;
136- }
137-
138 clear_active_connections (applet);
139 applet->active_connections = nm_client_get_active_connections (applet->nm_client);
140
141@@ -3166,17 +3090,8 @@
142 if (applet->wireless_100_icon)
143 g_object_unref (applet->wireless_100_icon);
144
145- for (i = 0; i < NUM_CONNECTING_STAGES; i++) {
146- int j;
147-
148- for (j = 0; j < NUM_CONNECTING_FRAMES; j++)
149- if (applet->network_connecting_icons[i][j])
150- g_object_unref (applet->network_connecting_icons[i][j]);
151- }
152-
153- for (i = 0; i < NUM_VPN_CONNECTING_FRAMES; i++)
154- if (applet->vpn_connecting_icons[i])
155- g_object_unref (applet->vpn_connecting_icons[i]);
156+ if (applet->network_connecting_icon)
157+ g_object_unref (applet->network_connecting_icon);
158
159 nma_icons_zero (applet);
160 }
161@@ -3196,16 +3111,7 @@
162 applet->wireless_75_icon = NULL;
163 applet->wireless_100_icon = NULL;
164
165- for (i = 0; i < NUM_CONNECTING_STAGES; i++)
166- {
167- int j;
168-
169- for (j = 0; j < NUM_CONNECTING_FRAMES; j++)
170- applet->network_connecting_icons[i][j] = NULL;
171- }
172-
173- for (i = 0; i < NUM_VPN_CONNECTING_FRAMES; i++)
174- applet->vpn_connecting_icons[i] = NULL;
175+ applet->network_connecting_icon = NULL;
176
177 applet->icons_loaded = FALSE;
178 }
179@@ -3257,28 +3163,7 @@
180 ICON_LOAD(applet->wireless_75_icon, "nm-signal-75");
181 ICON_LOAD(applet->wireless_100_icon, "nm-signal-100");
182
183- for (i = 0; i < NUM_CONNECTING_STAGES; i++)
184- {
185- int j;
186-
187- for (j = 0; j < NUM_CONNECTING_FRAMES; j++)
188- {
189- char *name;
190-
191- name = g_strdup_printf ("nm-stage%02d-connecting%02d", i+1, j+1);
192- ICON_LOAD(applet->network_connecting_icons[i][j], name);
193- g_free (name);
194- }
195- }
196-
197- for (i = 0; i < NUM_VPN_CONNECTING_FRAMES; i++)
198- {
199- char *name;
200-
201- name = g_strdup_printf ("nm-vpn-connecting%02d", i+1);
202- ICON_LOAD(applet->vpn_connecting_icons[i], name);
203- g_free (name);
204- }
205+ ICON_LOAD(applet->network_connecting_icon, "nm-connecting");
206
207 success = TRUE;
208
209Index: trunk/src/applet.h
210===================================================================
211--- trunk.orig/src/applet.h 2008-02-06 20:30:06.000000000 +0000
212+++ trunk/src/applet.h 2008-02-06 20:46:05.000000000 +0000
213@@ -111,20 +111,12 @@
214 GdkPixbuf * wireless_50_icon;
215 GdkPixbuf * wireless_75_icon;
216 GdkPixbuf * wireless_100_icon;
217-#define NUM_CONNECTING_STAGES 3
218-#define NUM_CONNECTING_FRAMES 11
219- GdkPixbuf * network_connecting_icons[NUM_CONNECTING_STAGES][NUM_CONNECTING_FRAMES];
220-#define NUM_VPN_CONNECTING_FRAMES 14
221- GdkPixbuf * vpn_connecting_icons[NUM_VPN_CONNECTING_FRAMES];
222+ GdkPixbuf * network_connecting_icon;
223 GdkPixbuf * vpn_lock_icon;
224
225 /* Active status icon pixbufs */
226 GdkPixbuf * icon_layers[ICON_LAYER_MAX + 1];
227
228- /* Animation stuff */
229- int animation_step;
230- guint animation_id;
231-
232 /* Direct UI elements */
233 #ifdef HAVE_STATUS_ICON
234 GtkStatusIcon * status_icon;
diff --git a/meta-extras/packages/networkmanager/files/applet-no-gnome.diff b/meta-extras/packages/networkmanager/files/applet-no-gnome.diff
new file mode 100644
index 0000000000..e098e8c9ed
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/applet-no-gnome.diff
@@ -0,0 +1,59 @@
1---
2 configure.ac | 3 +--
3 src/main.c | 8 ++++++++
4 2 files changed, 9 insertions(+), 2 deletions(-)
5
6Index: src/main.c
7===================================================================
8--- src/main.c.orig 2007-09-26 10:39:16.000000000 +0100
9+++ src/main.c 2007-09-26 10:39:37.000000000 +0100
10@@ -27,7 +27,9 @@
11
12 #include <string.h>
13 #include <gtk/gtk.h>
14+#if 0
15 #include <libgnomeui/libgnomeui.h>
16+#endif
17 #include <glib/gi18n-lib.h>
18
19 #include "applet.h"
20@@ -36,11 +38,15 @@
21 int main (int argc, char *argv[])
22 {
23 NMApplet * applet;
24+#if 0
25 GnomeProgram * program;
26
27 program = gnome_program_init ("nm-applet", VERSION, LIBGNOMEUI_MODULE,
28 argc, argv,
29 GNOME_PARAM_NONE, GNOME_PARAM_NONE);
30+#else
31+ gtk_init (&argc, &argv);
32+#endif
33
34 bindtextdomain (GETTEXT_PACKAGE, GNOMELOCALEDIR);
35 bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
36@@ -53,7 +59,9 @@ int main (int argc, char *argv[])
37 gtk_main ();
38
39 g_object_unref (applet);
40+#if 0
41 g_object_unref (program);
42+#endif
43
44 exit (0);
45 }
46Index: configure.ac
47===================================================================
48--- configure.ac.orig 2007-09-26 10:39:30.000000000 +0100
49+++ configure.ac 2007-09-26 10:39:37.000000000 +0100
50@@ -65,8 +65,7 @@ PKG_CHECK_MODULES(NMA,
51 gtk+-2.0 >= 2.6
52 libglade-2.0
53 gconf-2.0
54- gnome-keyring-1
55- libgnomeui-2.0])
56+ gnome-keyring-1])
57
58 ##### Find out the version of DBUS we're using
59 dbus_version=`pkg-config --modversion dbus-1`
diff --git a/meta-extras/packages/networkmanager/files/libnlfix.patch b/meta-extras/packages/networkmanager/files/libnlfix.patch
new file mode 100644
index 0000000000..69f4922ea0
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/libnlfix.patch
@@ -0,0 +1,29 @@
1Index: trunk/src/nm-netlink.c
2===================================================================
3--- trunk.orig/src/nm-netlink.c 2007-09-25 22:37:50.000000000 +0100
4+++ trunk/src/nm-netlink.c 2009-05-16 12:44:26.000000000 +0100
5@@ -52,16 +52,20 @@
6 struct nl_handle *
7 nm_netlink_get_default_handle (void)
8 {
9+ struct nl_cb *cb;
10+
11 if (def_nl_handle)
12 return def_nl_handle;
13
14- def_nl_handle = nl_handle_alloc_nondefault (NL_CB_VERBOSE);
15- g_assert (def_nl_handle);
16+ cb = nl_cb_alloc(NL_CB_VERBOSE);
17+ def_nl_handle = nl_handle_alloc_cb (cb);
18+ if (!def_nl_handle) {
19+ nm_warning ("couldn't allocate netlink handle.");
20+ return NULL;
21+ }
22
23- nl_handle_set_pid (def_nl_handle, (pthread_self () << 16 | getpid ()));
24 if (nl_connect (def_nl_handle, NETLINK_ROUTE) < 0) {
25 nm_error ("couldn't connect to netlink: %s", nl_geterror ());
26- nl_handle_destroy (def_nl_handle);
27 return NULL;
28 }
29
diff --git a/meta-extras/packages/networkmanager/files/makefile-fix.patch b/meta-extras/packages/networkmanager/files/makefile-fix.patch
new file mode 100644
index 0000000000..5fbbf3a74a
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/makefile-fix.patch
@@ -0,0 +1,17 @@
1This line causes libtool to try and create a program which fails since there is no
2main(). This is hidden with libtool 1.5.10 but appears with 2.2.2.
3
4RP - 14/4/08
5
6Index: trunk/src/ppp-manager/Makefile.am
7===================================================================
8--- trunk.orig/src/ppp-manager/Makefile.am 2008-04-14 23:00:54.000000000 +0100
9+++ trunk/src/ppp-manager/Makefile.am 2008-04-14 23:01:24.000000000 +0100
10@@ -25,7 +25,6 @@
11 $(top_builddir)/src/marshallers/libmarshallers.la
12
13 nm_pppd_plugindir = $(libdir)
14-nm_pppd_plugin_PROGRAMS = nm-pppd-plugin.so
15
16 nm_pppd_plugin_so_SOURCES = \
17 nm-pppd-plugin.c \
diff --git a/meta-extras/packages/networkmanager/files/nmutil-fix.patch b/meta-extras/packages/networkmanager/files/nmutil-fix.patch
new file mode 100644
index 0000000000..d8495bac40
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/nmutil-fix.patch
@@ -0,0 +1,12 @@
1Index: trunk/configure.ac
2===================================================================
3--- trunk.orig/configure.ac 2009-01-08 10:49:26.000000000 -0600
4+++ trunk/configure.ac 2009-01-08 12:00:34.000000000 -0600
5@@ -62,6 +62,7 @@
6 glib-2.0 >= 2.10
7 NetworkManager >= 0.7.0
8 libnm_glib
9+ libnm-util
10 gtk+-2.0 >= 2.6
11 libglade-2.0
12 gconf-2.0
diff --git a/meta-extras/packages/networkmanager/files/no-restarts.diff b/meta-extras/packages/networkmanager/files/no-restarts.diff
new file mode 100644
index 0000000000..20bdf82aab
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/no-restarts.diff
@@ -0,0 +1,21 @@
1Index: src/backends/NetworkManagerDebian.c
2===================================================================
3--- src/backends/NetworkManagerDebian.c (revision 2881)
4+++ src/backends/NetworkManagerDebian.c (working copy)
5@@ -204,8 +204,6 @@
6 */
7 void nm_system_update_dns (void)
8 {
9- nm_spawn_process ("/usr/sbin/invoke-rc.d nscd restart");
10-
11 }
12
13
14@@ -218,7 +216,6 @@
15 */
16 void nm_system_restart_mdns_responder (void)
17 {
18- nm_spawn_process ("/usr/bin/killall -q -USR1 mDNSResponder");
19 }
20
21
diff --git a/meta-extras/packages/networkmanager/files/no_vpn.patch b/meta-extras/packages/networkmanager/files/no_vpn.patch
new file mode 100644
index 0000000000..49423e879f
--- /dev/null
+++ b/meta-extras/packages/networkmanager/files/no_vpn.patch
@@ -0,0 +1,13 @@
1Index: trunk/src/applet.c
2===================================================================
3--- trunk.orig/src/applet.c 2008-02-29 17:47:39.000000000 +0000
4+++ trunk/src/applet.c 2008-02-29 17:48:38.000000000 +0000
5@@ -1783,7 +1783,7 @@
6 }
7
8 nma_menu_add_devices (menu, applet);
9- nma_menu_add_vpn_submenu (menu, applet);
10+ //nma_menu_add_vpn_submenu (menu, applet);
11
12 gtk_widget_show_all (applet->menu);
13
diff --git a/meta-extras/packages/networkmanager/networkmanager-applet_svn.bb b/meta-extras/packages/networkmanager/networkmanager-applet_svn.bb
new file mode 100644
index 0000000000..1f0987011f
--- /dev/null
+++ b/meta-extras/packages/networkmanager/networkmanager-applet_svn.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "GTK+ applet for NetworkManager"
2HOMEPAGE = "http://projects.gnome.org/NetworkManager/"
3BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=NetworkManager&content="
4LICENSE = "GPLv2+ & LGPLv2.1+"
5DEPENDS = "networkmanager dbus-glib libglade gconf gnome-keyring"
6#TODO DEPENDS libnotify
7RDEPENDS = "networkmanager dbus-wait"
8PR = "r7"
9
10inherit gnome gtk-icon-cache
11
12SRC_URI = "svn://svn.gnome.org/svn/network-manager-applet/;module=trunk;proto=http \
13 file://applet-no-gnome.diff;patch=1;pnum=0 \
14 file://applet-no-animation.patch;patch=1 \
15 file://no_vpn.patch;patch=1 \
16 file://nmutil-fix.patch;patch=1 \
17 file://70NetworkManagerApplet.shbg"
18
19PV = "0.0+svnr${SRCREV}"
20
21S = "${WORKDIR}/trunk"
22
23FILES_${PN} += "${datadir}/nm-applet/ \
24 ${datadir}/gnome-vpn-properties/ \
25 ${datadir}/gnome/autostart/"
26
27do_install_append () {
28 install -d ${D}${sysconfdir}/X11/Xsession.d/
29 install -m 755 ${WORKDIR}/70NetworkManagerApplet.shbg ${D}${sysconfdir}/X11/Xsession.d/
30}
31
32#TODO: remove if libnotify in DEPENDS
33EXTRA_OECONF += "--without-libnotify"
diff --git a/meta-extras/packages/networkmanager/networkmanager_svn.bb b/meta-extras/packages/networkmanager/networkmanager_svn.bb
new file mode 100644
index 0000000000..40f04e497c
--- /dev/null
+++ b/meta-extras/packages/networkmanager/networkmanager_svn.bb
@@ -0,0 +1,51 @@
1DESCRIPTION = "NetworkManager"
2HOMEPAGE = "http://projects.gnome.org/NetworkManager/"
3BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=NetworkManager&content="
4SECTION = "net/misc"
5LICENSE = "GPLv2+ & LGPLv2+"
6PRIORITY = "optional"
7DEPENDS = "libnl dbus dbus-glib hal gconf-dbus wireless-tools ppp gnome-common polkit"
8RDEPENDS = "hal wpa-supplicant iproute2 dhcp-client"
9
10PV = "0.7+svnr${SRCREV}"
11PR = "r10"
12
13SRC_URI="svn://svn.gnome.org/svn/NetworkManager/;module=trunk;proto=http \
14 file://no-restarts.diff;patch=1;pnum=0 \
15 file://libnlfix.patch;patch=1 \
16 file://makefile-fix.patch;patch=1 \
17 file://allow-disabling.patch;patch=1 \
18 file://NetworkManager \
19 file://99_networkmanager"
20
21EXTRA_OECONF = "--with-distro=debian \
22 --with-ip=/sbin/ip"
23# TODO: will /bin/ip from busybox do?
24
25S = "${WORKDIR}/trunk"
26
27inherit autotools pkgconfig update-rc.d
28
29INITSCRIPT_NAME = "NetworkManager"
30INITSCRIPT_PARAMS = "defaults 22"
31
32do_install_append () {
33 install -d ${D}/etc/default/volatiles
34 install -m 0644 ${WORKDIR}/99_networkmanager ${D}/etc/default/volatiles
35 # This overwrites the provided init script
36 install -m 0755 ${WORKDIR}/NetworkManager ${D}/etc/init.d/
37 rmdir ${D}/var/run/NetworkManager
38 rmdir ${D}/var/run
39}
40
41PACKAGES =+ "libnmutil libnmglib"
42
43FILES_libnmutil += "${libdir}/libnm-util.so.*"
44
45FILES_libnmglib += "${libdir}/libnm_glib.so.*"
46
47FILES_${PN}-dev = "${includedir}/* \
48 ${libdir}/*.so \
49 ${libdir}/*.a \
50 ${libdir}/pkgconfig/*.pc \
51 ${datadir}/NetworkManager/gdb-cmd"