diff options
Diffstat (limited to 'meta-extras/packages/lirc/lirc-modules_0.8.3.bb')
-rw-r--r-- | meta-extras/packages/lirc/lirc-modules_0.8.3.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-extras/packages/lirc/lirc-modules_0.8.3.bb b/meta-extras/packages/lirc/lirc-modules_0.8.3.bb new file mode 100644 index 0000000000..ee1de7194e --- /dev/null +++ b/meta-extras/packages/lirc/lirc-modules_0.8.3.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls." | ||
2 | SECTION = "base" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "virtual/kernel virtual/fakeroot-native" | ||
6 | PR = "r2" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \ | ||
9 | file://lirc_sir-sa1100.patch;patch=1" | ||
10 | S = "${WORKDIR}/lirc-${PV}" | ||
11 | |||
12 | inherit autotools module-base | ||
13 | |||
14 | include lirc-config.inc | ||
15 | |||
16 | do_compile() { | ||
17 | # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them | ||
18 | cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS="" | ||
19 | } | ||
20 | |||
21 | fakeroot do_install() { | ||
22 | oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install | ||
23 | rm -rf ${D}/dev | ||
24 | } | ||
25 | |||
26 | pkg_postinst() { | ||
27 | #!/bin/sh | ||
28 | set -e | ||
29 | if [ ! -c $D/dev/lirc ]; then mknod $D/dev/lirc c 61 0; fi | ||
30 | exit 0 | ||
31 | } | ||
32 | |||
33 | FILES_${PN} = "/lib/modules" | ||