summaryrefslogtreecommitdiffstats
path: root/meta-extras/conf/machine/om-gta01.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/conf/machine/om-gta01.conf')
-rw-r--r--meta-extras/conf/machine/om-gta01.conf48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-extras/conf/machine/om-gta01.conf b/meta-extras/conf/machine/om-gta01.conf
new file mode 100644
index 0000000000..f40457e226
--- /dev/null
+++ b/meta-extras/conf/machine/om-gta01.conf
@@ -0,0 +1,48 @@
1#-----------------------------------------------------------------------------
2#@TYPE: Machine
3#@NAME: FIC GTA01 (Neo1973)
4#@DESCRIPTION: Machine configuration for the FIC Neo1973/1 GSM phone
5#-----------------------------------------------------------------------------
6
7TARGET_ARCH = "arm"
8MACHINE_CLASS = "neo1973"
9PACKAGE_EXTRA_ARCHS = "armv4t fic-gta01 ${MACHINE_CLASS}"
10
11PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko"
12UBOOT_ENTRYPOINT = "30008000"
13
14MACHINE_FEATURES = "kernel26 apm alsa bluetooth gps usbgadget usbhost phone vfat ext2"
15MACHINE_DISPLAY_WIDTH_PIXELS = "480"
16MACHINE_DISPLAY_HEIGHT_PIXELS = "640"
17MACHINE_DISPLAY_ORIENTATION = "0"
18MACHINE_DISPLAY_PPI = "285"
19XSERVER = "xserver-kdrive-fbdev"
20
21MACHINE_EXTRA_RDEPENDS = "usbinit"
22# package machine specific modules
23MACHINE_EXTRA_RRECOMMENDS = "\
24 kernel-module-gta01-pm-bt \
25 kernel-module-gta01-pm-gps \
26 kernel-module-gta01-pm-gsm \
27 kernel-module-gta01kbd \
28 kernel-module-s3cmci \
29 kernel-module-snd-soc-neo1973-wm8753 \
30 kernel-module-snd-soc-smdk2440 \
31"
32
33# do not outcomment, we bypass the sysvinit.bb logic here -- see FIC GTA01 inittab
34#SERIAL_CONSOLE = "115200 ttySAC0"
35
36# used by some images
37ROOT_FLASH_SIZE = "60"
38
39# extra jffs2 tweaks
40IMAGE_FSTYPES ?= "jffs2"
41EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x4000 --pad -n"
42
43# build / upload tools
44#EXTRA_IMAGEDEPENDS += "dfu-util-native"
45
46# tune for S3C24x0
47include conf/machine/include/tune-arm920t.inc
48