diff options
Diffstat (limited to 'meta-emenlow/recipes-kernel/linux')
3 files changed, 74 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig b/meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig new file mode 100644 index 0000000000..a516dc987e --- /dev/null +++ b/meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig | |||
@@ -0,0 +1,68 @@ | |||
1 | CONFIG_X86_32=y | ||
2 | CONFIG_PRINTK=y | ||
3 | |||
4 | # Basic hardware support for the box - network, USB, PCI, sound | ||
5 | CONFIG_NETDEVICES=y | ||
6 | CONFIG_NETDEV_1000=y | ||
7 | CONFIG_ATA=y | ||
8 | CONFIG_ATA_GENERIC=y | ||
9 | CONFIG_ATA_SFF=y | ||
10 | CONFIG_PCI=y | ||
11 | CONFIG_MMC=y | ||
12 | CONFIG_MMC_SDHCI=y | ||
13 | CONFIG_USB_SUPPORT=y | ||
14 | CONFIG_USB=y | ||
15 | CONFIG_USB_ARCH_HAS_EHCI=y | ||
16 | CONFIG_E1000E=y | ||
17 | CONFIG_R8169=y | ||
18 | CONFIG_PATA_SCH=y | ||
19 | CONFIG_MMC_SDHCI_PCI=y | ||
20 | CONFIG_USB_EHCI_HCD=y | ||
21 | CONFIG_PCIEPORTBUS=y | ||
22 | CONFIG_NET=y | ||
23 | CONFIG_USB_UHCI_HCD=y | ||
24 | CONFIG_BLK_DEV_SD=y | ||
25 | CONFIG_CHR_DEV_SG=y | ||
26 | CONFIG_SOUND=y | ||
27 | CONFIG_SND=y | ||
28 | CONFIG_SND_HDA_INTEL=y | ||
29 | |||
30 | # Make sure these are on, otherwise the bootup won't be fun | ||
31 | CONFIG_EXT3_FS=y | ||
32 | CONFIG_UNIX=y | ||
33 | CONFIG_INET=y | ||
34 | CONFIG_MODULES=y | ||
35 | CONFIG_SHMEM=y | ||
36 | CONFIG_TMPFS=y | ||
37 | CONFIG_PACKET=y | ||
38 | |||
39 | # These are needed for the Poulsbo kernel modules | ||
40 | CONFIG_I2C=y | ||
41 | CONFIG_AGP=y | ||
42 | CONFIG_VFAT_FS=y | ||
43 | CONFIG_PM=y | ||
44 | CONFIG_ACPI=y | ||
45 | CONFIG_FB=y | ||
46 | CONFIG_BACKLIGHT_LCD_SUPPORT=y | ||
47 | CONFIG_BACKLIGHT_CLASS_DEVICE=y | ||
48 | CONFIG_INPUT=y | ||
49 | CONFIG_VIDEO_V4L2=y | ||
50 | CONFIG_VIDEO_IVTV=y | ||
51 | CONFIG_MEDIA_SUPPORT=y | ||
52 | CONFIG_VIDEO_CAPTURE_DRIVERS=y | ||
53 | CONFIG_VIDEO_DEV=y | ||
54 | CONFIG_VIDEO_V4L2_COMMON=y | ||
55 | CONFIG_I2C_ALGOBIT=y | ||
56 | CONFIG_FB_CFB_COPYAREA=y | ||
57 | CONFIG_FB_CFB_IMAGEBLIT=y | ||
58 | CONFIG_FB_CFB_FILLRECT=y | ||
59 | CONFIG_VIDEO_FB_IVTV=y | ||
60 | |||
61 | # Needed for booting (and using) USB memory sticks | ||
62 | CONFIG_USB_STORAGE=y | ||
63 | CONFIG_BLK_DEV_RAM=y | ||
64 | CONFIG_BLK_DEV_LOOP=y | ||
65 | CONFIG_BLK_DEV_INITRD=y | ||
66 | CONFIG_RD_GZIP=y | ||
67 | CONFIG_NLS_CODEPAGE_437=y | ||
68 | CONFIG_NLS_ISO8859_1=y | ||
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend new file mode 100644 index 0000000000..9fa2937d4f --- /dev/null +++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | COMPATIBLE_MACHINE_emenlow = "emenlow" | ||
3 | KMACHINE_emenlow = "emenlow" | ||
diff --git a/meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend b/meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend new file mode 100644 index 0000000000..fac0921401 --- /dev/null +++ b/meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESPATH := "${FILESPATH}:${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | ||
2 | SRC_URI += "file://defconfig" | ||
3 | COMPATIBLE_MACHINE_emenlow = "emenlow" | ||