diff options
Diffstat (limited to 'meta-emenlow/recipes-graphics/libdrm-poulsbo')
-rw-r--r-- | meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch | 61 | ||||
-rw-r--r-- | meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb | 19 |
2 files changed, 80 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch new file mode 100644 index 0000000000..14bde6887a --- /dev/null +++ b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch | |||
@@ -0,0 +1,61 @@ | |||
1 | # Make this package produce libdrm-poulsbo instead of libdrm so that the | ||
2 | # emenlow libdrm can coexist with the normal libdrm. | ||
3 | # jdike@linux.intel.com | ||
4 | |||
5 | Index: libdrm-poulsbo-2.3.0/configure.ac | ||
6 | =================================================================== | ||
7 | --- libdrm-poulsbo-2.3.0.orig/configure.ac | ||
8 | +++ libdrm-poulsbo-2.3.0/configure.ac | ||
9 | @@ -19,7 +19,7 @@ | ||
10 | # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
11 | |||
12 | AC_PREREQ(2.57) | ||
13 | -AC_INIT([libdrm], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm) | ||
14 | +AC_INIT([libdrm_poulsbo], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm_poulsbo) | ||
15 | AC_CONFIG_SRCDIR([Makefile.am]) | ||
16 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
17 | |||
18 | @@ -35,4 +35,4 @@ AC_SYS_LARGEFILE | ||
19 | pkgconfigdir=${libdir}/pkgconfig | ||
20 | AC_SUBST(pkgconfigdir) | ||
21 | |||
22 | -AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm.pc]) | ||
23 | +AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm_poulsbo.pc]) | ||
24 | Index: libdrm-poulsbo-2.3.0/Makefile.am | ||
25 | =================================================================== | ||
26 | --- libdrm-poulsbo-2.3.0.orig/Makefile.am | ||
27 | +++ libdrm-poulsbo-2.3.0/Makefile.am | ||
28 | @@ -25,6 +25,6 @@ AUTOMAKE_OPTIONS = foreign | ||
29 | SUBDIRS = libdrm shared-core | ||
30 | |||
31 | pkgconfigdir = @pkgconfigdir@ | ||
32 | -pkgconfig_DATA = libdrm.pc | ||
33 | +pkgconfig_DATA = libdrm_poulsbo.pc | ||
34 | |||
35 | -EXTRA_DIST = libdrm.pc.in | ||
36 | +EXTRA_DIST = libdrm_poulsbo.pc.in | ||
37 | Index: libdrm-poulsbo-2.3.0/libdrm/Makefile.am | ||
38 | =================================================================== | ||
39 | --- libdrm-poulsbo-2.3.0.orig/libdrm/Makefile.am | ||
40 | +++ libdrm-poulsbo-2.3.0/libdrm/Makefile.am | ||
41 | @@ -18,14 +18,14 @@ | ||
42 | # IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN | ||
43 | # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
44 | |||
45 | -libdrm_la_LTLIBRARIES = libdrm.la | ||
46 | -libdrm_ladir = $(libdir) | ||
47 | -libdrm_la_LDFLAGS = -version-number 2:3:0 -no-undefined | ||
48 | +libdrm_poulsbo_la_LTLIBRARIES = libdrm_poulsbo.la | ||
49 | +libdrm_poulsbo_ladir = $(libdir) | ||
50 | +libdrm_poulsbo_la_LDFLAGS = -version-number 2:3:0 -no-undefined | ||
51 | |||
52 | AM_CFLAGS = -I$(top_srcdir)/shared-core | ||
53 | -libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c xf86drmMode.c | ||
54 | +libdrm_poulsbo_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c xf86drmMode.c | ||
55 | |||
56 | -libdrmincludedir = ${includedir}/psb | ||
57 | -libdrminclude_HEADERS = xf86drm.h xf86mm.h xf86drmMode.h | ||
58 | +libdrm_poulsboincludedir = ${includedir}/psb | ||
59 | +libdrm_poulsboinclude_HEADERS = xf86drm.h xf86mm.h xf86drmMode.h | ||
60 | |||
61 | EXTRA_DIST = ChangeLog TODO | ||
diff --git a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb new file mode 100644 index 0000000000..d0e14a5622 --- /dev/null +++ b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "Userspace interface to kernel DRM services" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7" | ||
4 | PR = "r4" | ||
5 | |||
6 | PROVIDES = "libdrm-poulsbo" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libdrm-poulsbo_2.3.0-1ubuntu0sarvatt4~1004um1ubuntu1.tar.gz \ | ||
11 | file://libdrm-poulsbo.patch" | ||
12 | |||
13 | SRC_URI[md5sum] = "82c00bb9f1239f1d00b18411b89c2380" | ||
14 | SRC_URI[sha256sum] = "335d4ac6694687475efe07b44a2d77a9a9fadcbc16946d01ea8a02339ae7d9ec" | ||
15 | |||
16 | do_configure_prepend() { | ||
17 | sed -e 's/-ldrm/-ldrm_poulsbo/' -e 's/libdrm/libdrm_poulsbo/' \ | ||
18 | < ${S}/libdrm.pc.in > ${S}/libdrm_poulsbo.pc.in | ||
19 | } | ||