summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch')
-rw-r--r--meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch b/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch
new file mode 100644
index 0000000000..029d761d95
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch
@@ -0,0 +1,63 @@
1During the build process the mkg3states binary needs to be run. This patch
2allows it to be built with the build systems gcc allowing this to work.
3
4RP 31/3/10
5
6Index: liblbxutil-1.1.0/configure.ac
7===================================================================
8--- liblbxutil-1.1.0.orig/configure.ac 2009-12-04 22:52:04.000000000 +0000
9+++ liblbxutil-1.1.0/configure.ac 2010-03-31 15:26:33.000000000 +0100
10@@ -50,4 +50,5 @@
11
12 AC_OUTPUT([Makefile
13 src/Makefile
14+ src/image/Makefile
15 lbxutil.pc])
16Index: liblbxutil-1.1.0/src/Makefile.am
17===================================================================
18--- liblbxutil-1.1.0.orig/src/Makefile.am 2009-12-04 23:03:17.000000000 +0000
19+++ liblbxutil-1.1.0/src/Makefile.am 2010-03-31 15:27:25.000000000 +0100
20@@ -3,10 +3,7 @@
21 AM_CFLAGS = $(CWARNFLAGS) $(LBXUTIL_CFLAGS)
22 INCLUDES = -I$(top_srcdir)/include
23
24-noinst_PROGRAMS = mkg3states
25-
26-mkg3states_SOURCES = \
27- $(srcdir)/image/mkg3states.c
28+SUBDIRS = image
29
30 liblbxutil_la_SOURCES = \
31 $(srcdir)/lbx_zlib/reqstats.h \
32@@ -38,9 +35,8 @@
33
34 $(srcdir)/image/dfaxg42d.c: g3states.h
35
36-g3states.h: mkg3states
37- -rm -f g3states.h
38- $(AM_V_GEN) ./mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
39+g3states.h: image/mkg3states
40+ ./image/mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
41
42 liblbxutil_la_LDFLAGS = -version-number 1:0:0 -no-undefined
43
44Index: liblbxutil-1.1.0/src/image/Makefile.am
45===================================================================
46--- /dev/null 1970-01-01 00:00:00.000000000 +0000
47+++ liblbxutil-1.1.0/src/image/Makefile.am 2010-03-31 15:26:33.000000000 +0100
48@@ -0,0 +1,15 @@
49+# evil hack
50+CFLAGS=$(CFLAGS_FOR_BUILD)
51+CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
52+LDFLAGS=$(LDFLAGS_FOR_BUILD)
53+
54+CC=$(CC_FOR_BUILD)
55+LIBTOOL = @LIBTOOL@ --tag=CC
56+
57+noinst_PROGRAMS = mkg3states
58+
59+mkg3states_SOURCES = \
60+ mkg3states.c
61+
62+mkg3states_CFLAGS=$(CFLAGS_FOR_BUILD)
63+mkg3states_LDFLAGS=$(LDFLAGS_FOR_BUILD)