summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch')
-rw-r--r--meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch b/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch
deleted file mode 100644
index 63c1847223..0000000000
--- a/meta-demoapps/recipes-graphics/xorg-lib/liblbxutil/mkg3states.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1Upstream-Status: Inappropriate [configuration]
2
3During the build process the mkg3states binary needs to be run. This patch
4allows it to be built with the build systems gcc allowing this to work.
5
6RP 31/3/10
7
8Index: liblbxutil-1.1.0/configure.ac
9===================================================================
10--- liblbxutil-1.1.0.orig/configure.ac 2009-12-04 22:52:04.000000000 +0000
11+++ liblbxutil-1.1.0/configure.ac 2010-03-31 15:26:33.000000000 +0100
12@@ -50,4 +50,5 @@
13
14 AC_OUTPUT([Makefile
15 src/Makefile
16+ src/image/Makefile
17 lbxutil.pc])
18Index: liblbxutil-1.1.0/src/Makefile.am
19===================================================================
20--- liblbxutil-1.1.0.orig/src/Makefile.am 2009-12-04 23:03:17.000000000 +0000
21+++ liblbxutil-1.1.0/src/Makefile.am 2010-03-31 15:27:25.000000000 +0100
22@@ -3,10 +3,7 @@
23 AM_CFLAGS = $(CWARNFLAGS) $(LBXUTIL_CFLAGS)
24 INCLUDES = -I$(top_srcdir)/include
25
26-noinst_PROGRAMS = mkg3states
27-
28-mkg3states_SOURCES = \
29- $(srcdir)/image/mkg3states.c
30+SUBDIRS = image
31
32 liblbxutil_la_SOURCES = \
33 $(srcdir)/lbx_zlib/reqstats.h \
34@@ -38,9 +35,8 @@
35
36 $(srcdir)/image/dfaxg42d.c: g3states.h
37
38-g3states.h: mkg3states
39- -rm -f g3states.h
40- $(AM_V_GEN) ./mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
41+g3states.h: image/mkg3states
42+ ./image/mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
43
44 liblbxutil_la_LDFLAGS = -version-number 1:0:0 -no-undefined
45
46Index: liblbxutil-1.1.0/src/image/Makefile.am
47===================================================================
48--- /dev/null 1970-01-01 00:00:00.000000000 +0000
49+++ liblbxutil-1.1.0/src/image/Makefile.am 2010-03-31 15:26:33.000000000 +0100
50@@ -0,0 +1,15 @@
51+# evil hack
52+CFLAGS=$(CFLAGS_FOR_BUILD)
53+CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
54+LDFLAGS=$(LDFLAGS_FOR_BUILD)
55+
56+CC=$(CC_FOR_BUILD)
57+LIBTOOL = @LIBTOOL@ --tag=CC
58+
59+noinst_PROGRAMS = mkg3states
60+
61+mkg3states_SOURCES = \
62+ mkg3states.c
63+
64+mkg3states_CFLAGS=$(CFLAGS_FOR_BUILD)
65+mkg3states_LDFLAGS=$(LDFLAGS_FOR_BUILD)