summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb')
-rw-r--r--meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb b/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
new file mode 100644
index 0000000000..e3ac0017ff
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Parsing and Encoding of WBXML documents"
2DESCRIPTION = "The WBXML Library (aka libwbxml) contains a library and \
3its associated tools to Parse, Encode and Handle WBXML documents. The \
4WBXML format is a binary representation of XML, defined by the Wap \
5Forum, and used to reduce bandwidth in mobile communications."
6LICENSE = "GPLv2"
7
8DEPENDS = "libxml2 sed-native expat"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
11 file://no-doc-install.patch;patch=1"
12
13inherit autotools pkgconfig
14
15do_configure_append() {
16 sed -i s:-I/usr/include::g Makefile
17 sed -i s:-I/usr/include::g */Makefile
18}
19
20PACKAGES += "${PN}-tools"
21
22FILES_${PN}-tools = "${bindir}"
23FILES_${PN} = "${libdir}/*.so.*"
24