summaryrefslogtreecommitdiffstats
path: root/bitbake/classes/base.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake/classes/base.bbclass')
-rw-r--r--bitbake/classes/base.bbclass79
1 files changed, 79 insertions, 0 deletions
diff --git a/bitbake/classes/base.bbclass b/bitbake/classes/base.bbclass
new file mode 100644
index 0000000000..1d75964f57
--- /dev/null
+++ b/bitbake/classes/base.bbclass
@@ -0,0 +1,79 @@
1# Copyright (C) 2003 Chris Larson
2#
3# Permission is hereby granted, free of charge, to any person obtaining a
4# copy of this software and associated documentation files (the "Software"),
5# to deal in the Software without restriction, including without limitation
6# the rights to use, copy, modify, merge, publish, distribute, sublicense,
7# and/or sell copies of the Software, and to permit persons to whom the
8# Software is furnished to do so, subject to the following conditions:
9#
10# The above copyright notice and this permission notice shall be included
11# in all copies or substantial portions of the Software.
12#
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
16# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
17# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
18# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
19# OTHER DEALINGS IN THE SOFTWARE.
20
21die() {
22 bbfatal "$*"
23}
24
25bbnote() {
26 echo "NOTE:" "$*"
27}
28
29bbwarn() {
30 echo "WARNING:" "$*"
31}
32
33bbfatal() {
34 echo "FATAL:" "$*"
35 exit 1
36}
37
38bbdebug() {
39 test $# -ge 2 || {
40 echo "Usage: bbdebug level \"message\""
41 exit 1
42 }
43
44 test ${@bb.debug_level} -ge $1 && {
45 shift
46 echo "DEBUG:" $*
47 }
48}
49
50addtask showdata
51do_showdata[nostamp] = "1"
52python do_showdata() {
53 import sys
54 # emit variables and shell functions
55 bb.data.emit_env(sys.__stdout__, d, True)
56 # emit the metadata which isnt valid shell
57 for e in bb.data.keys(d):
58 if bb.data.getVarFlag(e, 'python', d):
59 sys.__stdout__.write("\npython %s () {\n%s}\n" % (e, bb.data.getVar(e, d, 1)))
60}
61
62addtask listtasks
63do_listtasks[nostamp] = "1"
64python do_listtasks() {
65 import sys
66 for e in bb.data.keys(d):
67 if bb.data.getVarFlag(e, 'task', d):
68 sys.__stdout__.write("%s\n" % e)
69}
70
71addtask build
72do_build[dirs] = "${TOPDIR}"
73do_build[nostamp] = "1"
74python base_do_build () {
75 bb.note("The included, default BB base.bbclass does not define a useful default task.")
76 bb.note("Try running the 'listtasks' task against a .bb to see what tasks are defined.")
77}
78
79EXPORT_FUNCTIONS do_clean do_mrproper do_build