summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2014-12-03 11:15:51 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-05 18:00:22 +0000
commitbf0ec702842e5cf78b96e8581d1a5f14c0d948ae (patch)
tree667ed1044fa41be68510a1600d6739575b8dc563 /scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend
parent0cc9a12ff855ad472c082efc429043208112b888 (diff)
downloadpoky-bf0ec702842e5cf78b96e8581d1a5f14c0d948ae.tar.gz
yocto-bsp: Add mips64 support
mips64 support was recently added to the core BSPs; we should also support it in yocto-bsp. [YOCTO #5314] (From meta-yocto rev: 3f3d29e2df6462c915d0763ab07f3be3c739ca4d) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend b/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend
index 013883ffeb..5c5b0c8916 100644
--- a/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.14": }} linux-yocto-tiny_3.4.bbappend
@@ -35,6 +35,12 @@ COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
35{{ if need_new_kbranch == "n" and qemuarch == "mips": }} 35{{ if need_new_kbranch == "n" and qemuarch == "mips": }}
36{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }} 36{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
37 37
38{{ if need_new_kbranch == "y" and qemuarch == "mips64": }}
39{{ input type:"choicelist" name:"new_kbranch" nameappend:"mips64" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
40
41{{ if need_new_kbranch == "n" and qemuarch == "mips64": }}
42{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips64" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
43
38{{ if need_new_kbranch == "n": }} 44{{ if need_new_kbranch == "n": }}
39KBRANCH_{{=machine}} = "{{=existing_kbranch}}" 45KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
40 46