summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-03-27 21:32:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 08:52:14 +0100
commite6adeac7aa322bb074c0daf2c773f0d80eb59141 (patch)
tree819d42bbe0a83d883ab5949d2de96d28f330b264 /scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
parent759fcd204f9594b078b4ceebcdb2049793f7a288 (diff)
downloadpoky-e6adeac7aa322bb074c0daf2c773f0d80eb59141.tar.gz
recipes-kernel: Skip kernel version check on kernel templates
Currently, SRCREV is set to AUTOREV, causing mismatch between PV and the kernel version shown in the makefile (see below to see the bitbake log). The solution is to skip this check, suggesting to remove it once SRCREV is locked. ERROR: linux-yocto-4.10+gitAUTOINC+01f18cba44_53be19cad6-r0.1 do_kernel_version_sanity_check: Package Version (4.10+gitAUTOINC+01f18cba44_53be19cad6) does not match of kernel being built (4.10.5). Please update the PV variable to match the kernel source or set KERNEL_VERSION_SANITY_SKIP="1" in your recipe. ERROR: linux-yocto-4.10+gitAUTOINC+01f18cba44_53be19cad6-r0.1 do_kernel_version_sanity_check: Function failed: do_kernel_version_sanity_check (log file is located at /home/lsandov1/poky2/build/tmp/work/myqemu-poky-linux/linux-yocto/4.10+gitAUTOINC+01f18cba44_53be19cad6-r0.1/temp/log.do_kernel_version_sanity_check.26904) ERROR: Logfile of failure stored in: /home/lsandov1/poky2/build/tmp/work/myqemu-poky-linux/linux-yocto/4.10+gitAUTOINC+01f18cba44_53be19cad6-r0.1/temp/log.do_kernel_version_sanity_check.26904 ERROR: Task (/home/lsandov1/poky2/meta/recipes-kernel/linux/linux-yocto_4.10.bb:do_kernel_version_sanity_check) failed with exit code '1 [YOCTO #11064] (From meta-yocto rev: 79bfd911f826c6c7e26827bb200dd69e6f567b17) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
index 815c77b813..070bd876ad 100644
--- a/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
@@ -31,3 +31,5 @@ SRC_URI += "file://{{=machine}}-tiny.scc \
31SRCREV_machine_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}" 31SRCREV_machine_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
32SRCREV_meta_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}" 32SRCREV_meta_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
33#LINUX_VERSION = "4.4" 33#LINUX_VERSION = "4.4"
34#Remove the following line once AUTOREV is locked to a certain SRCREV
35KERNEL_VERSION_SANITY_SKIP = "1"