summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-22 23:43:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-05 22:54:29 +0100
commitfd7077260b1675b21228903cc8b616254926eadf (patch)
tree915a01bc843edd99ddac9cb7eab01779f503f2c3 /scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend
parent03b5c841618f14445ff720e542da02f92490dece (diff)
downloadpoky-fd7077260b1675b21228903cc8b616254926eadf.tar.gz
yocto-bsp: add KBRANCH for existing kbranch cases
For the cases where a BSP reuses an existing branch, we still need the KBRANCH in order to be able to specify an existing branch. (From meta-yocto rev: 5a3167c4fa6cb53ec501e9de185b93748973ec18) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend b/scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend
index d2559e0da1..cdf52af6c0 100644
--- a/scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/mips/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.8": }} linux-yocto_3.8.bbappend
@@ -12,6 +12,9 @@ COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
12{{ if need_new_kbranch == "n": }} 12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }} 13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
14 14
15{{ if need_new_kbranch == "n": }}
16KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
17
15{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}} 18{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
16{{ if smp == "y": }} 19{{ if smp == "y": }}
17KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc" 20KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"