summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
diff options
context:
space:
mode:
authorBrian A. Lloyd <brian.lloyd@familyhonor.net>2013-01-21 15:14:22 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-05 21:37:35 +0000
commita7ce81df2f6e513a7e364c443759733c778b5c1f (patch)
treee11282313e3183c367b22bea664405189b1f1384 /scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
parent47b0864fbd65746558d8186450c182d98bac78ca (diff)
downloadpoky-a7ce81df2f6e513a7e364c443759733c778b5c1f.tar.gz
yocto-bsp: qualify user files with machine name
The bblayer abstraction makes it where multiple layers can be configured and used at the same time. Some layers make changes to support a specific machine, and should not have any affect when other machines are in use. For linux-yocto, all bsps are created with a user-config.cfg and user-config.cfg and user-patches.scc. This means that those files will be pulled from the first location found, which might correspond to files customized for a different machine. Instead of using the names user-config.cfg and user-patches.scc, I propose a machine specific name be used such as {{=machine}}user-patches.scc and {{=machine}}user-config.cfg. This would necessitate that all references changed to these new names, which would affect the yocto-bsp and yocto-kernel scripts. With this change, it would be possible to have multiple machine BSPs searched at the same time and to select which to build against by using a command like MACHINE=qmeux86 bitbake core-image-sato to override the default. Note many of the standard BSPs do not seem to suffer this problem as they do not use the common files user-config.cfg and user-patches.scc that the yocto-* scripts depend upon. Additions by Tom Zanussi: - renamed user-config.cfg to {{=machine}}-user-config.cfg everywhere - renamed user-patches.scc to {{=machine}}-user-patches.scc everywhere - added the user-config/patches SRC_URI items to the qemu -rt kernel recipes Fixes [YOCTO #3731] (From meta-yocto rev: b148d800773f3c2e6edeb4f05850b0291a8bb7d5) Signed-off-by: Brian A. Lloyd <brian.lloyd@familyhonor.net> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
index f11bfa5833..1ae5ceee18 100644
--- a/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 1FILESEXTRAPATHS_prepend_{{=machine}} := "${THISDIR}/files:"
2 2
3PR := "${PR}.1" 3PR := "${PR}.1"
4 4
@@ -27,8 +27,8 @@ KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
27SRC_URI += "file://{{=machine}}-preempt-rt.scc \ 27SRC_URI += "file://{{=machine}}-preempt-rt.scc \
28 file://{{=machine}}.scc \ 28 file://{{=machine}}.scc \
29 file://{{=machine}}.cfg \ 29 file://{{=machine}}.cfg \
30 file://user-config.cfg \ 30 file://{{=machine}}-user-config.cfg \
31 file://user-patches.scc \ 31 file://{{=machine}}-user-patches.scc \
32 " 32 "
33 33
34# uncomment and replace these SRCREVs with the real commit ids once you've had 34# uncomment and replace these SRCREVs with the real commit ids once you've had