summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-08-28 22:01:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-29 14:23:36 -0700
commitbb0aab79e488a99cb1b43f72f0e8ddbe39d97519 (patch)
tree5b3d2ebfd5ce6d7fb6f0d2094c566635b5e9d12d /scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
parent6b961470486b2dd4215f6753d4f155e6f279959c (diff)
downloadpoky-bb0aab79e488a99cb1b43f72f0e8ddbe39d97519.tar.gz
yocto-bsp: use KBRANCH_DEFAULT in 'newbranch' cases
The new yocto-kernel way of specifying that the branch sanity check doesn't need to be run is to specify a default kbranch and build that. In the case where we have a new kbranch but it's not yet in the repo, we need to tell it that our new branch is the default and we're building the default and that's how we avoid the sanity check and the subsequent do_validate_branches() failure. (From meta-yocto rev: dadd020c67e901609be3ac13a4ffd8cb28532966) Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
index bea555c33f..5b20babe77 100644
--- a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
@@ -13,7 +13,8 @@ COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }} 13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
14 14
15{{ if need_new_kbranch == "y": }} 15{{ if need_new_kbranch == "y": }}
16KBRANCH_{{=machine}} = "{{=strip_base(new_kbranch)}}/{{=machine}}" 16KBRANCH_DEFAULT_{{=machine}} = "{{=strip_base(new_kbranch)}}/{{=machine}}"
17KBRANCH_{{=machine}} = "${KBRANCH_DEFAULT}"
17{{ if need_new_kbranch == "n": }} 18{{ if need_new_kbranch == "n": }}
18KBRANCH_{{=machine}} = "{{=existing_kbranch}}" 19KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
19 20