summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-22 23:43:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-05 22:54:29 +0100
commitfd7077260b1675b21228903cc8b616254926eadf (patch)
tree915a01bc843edd99ddac9cb7eab01779f503f2c3 /scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
parent03b5c841618f14445ff720e542da02f92490dece (diff)
downloadpoky-fd7077260b1675b21228903cc8b616254926eadf.tar.gz
yocto-bsp: add KBRANCH for existing kbranch cases
For the cases where a BSP reuses an existing branch, we still need the KBRANCH in order to be able to specify an existing branch. (From meta-yocto rev: 5a3167c4fa6cb53ec501e9de185b93748973ec18) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
index 5112c07a56..146009aa1c 100644
--- a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
@@ -11,6 +11,9 @@ COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
11{{ if need_new_kbranch == "n": }} 11{{ if need_new_kbranch == "n": }}
12{{ input type:"choicelist" name:"existing_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }} 12{{ input type:"choicelist" name:"existing_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
13 13
14{{ if need_new_kbranch == "n": }}
15KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
16
14{{ input type:"boolean" name:"smp" prio:"30" msg:"Would you like SMP support? (y/n)" default:"y"}} 17{{ input type:"boolean" name:"smp" prio:"30" msg:"Would you like SMP support? (y/n)" default:"y"}}
15{{ if smp == "y": }} 18{{ if smp == "y": }}
16KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc" 19KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"