summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-08 20:37:25 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-08 20:37:25 +0000
commit64725e12d44b3484ddde2de6e265f6d64331a4f3 (patch)
treeef030a7fc8f565ca0cc8920d6dc1f313a5ff7aa9 /openembedded
parent722f400c1cf04aaa90c760f3b6507492c74235fc (diff)
downloadpoky-64725e12d44b3484ddde2de6e265f6d64331a4f3.tar.gz
Add accidently removed module-init-tools bb file
git-svn-id: https://svn.o-hand.com/repos/poky@176 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools_3.1.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb
new file mode 100644
index 0000000000..62523f513a
--- /dev/null
+++ b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb
@@ -0,0 +1,60 @@
1LICENSE = "GPL"
2SECTION = "base"
3DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
4removing kernel modules for Linux (versions 2.5.48 and above). It serves \
5the same function that the modutils package serves for Linux 2.4."
6PR = "r2"
7
8PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
9RDEPENDS_${PN} += "module-init-tools-depmod"
10
11FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
12FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
13
14SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
15 file://ignore_arch_directory;patch=1 \
16 file://modutils_extension;patch=1 \
17 file://no_man_rebuild;patch=1 \
18 file://manpagesopt;patch=1 \
19 file://soc.patch;patch=1;pnum=0"
20S = "${WORKDIR}/module-init-tools-${PV}"
21
22EXTRA_OECONF = "--disable-manpages"
23
24bindir = "/bin"
25sbindir = "/sbin"
26
27inherit autotools
28
29do_install() {
30 autotools_do_install
31 for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
32 mv ${D}/$f ${D}/$f.26
33 done
34}
35
36pkg_postinst_module-init-tools() {
37#!/bin/sh
38for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
39bn=`basename $f`
40 update-alternatives --install /$f $bn /$f.26 20
41done
42}
43
44pkg_prerm_module-init-tools() {
45#!/bin/sh
46for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
47bn=`basename $f`
48 update-alternatives --remove $bn /$f.26
49done
50}
51
52pkg_postinst_module-init-tools-depmod() {
53#!/bin/sh
54update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 20
55}
56
57pkg_prerm_module-init-tools() {
58#!/bin/sh
59update-alternatives --remove depmod /sbin/depmod.26
60}