summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-02-13 00:21:13 +0000
committerRichard Purdie <richard@openedhand.com>2006-02-13 00:21:13 +0000
commitc66704cd6f91044a345096b9e3ab413e14e79319 (patch)
tree23700094871048b2deebd1e75ac5bb2171846c6d /openembedded
parent5fb35ca11147ed30c619cf93e19331fd835f3da9 (diff)
downloadpoky-c66704cd6f91044a345096b9e3ab413e14e79319.tar.gz
Various misc metadata fixes to enable poky builds again
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@273 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/classes/package.bbclass4
-rw-r--r--openembedded/conf/distro/poky.conf4
-rwxr-xr-xopenembedded/packages/eds/eds-dbus_svn.bb3
-rw-r--r--openembedded/packages/fontconfig/fontconfig_2.2.95.bb4
-rwxr-xr-xopenembedded/packages/gnome/gnome-vfs-dbus_cvs.bb2
-rw-r--r--openembedded/packages/gtk+/gtk+_2.6.7.bb2
6 files changed, 14 insertions, 5 deletions
diff --git a/openembedded/classes/package.bbclass b/openembedded/classes/package.bbclass
index fd8d1b7b09..03a533d59a 100644
--- a/openembedded/classes/package.bbclass
+++ b/openembedded/classes/package.bbclass
@@ -84,8 +84,8 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst
84# Function to strip a single file, called from RUNSTRIP below 84# Function to strip a single file, called from RUNSTRIP below
85# A working 'file' (one which works on the target architecture) 85# A working 'file' (one which works on the target architecture)
86# is necessary for this stuff to work. 86# is necessary for this stuff to work.
87PACKAGE_DEPENDS ?= "file-native" 87#PACKAGE_DEPENDS ?= "file-native"
88DEPENDS_prepend =+ "${PACKAGE_DEPENDS} " 88#DEPENDS_prepend =+ "${PACKAGE_DEPENDS} "
89#FIXME: this should be "" when any errors are gone! 89#FIXME: this should be "" when any errors are gone!
90IGNORE_STRIP_ERRORS ?= "1" 90IGNORE_STRIP_ERRORS ?= "1"
91 91
diff --git a/openembedded/conf/distro/poky.conf b/openembedded/conf/distro/poky.conf
index ad35c65b00..a996183c79 100644
--- a/openembedded/conf/distro/poky.conf
+++ b/openembedded/conf/distro/poky.conf
@@ -69,6 +69,8 @@ PREFERRED_PROVIDER_x11 = "diet-x11"
69PREFERRED_PROVIDER_gconf=gconf-dbus 69PREFERRED_PROVIDER_gconf=gconf-dbus
70PREFERRED_PROVIDER_gnome-vfs=gnome-vfs-dbus 70PREFERRED_PROVIDER_gnome-vfs=gnome-vfs-dbus
71 71
72PREFERRED_VERSION_gnome-vfs-dbus = "2.12.0+cvs${SRCDATE}"
73
72 74
73# 75#
74# CVS Dates to use: 76# CVS Dates to use:
@@ -170,3 +172,5 @@ PREFERRED_VERSION_xrdb ?= "0.0+cvs${SRCDATE}"
170PREFERRED_VERSION_xst ?= "0.15" 172PREFERRED_VERSION_xst ?= "0.15"
171 173
172PREFERRED_VERSION_oprofile ?= "0.0+cvs${SRCDATE}" 174PREFERRED_VERSION_oprofile ?= "0.0+cvs${SRCDATE}"
175
176PCMCIA_MANAGER = "pcmciautils" \ No newline at end of file
diff --git a/openembedded/packages/eds/eds-dbus_svn.bb b/openembedded/packages/eds/eds-dbus_svn.bb
index 98658a1fae..a402e65a27 100755
--- a/openembedded/packages/eds/eds-dbus_svn.bb
+++ b/openembedded/packages/eds/eds-dbus_svn.bb
@@ -1,6 +1,7 @@
1LICENSE = "LGPL" 1LICENSE = "LGPL"
2DEPENDS = "glib-2.0 gtk+ gconf dbus db gnome-common libglade libiconv" 2DEPENDS = "glib-2.0 gtk+ gconf dbus db gnome-common libglade libiconv"
3RDEPENDS = "gconf dbus-1 db libiconv" 3RDEPENDS = "gconf db libiconv"
4#dbus
4MAINTAINER = "Chris Lord <chris@openedhand.com>" 5MAINTAINER = "Chris Lord <chris@openedhand.com>"
5DESCRIPTION = "Evolution database backend server" 6DESCRIPTION = "Evolution database backend server"
6PV = "1.4.0+svn${SRCDATE}" 7PV = "1.4.0+svn${SRCDATE}"
diff --git a/openembedded/packages/fontconfig/fontconfig_2.2.95.bb b/openembedded/packages/fontconfig/fontconfig_2.2.95.bb
index 6989b7a053..78b35b1793 100644
--- a/openembedded/packages/fontconfig/fontconfig_2.2.95.bb
+++ b/openembedded/packages/fontconfig/fontconfig_2.2.95.bb
@@ -7,11 +7,13 @@ SRC_URI = "http://pdx.freedesktop.org/fontconfig/release/fontconfig-${PV}.tar.gz
7 file://fc-glyphname.patch;patch=1 \ 7 file://fc-glyphname.patch;patch=1 \
8 file://fc-lang.patch;patch=1 \ 8 file://fc-lang.patch;patch=1 \
9 file://local.conf" 9 file://local.conf"
10PR = "r1" 10PR = "r2"
11 11
12PACKAGES =+ "fontconfig-utils " 12PACKAGES =+ "fontconfig-utils "
13FILES_fontconfig-utils = "${bindir}/*" 13FILES_fontconfig-utils = "${bindir}/*"
14 14
15PKG_fontconfig-utils=fontconfig-utils
16
15S = "${WORKDIR}/fontconfig-${PV}" 17S = "${WORKDIR}/fontconfig-${PV}"
16 18
17inherit autotools pkgconfig 19inherit autotools pkgconfig
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb b/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
index 660271d1c0..4a890ac32c 100755
--- a/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
+++ b/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
@@ -89,6 +89,8 @@ do_stage() {
89 for i in ${GNOME_VFS_PLATFORM_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/include/libgnomevfs/; done 89 for i in ${GNOME_VFS_PLATFORM_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/include/libgnomevfs/; done
90} 90}
91 91
92PACKAGES_DYNAMIC = "gnome-vfs-plugin-*"
93
92python populate_packages_prepend () { 94python populate_packages_prepend () {
93 print bb.data.getVar('FILES_gnome-vfs', d, 1) 95 print bb.data.getVar('FILES_gnome-vfs', d, 1)
94 96
diff --git a/openembedded/packages/gtk+/gtk+_2.6.7.bb b/openembedded/packages/gtk+/gtk+_2.6.7.bb
index bcfd2b598d..e4e93cacdd 100644
--- a/openembedded/packages/gtk+/gtk+_2.6.7.bb
+++ b/openembedded/packages/gtk+/gtk+_2.6.7.bb
@@ -64,7 +64,7 @@ fi
64 64
65} 65}
66 66
67PACKAGES_DYANMIC = "gdk-pixbuf-loader-* gtk-immodule-*" 67PACKAGES_DYNAMIC = "gdk-pixbuf-loader-* gtk-immodule-*"
68 68
69python populate_packages_prepend () { 69python populate_packages_prepend () {
70 import os.path 70 import os.path