summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-10-04 19:41:15 +0000
committerChris Lord <chris@openedhand.com>2005-10-04 19:41:15 +0000
commit94a3b01ef5e235d2507b8d81701e012098ce6c2c (patch)
tree152a312b68741c6053a03ea3b98f86ac39986302 /openembedded
parentebd747180e3a94e8312f5f0e7f58d3c208fd1b21 (diff)
downloadpoky-94a3b01ef5e235d2507b8d81701e012098ce6c2c.tar.gz
Update patch for latest svn
git-svn-id: https://svn.o-hand.com/repos/poky@121 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/eds/eds-dbus/no_gnomevfs.patch80
-rwxr-xr-xopenembedded/packages/eds/eds-dbus_svn.bb2
2 files changed, 39 insertions, 43 deletions
diff --git a/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch b/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch
index ad4c2572c3..e752a13696 100644
--- a/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch
+++ b/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch
@@ -1,7 +1,6 @@
1Index: addressbook/libebook/e-contact.c 1diff -urNd ../eds-dbus-1.4.0cvs20051004-r7/trunk/addressbook/libebook/e-contact.c trunk/addressbook/libebook/e-contact.c
2=================================================================== 2--- ../eds-dbus-1.4.0cvs20051004-r7/trunk/addressbook/libebook/e-contact.c 2005-10-04 18:08:14.000000000 +0100
3--- trunk/addressbook/libebook/e-contact.c (revision 206) 3+++ trunk/addressbook/libebook/e-contact.c 2005-10-04 19:11:37.000000000 +0100
4+++ trunk/addressbook/libebook/e-contact.c (working copy)
5@@ -27,7 +27,9 @@ 4@@ -27,7 +27,9 @@
6 #include <ctype.h> 5 #include <ctype.h>
7 #include <string.h> 6 #include <string.h>
@@ -12,66 +11,63 @@ Index: addressbook/libebook/e-contact.c
12 #include "e-contact.h" 11 #include "e-contact.h"
13 #include "e-book.h" 12 #include "e-book.h"
14 #include "e-name-western.h" 13 #include "e-name-western.h"
15@@ -418,8 +420,11 @@ 14@@ -419,7 +421,11 @@
16 e_vcard_attribute_add_param_with_value (attr,
17 e_vcard_attribute_param_new (EVC_ENCODING), 15 e_vcard_attribute_param_new (EVC_ENCODING),
18 "b"); 16 "b");
19- 17
20+#if 0 18+#if 0
21 mime_type = gnome_vfs_get_mime_type_for_data (photo->inlined.data, photo->inlined.length); 19 mime_type = gnome_vfs_get_mime_type_for_data (photo->inlined.data, photo->inlined.length);
22+#else 20+#else
23+ mime_type = "image/jpeg"; 21+ mine_type = "image/jpeg";
24+#endif 22+#endif
25 if (!strcmp (mime_type, "image/gif")) 23 if (!strcmp (mime_type, "image/gif"))
26 image_type = "GIF"; 24 image_type = "GIF";
27 else if (!strcmp (mime_type, "image/jpeg")) 25 else if (!strcmp (mime_type, "image/jpeg"))
28Index: configure.in 26diff -urNd ../eds-dbus-1.4.0cvs20051004-r7/trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c
29=================================================================== 27--- ../eds-dbus-1.4.0cvs20051004-r7/trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c 2005-10-04 18:08:34.000000000 +0100
30--- trunk/configure.in (revision 214) 28+++ trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c 2005-10-04 19:12:54.000000000 +0100
31+++ trunk/configure.in (working copy) 29@@ -29,7 +29,9 @@
32@@ -1180,7 +1180,7 @@
33
34 dnl --- evolution-addressbook flags
35
36-EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS gnome-vfs-2.0 "
37+EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS"
38
39 EVO_SET_COMPILE_FLAGS(EVOLUTION_ADDRESSBOOK, $EVOLUTION_ADDRESSBOOK_DEPS)
40 AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
41@@ -1188,7 +1188,7 @@
42
43 dnl --- evolution-calendar flags
44
45-EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 gnome-vfs-2.0 dbus-glib-1"
46+EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 dbus-glib-1"
47
48 EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, $EVOLUTION_CALENDAR_DEPS)
49 AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
50Index: calendar/libedata-cal-dbus/e-data-cal-factory.c
51===================================================================
52--- trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c (revision 206)
53+++ trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c (working copy)
54@@ -28,8 +28,9 @@
55 #include <dbus/dbus-protocol.h>
56 #include <dbus/dbus-glib.h> 30 #include <dbus/dbus-glib.h>
57 #include <dbus/dbus-glib-bindings.h> 31 #include <dbus/dbus-glib-bindings.h>
58-/**/ 32 /**/
59+#if 0 33+#if 0
60 #include <libgnomevfs/gnome-vfs.h> 34 #include <libgnomevfs/gnome-vfs.h>
61+#endif 35+#endif
62 #include <libedataserver/e-url.h> 36 #include <libedataserver/e-url.h>
63 #include <libedataserver/e-source.h> 37 #include <libedataserver/e-source.h>
64 #include <libedataserver/e-data-server-module.h> 38 #include <libedataserver/e-data-server-module.h>
65@@ -406,10 +407,12 @@ 39@@ -403,10 +405,12 @@
66 40
67 loop = g_main_loop_new (NULL, FALSE); 41 loop = g_main_loop_new (NULL, FALSE);
68 42
69+#if 0 43+#if 0
70 if (!gnome_vfs_init ()) { 44 if (!gnome_vfs_init ()) {
71 g_error ("Failed to initialise gnome-vfs"); 45 g_error ("Failed to initialise gnome-vfs");
72 exit (1);
73 } 46 }
47-
74+#endif 48+#endif
75 49+
76 g_print ("Launching EDataCalFactory\n"); 50 g_printerr ("Launching EDataCalFactory\n");
77 51
52 /* Obtain a connection to the session bus */
53diff -urNd ../eds-dbus-1.4.0cvs20051004-r7/trunk/configure.in trunk/configure.in
54--- ../eds-dbus-1.4.0cvs20051004-r7/trunk/configure.in 2005-10-04 19:14:49.000000000 +0100
55+++ trunk/configure.in 2005-10-04 19:12:07.000000000 +0100
56@@ -1195,7 +1195,7 @@
57
58 dnl --- evolution-addressbook flags
59
60-EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS gnome-vfs-2.0 "
61+EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS"
62
63 EVO_SET_COMPILE_FLAGS(EVOLUTION_ADDRESSBOOK, $EVOLUTION_ADDRESSBOOK_DEPS)
64 AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
65@@ -1203,7 +1203,7 @@
66
67 dnl --- evolution-calendar flags
68
69-EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 gnome-vfs-2.0 dbus-glib-1"
70+EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 dbus-glib-1"
71
72 EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, $EVOLUTION_CALENDAR_DEPS)
73 AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
diff --git a/openembedded/packages/eds/eds-dbus_svn.bb b/openembedded/packages/eds/eds-dbus_svn.bb
index 1e24e420e4..a0177df250 100755
--- a/openembedded/packages/eds/eds-dbus_svn.bb
+++ b/openembedded/packages/eds/eds-dbus_svn.bb
@@ -4,7 +4,7 @@ RDEPENDS = "gtk+ gconf db libiconv"
4MAINTAINER = "Chris Lord <chris@openedhand.com>" 4MAINTAINER = "Chris Lord <chris@openedhand.com>"
5DESCRIPTION = "Evolution database backend server" 5DESCRIPTION = "Evolution database backend server"
6PV = "1.4.0cvs${CVSDATE}" 6PV = "1.4.0cvs${CVSDATE}"
7PR = "r7" 7PR = "r8"
8 8
9SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \ 9SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
10 file://external_libdb.patch;patch=1 \ 10 file://external_libdb.patch;patch=1 \